Bug 4279 - "Set VBE Mode failed" with dualhead and different resolutions
Summary: "Set VBE Mode failed" with dualhead and different resolutions
Status: RESOLVED DUPLICATE of bug 643
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-28 09:37 UTC by Osma Ahvenlampi
Modified: 2006-05-08 04:45 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf used (5.65 KB, text/plain)
2005-08-28 09:39 UTC, Osma Ahvenlampi
no flags Details
Xorg log file (72.03 KB, text/plain)
2005-08-28 09:40 UTC, Osma Ahvenlampi
no flags Details
log (96.00 KB, text/plain)
2005-11-25 05:06 UTC, Osma Ahvenlampi
no flags Details
multihead log file (107.15 KB, text/plain)
2005-11-25 05:49 UTC, Osma Ahvenlampi
no flags Details
log with monitorlayout switched (44.17 KB, text/plain)
2005-11-26 02:35 UTC, Osma Ahvenlampi
no flags Details
log with fixedpipe (78.53 KB, text/plain)
2005-11-27 17:10 UTC, Osma Ahvenlampi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Osma Ahvenlampi 2005-08-28 09:37:50 UTC
On an Acer TravelMate 382TMi laptop, with i855GM graphics, use of dualhead has
recently started to work with Alan's test drivers. However, it still fails if
different resolution is desired on the external screen. This is what would
happen if possible modes are autodetected (LFP is 1024x768, and DDC will detect
1280x1024 capability on the VGA-port attached LCD monitor).

Apparently this might be a bug in Acer's VideoBIOS - only one BIOS version is
available for this machine (v 1.07).
Comment 1 Osma Ahvenlampi 2005-08-28 09:39:46 UTC
Created attachment 3081 [details]
xorg.conf used

FixedPipe, DevicePresence, DisplayInfo etc options do not change results.
Problem can be worked around by forcing 1024x768 resolution on both displays.
Comment 2 Osma Ahvenlampi 2005-08-28 09:40:13 UTC
Created attachment 3082 [details]
Xorg log file
Comment 3 Osma Ahvenlampi 2005-08-28 09:43:06 UTC
lspci information:

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02) (prog-if 00 [VGA])
        Subsystem: Acer Incorporated [ALI]: Unknown device 0037
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Memory at e0000000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at 1800 [size=8]
        Capabilities: [d0] Power Management version 1

00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)
        Subsystem: Acer Incorporated [ALI]: Unknown device 0037
        Flags: fast devsel
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Memory at e0080000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [d0] Power Management version 1

Comment 4 Alan Hourihane 2005-10-03 02:51:54 UTC
The fact is, that the Acer's VideoBIOS is restricting the modes when in dual
head. Probably related to bandwidth issues.

The ModeAttributes field shows as 0x9a when a mode cannot be supported. 0x9b is
what is expected when a mode is possible.

You'll notice that these values change in dual head, so Acer's BIOS is
restricting you to 1024x768 on both heads.
Comment 5 Alan Hourihane 2005-10-03 02:53:23 UTC
Whoops wrong report. Sorry about that.
Comment 6 Alan Hourihane 2005-10-03 03:00:09 UTC
Just uploaded 1.5.157 to see if I can fix this in the driver.

Can you try it and let me know ?
Comment 7 Alan Hourihane 2005-10-06 02:11:01 UTC
Can you try my latest test driver and upload a new log file ??
Comment 8 Osma Ahvenlampi 2005-10-27 05:00:09 UTC
The Acer is currently in the shop for fan repairs. I'll test when I get it back.
However, I can state that on my substitute machine, a Fujitsu Siemens laptop
also based on Centrino platform, I can use dual head with 1400x1050 on the
laptop display and 1280x1024 on the external display (via the VGA port) without
problems, even with an older driver build.

As for bandwidth, under Windows the Acer is capable of different modes on the
two displays.
Comment 9 Alan Hourihane 2005-10-27 08:37:30 UTC
Right. I know (or at least have an idea) where the problem is, so I'm just
trying to find if it's possible to work around the problems in the driver.
Comment 10 Osma Ahvenlampi 2005-11-25 05:06:25 UTC
Created attachment 3893 [details]
log

Got the Acer back. With a test driver downloaded two hours ago, the machine
freezes on virtual console change if VBERestore, DevicePresence and
CheckDevices are turned on. With them commented out, the machine is stable.
However, I can not get 1280x1024, or in fact a "good" 1024x768 on the external
display - I only get a flattened 1024x768 display and my monitor complains
"Input signal out of range".

In single head mode, I believe the driver thinks its programming 1280x1024 on,
but the display remains blank.
Comment 11 Osma Ahvenlampi 2005-11-25 05:49:38 UTC
Created attachment 3894 [details]
multihead log file

Found that by commenting out VBERestore and DevicePresence, but retaining the
CheckDevices option, I can get a stable 1280x1024 on a single head (the
external screen). However, dualhead still fails. Hopefully a trained eye can
read the log file better than I (disregard the earlier log).
Comment 12 Alan Hourihane 2005-11-25 23:43:57 UTC
O.k. 

Can you try this for the MonitorLayout command and post another log.

Option "MonitorLayout" "LFP,CRT"
Comment 13 Osma Ahvenlampi 2005-11-26 02:35:12 UTC
Created attachment 3906 [details]
log with monitorlayout switched

Won't start at all with MonitorLayout "LFP,CRT".
Comment 14 Alan Hourihane 2005-11-26 02:48:58 UTC
o.k. put it back to CRT,LFP and add

Option "FixedPipe" "B"

and post another log.
Comment 15 Osma Ahvenlampi 2005-11-27 17:10:10 UTC
Created attachment 3918 [details]
log with fixedpipe

not sure which head was supposed to be FixedPipe "B", but here's one with it
different from the default. Both ways it dies with the same error if the modes
list for the external head includes 1280x1024 or I leave the modes list for
autodetection. Initializes correctly if I force modes to 1024x768 only.

My home monitor doesn't mind the refresh rates set by this driver, and the
image on the external display has correct proportions with the same config file
that creates a flattened image on my work monitor.
Comment 16 Jos Delbar 2006-01-23 12:17:24 UTC
I have a similar problem with my video BIOS restricting a dual head setup with  
a CRT resolution of 1280x1024 and a LFP resolution of 1024x768. Dual head with  
both screens at 1024x768 works fine. As always, in Windows this setup works 
using the Intel driver. 
  
If you're still attempting to work around this in the i810 driver, I'm 
available for testing. It would be great if you could fix this "bug". 
Comment 17 Alan Hourihane 2006-05-08 20:51:58 UTC
Marking as duplicate of 643 because the new modesetting branch should deal with
all vbios resolution issues.

*** This bug has been marked as a duplicate of 643 ***
Comment 18 Osma Ahvenlampi 2006-05-08 21:45:28 UTC
ooohh.. by any chance could you make a build of the modesetting branch available
somewhere for xorg 7.0? I'd be more than happy to test it, but not sure I can
build it.. never had that much luck building xfree and never tried to with xorg.
I've nearly given up on being able to utilize dualhead with this machine..


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.