Bug 43359 - texture3D failed to link in vertex shader
texture3D failed to link in vertex shader
Status: RESOLVED DUPLICATE of bug 29522
Product: Mesa
Classification: Unclassified
Component: glsl-compiler
All Linux (All)
: medium normal
Assigned To: Ian Romanick
Depends on:
  Show dependency treegraph
Reported: 2011-11-29 19:25 UTC by Ouping Zhang
Modified: 2011-12-23 17:35 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

texture3D test case (197 bytes, text/plain)
2011-11-29 19:25 UTC, Ouping Zhang

Note You need to log in before you can comment on or make changes to this bug.
Description Ouping Zhang 2011-11-29 19:25:46 UTC
Created attachment 53963 [details]
texture3D test case

System Environment:
Kernel:         (drm-intel-next)9a10f401a401ca69c6537641c8fc0d6b57b5aee8
Libdrm:         (master)2.4.27-3-g37ccce5e390a9d757474920f488cafa1cf89854a
Xserver:        (master)xorg-server-

Bug detailed description:
texture3D failed to link in vertex shader, error: Too many vertex shader texture samplers.
the case at the attached can reproduce this issue.
Comment 1 Ouping Zhang 2011-12-22 23:15:06 UTC
System Environment:
Libdrm:         (master)2.4.29-3-gef20301a11afae50bfe127002913dbd0b81ddccc
Mesa:           (master)f1d89638c02afafbf82ef657cd6ba9965dad6738
Xserver:        (master)xorg-server-

with the latest mesa to verify, the issue can't be reproduced.
Comment 2 Anuj Phogat 2011-12-23 13:25:55 UTC
Similar to Bug 43360

Verified the functionality using following shaders:
static const char *vertShaderText =
        "uniform sampler3D tex3D;\n"
        "varying vec4 texcolor;\n"
        "void main()\n"
        " gl_Position = gl_ModelViewProjectionMatrix * gl_Vertex;\n"
        " texcolor  = texture3D(tex3D, gl_MultiTexCoord0.xyz);\n"

static const char *fragShaderText =
        "varying vec4 texcolor;\n"
        "void main()\n"
        " gl_FragColor = vec4(texcolor.xyz, 1.0);\n"

Seems like nothing need to be done for this bug.
Comment 3 Ian Romanick 2011-12-23 17:35:01 UTC
All of bug #29522, bug #43359, and bug #43360 should be fixed by the recent addition of vertex texture support to the i965 driver.

*** This bug has been marked as a duplicate of bug 29522 ***