Bug 43372 - Tests in Gabble openssl are failing to build
Summary: Tests in Gabble openssl are failing to build
Status: NEW
Alias: None
Product: Telepathy
Classification: Unclassified
Component: gabble (show other bugs)
Version: git master
Hardware: Other All
: medium normal
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-30 05:33 UTC by Alvaro Soliverez
Modified: 2011-11-30 08:43 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alvaro Soliverez 2011-11-30 05:33:08 UTC
gabble openssl build fails to build the tests.

It's building with the following options: 

../configure --disable-gtk-doc --with-tls=openssl

When running make check, it fails with the following error:
make[5]: Entering directory `/var/lib/buildbot/telepathy/gabble-openssl-i386/build/build/tests/twisted'
make[5]: *** No rule to make target `tls/*', needed by `check-TESTS'.  Stop.

Here's the link to the failed build: http://buildbot.telepathy.im/builders/Gabble%20-%20openssl%20-%20i386/builds/142/steps/Tests/logs/stdio
Comment 1 Nicolas Dufresne 2011-11-30 08:43:58 UTC
I know wocky SSL support is written for an older version of OpenSSL and may still need porting. What is the OpenSSL version on the build bot ?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.