Bug 4374 - [855GM] Incorrect painting in crack-attack
[855GM] Incorrect painting in crack-attack
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
6.5
x86 (IA32) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
: 9909 (view as bug list)
Depends on:
Blocks: 16029
  Show dependency treegraph
 
Reported: 2005-09-06 13:03 UTC by Albert Astals Cid
Modified: 2012-03-02 17:44 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Strange painting in crack attack (148.32 KB, image/png)
2005-09-06 13:05 UTC, Albert Astals Cid
Details
Hacked image to describe what i should see (146.65 KB, image/png)
2005-09-06 13:25 UTC, Albert Astals Cid
Details
rendering error on i865 with mesa 6.5.3 in 1280x1024 game mode (129.95 KB, image/png)
2007-08-04 01:21 UTC, Brice Goglin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Astals Cid 2005-09-06 13:03:36 UTC
Hi, since i got my centrino laptop with i855 graphics card i've been 
experiencing problems with crack-attack, today i've upgraded to lastest xorg 
release (6.9 RC0) and i've seen the problems are still there so i'm reporting 
the problem here so you know it exists. 
 
The problem is that there is some weird painting in crack-attack, i'll upload a 
screenshot showing the problem. 
 
Also sometimes it crashes while it never crashes on my workstation (that uses 
fbdev driver iirc) so it seems a graphics card problem as the distro is the 
same. 
 
If there is anything you need to know or need that i do some patching testing 
tellme and i'll try to do it.
Comment 1 Albert Astals Cid 2005-09-06 13:05:47 UTC
Created attachment 3184 [details]
Strange painting in crack attack

See that the upper red bars are cut in diagonal when they should not.
Comment 2 Alan Hourihane 2005-09-06 13:17:53 UTC
I'm not sure I can see the problem.

Can you also upload a screenshot of what you expect with the fbdev driver so I
can compare the images ?
Comment 3 Alan Hourihane 2005-09-06 13:19:01 UTC
Can you also attach the output of 'glxinfo'

Comment 4 Albert Astals Cid 2005-09-06 13:22:23 UTC
name of display: :0.0 
display: :0  screen: 0 
direct rendering: Yes 
server glx vendor string: SGI 
server glx version string: 1.2 
server glx extensions: 
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig 
client glx vendor string: SGI 
client glx version string: 1.4 
client glx extensions: 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory, 
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method, 
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control, 
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group 
GLX extensions: 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory, 
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group 
OpenGL vendor string: Tungsten Graphics, Inc 
OpenGL renderer string: Mesa DRI Intel(R) 852GM/855GM 20050225 x86/MMX/SSE2 
OpenGL version string: 1.3 Mesa 6.3.1 
OpenGL extensions: 
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture, 
    GL_ARB_point_parameters, GL_ARB_texture_border_clamp, 
    GL_ARB_texture_compression, GL_ARB_texture_cube_map, 
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine, 
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3, 
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_rectangle, 
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object, 
    GL_ARB_vertex_program, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra, 
    GL_EXT_blend_color, GL_EXT_blend_equation_separate, 
    GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract, 
    GL_EXT_clip_volume_hint, GL_EXT_cull_vertex, GL_EXT_compiled_vertex_array, 
    GL_EXT_convolution, GL_EXT_copy_texture, GL_EXT_draw_range_elements, 
    GL_EXT_fog_coord, GL_EXT_histogram, GL_EXT_multi_draw_arrays, 
    GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_polygon_offset, 
    GL_EXT_rescale_normal, GL_EXT_secondary_color, 
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_subtexture, 
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp, 
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine, 
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic, 
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle, 
    GL_EXT_vertex_array, GL_3DFX_texture_compression_FXT1, 
    GL_APPLE_client_storage, GL_APPLE_packed_pixels, 
    GL_ATI_blend_equation_separate, GL_IBM_rasterpos_clip, 
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate, 
    GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_MESA_window_pos, 
    GL_NV_blend_square, GL_NV_light_max_exponent, GL_NV_texture_rectangle, 
    GL_NV_texgen_reflection, GL_NV_vertex_program, GL_NV_vertex_program1_1, 
    GL_OES_read_format, GL_SGI_color_matrix, GL_SGI_color_table, 
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp, 
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays 
glu version: 1.3 
glu extensions: 
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess 
 
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav 
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat 
---------------------------------------------------------------------- 
0x23 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None 
0x24 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None 
0x25 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  8  0  0  0  0  0 0 Slow 
0x26 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  8  0  0  0  0  0 0 Slow 
0x27 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16  0  0 0 Slow 
0x28 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16  0  0 0 Slow 
0x29 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 Slow 
0x2a 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  8 16 16 16  0  0 0 Slow 
0x2b 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None 
0x2c 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None 
0x2d 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  8  0  0  0  0  0 0 Slow 
0x2e 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  8  0  0  0  0  0 0 Slow 
0x2f 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16  0  0 0 Slow 
0x30 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16  0  0 0 Slow 
0x31 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 Slow 
0x32 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  8 16 16 16  0  0 0 Slow 
 
Comment 5 Albert Astals Cid 2005-09-06 13:25:32 UTC
Created attachment 3185 [details]
Hacked image to describe what i should see

As it is difficult to have the same piece situation in the game (is a
tetris-like game) i've painted with a white outline how big the red pieces on
the top should be.
Comment 6 Alan Hourihane 2005-11-19 02:12:20 UTC
Does this still happen with 6.9 RC2 ?
Comment 7 Albert Astals Cid 2005-11-20 03:05:21 UTC
Hi, Mandriva has still not packaged RC2 for cooker, i'll say something as soon 
as they update their package. 
Comment 8 Albert Astals Cid 2005-12-05 05:24:28 UTC
Still happens with package xorg-x11-6.9-1.cvs20051129 (i guess that should be 
RC2 or higher) 
Comment 9 Daniel Stone 2007-02-27 01:27:54 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 10 Gordon Jin 2007-03-14 19:24:32 UTC
The bug priority was upgraded (P2->high) with the bugzilla configuration change.
I'm Changing the priority back to the normal one.
Sorry for the spam.
Comment 11 Brice Goglin 2007-08-04 01:01:58 UTC
*** Bug 9909 has been marked as a duplicate of this bug. ***
Comment 12 Brice Goglin 2007-08-04 01:21:34 UTC
Created attachment 10988 [details]
rendering error on i865 with mesa 6.5.3 in 1280x1024 game mode

followup for what was in #9909: this still happens with mesa 6.5.[123] (at least on i865).

I see the same rendering problems that Albert's screenshot when playing in 640x480 game mode, i.e.  a black triangle covere the top-right corner. But in 1280x1024 game-mode, this triangle is not black, it is kind of blurry, as shown in this new screenshot.

Note that XxY game mode is basically the window size, I am not changing the actual monitor resolution (1600x1200 is all the above).
Comment 13 Albert Astals Cid 2007-10-07 12:04:55 UTC
i've updated to intel driver 2.1.1 and Mesa 7.0.1 and the error is still there
Comment 14 Gordon Jin 2008-03-24 22:38:13 UTC
Can you try this with newer driver, i.e. 7.0.3, or better master branch?
Comment 15 Brice Goglin 2008-03-25 10:39:00 UTC
Still happens the same with 7.0.3-rc2 on my i865 (exactly as on the screenshot for comment #12). There is no way I can test mesa master branch on this server. But it's so easy to reproduce this bug that you should be able to do it yourself. Just start a game, play a bit and let blocks fill the entire screen (either regular small blocks or big red blocks). You should see unexpected black painting cover the top right of the window.
Comment 16 Gordon Jin 2008-05-05 01:16:56 UTC
Yes, I can confirm this bug on 855GM, with either 7_0_branch or master. 
But it works fine on my G33 and 965.
Comment 17 Michael Fu 2008-06-30 00:46:20 UTC
(In reply to comment #16)
> Yes, I can confirm this bug on 855GM, with either 7_0_branch or master. 
> But it works fine on my G33 and 965.
> 

haihao, sounds like gordon can confirm this on machines we have... I'll set a dependency with bug# 16029...thanks.
Comment 18 Brice Goglin 2009-04-15 22:22:09 UTC
Still happens with Xserver 1.6.1, Intel 2.7.0 and Mesa 7.4 on i865.
Comment 19 Eugeni Dodonov 2011-09-08 15:55:57 UTC
This issue is affecting a hardware component which is not being actively worked on anymore.

Moving the assignee to the dri-devel list as contact, to give this issue a better coverage.
Comment 20 Eric Anholt 2012-03-02 17:44:20 UTC
I seem to recall testing this on my 865 about a year ago and seeing the bug, but today the bug doesn't show up any more.  So I'm tentatively going to mark this fixed, though I don't have a commit identified that fixed it :(