Bug 4383 - Weird Characters (\x00 ?) crash XOrg
Summary: Weird Characters (\x00 ?) crash XOrg
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords: want-backtrace
Depends on:
Blocks:
 
Reported: 2005-09-07 06:28 UTC by Danny Brain
Modified: 2006-06-03 11:29 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Danny Brain 2005-09-07 06:28:29 UTC
When strange unreadable characters are shown in aMSN Xorg crashes.
This happens when someone tries to send a file, because of the new MSN 7
protocol it appends strange characters to the end of the filename.
When copied and pasted they are shown as \x00, but moving the chat window at all
when these characters are in it causes Xorg to crash out completely.

Can't give much more information than that. 
The Xorg.0.log shows no errors that explain anything.
If there's a good way to find a full list of debug info I'd be happy to test it :)
Comment 1 Alan Coopersmith 2005-10-03 00:25:18 UTC
Recent Xorg CVS releases and snapshots print stack backtraces to 
/var/log/Xorg.0.log on Linux & Solaris when Xorg crashes.  If you
can get one of those, it would help narrow down the cause of this
bug.
Comment 2 Erik Andren 2006-04-22 23:47:11 UTC
Can you still reproduce the problem using a more modern version of xorg?
Comment 3 Erik Andren 2006-06-03 11:29:41 UTC
Closing due to the lack of activity from the bug poster.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.