Bug 43971 - Support using systemd for session tracking
Summary: Support using systemd for session tracking
Status: RESOLVED DUPLICATE of bug 43339
Alias: None
Product: PolicyKit
Classification: Unclassified
Component: daemon (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: David Zeuthen (not reading bugmail)
QA Contact: David Zeuthen (not reading bugmail)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-19 19:40 UTC by Matthias Clasen
Modified: 2012-01-03 08:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Add systemd support (33.04 KB, patch)
2011-12-19 19:40 UTC, Matthias Clasen
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Clasen 2011-12-19 19:40:44 UTC
Created attachment 54588 [details] [review]
Add systemd support

Here is a (untested) patch that adds a --enable-systemd configure option.
When it is used, polkit is using systemd for session tracking instead of
ConsoleKit.
Comment 1 David Zeuthen (not reading bugmail) 2011-12-20 06:55:49 UTC
Thanks for the patch, it looks like a great start. We already have a bug for this effort so closing this one as a duplicate. Thanks!

*** This bug has been marked as a duplicate of bug 43339 ***
Comment 2 Lennart Poettering 2011-12-20 07:07:27 UTC
From a quick looks the patch looks all good to me!
Comment 3 David Zeuthen (not reading bugmail) 2012-01-03 08:31:42 UTC
Committed, thanks, and then I committed a patch on to top to automatically use systemd if available:

 http://cgit.freedesktop.org/PolicyKit/commit/?id=2027302e803a9569a370b429a475dae5ef8afe34
 http://cgit.freedesktop.org/PolicyKit/commit/?id=ee3abef68386421b4711fc15d14be91e30134bc6

Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.