Bug 43985 - Build regression on ia64 between 1.11.2.902 and 1.11.99.1
Summary: Build regression on ia64 between 1.11.2.902 and 1.11.99.1
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xorg (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: xserver-1.12
  Show dependency treegraph
 
Reported: 2011-12-20 09:18 UTC by Cyril Brulebois
Modified: 2012-03-24 11:49 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyril Brulebois 2011-12-20 09:18:02 UTC
Linking Xorg fails on ia64:
 - for 1.11.99.1: https://buildd.debian.org/status/fetch.php?pkg=xorg-server&arch=ia64&ver=2%3A1.11.99.1-1&stamp=1324099563
 - for 1.11.99.2: https://buildd.debian.org/status/fetch.php?pkg=xorg-server&arch=ia64&ver=2%3A1.11.99.2-1&stamp=1324400792

Log excerpt:

/bin/bash ../../libtool  --tag=CC   --mode=link gcc -std=gnu99 -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wformat=2 -Wold-style-definition -Wdeclaration-after-statement -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/usr/include/pixman-1 -I/usr/include/freetype2   -I../../../include -I../../include -I../../../Xext -I../../../composite -I../../../damageext -I../../../xfixes -I../../../Xi -I../../../mi -I../../../miext/sync -I../../../miext/shadow  -I../../../miext/damage -I../../../render -I../../../randr -I../../../fb -fvisibility=hidden  -DHAVE_XORG_CONFIG_H -fvisibility=hidden   -DXF86PM   -g -O2 -fPIE -Wformat -Wformat-security -Werror=format-security -export-dynamic -fPIE -pie -Wl,-Bsymbolic -o Xorg sdksyms.o ../../dix/libmain.la ../../dix/libdix.la ../../mi/libmi.la ../../os/libos.la loader/libloader.la common/libcommon.la os-support/libxorgos.la parser/libxf86config_internal.la dixmods/libdixmods.la modes/libxf86modes.la ramdac/libramdac.la ddc/libddc.la i2c/libi2c.la dixmods/libxorgxkb.la ../../composite/libcomposite.la ../../xfixes/libxfixes.la ../../Xext/libXextbuiltin.la ../../glx/libglx.la ../../randr/librandr.la ../../render/librender.la ../../damageext/libdamageext.la ../../miext/sync/libsync.la ../../miext/damage/libdamage.la ../../miext/shadow/libshadow.la ../../Xi/libXi.la ../../xkb/libxkb.la ../../mi/libmi.la ../../os/libos.la -lpciaccess    -lpthread   -lpixman-1 -lXfont -lXau -lXdmcp    -laudit -lm  -lrt -laudit -lm  -lrt
libtool: link: gcc -std=gnu99 -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wformat=2 -Wold-style-definition -Wdeclaration-after-statement -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/usr/include/pixman-1 -I/usr/include/freetype2 -I../../../include -I../../include -I../../../Xext -I../../../composite -I../../../damageext -I../../../xfixes -I../../../Xi -I../../../mi -I../../../miext/sync -I../../../miext/shadow -I../../../miext/damage -I../../../render -I../../../randr -I../../../fb -fvisibility=hidden -DHAVE_XORG_CONFIG_H -fvisibility=hidden -DXF86PM -g -O2 -fPIE -Wformat -Wformat-security -Werror=format-security -fPIE -pie -Wl,-Bsymbolic -o Xorg sdksyms.o -Wl,--export-dynamic  ../../dix/.libs/libmain.a ../../dix/.libs/libdix.a loader/.libs/libloader.a common/.libs/libcommon.a -ludev os-support/.libs/libxorgos.a parser/.libs/libxf86config_internal.a dixmods/.libs/libdixmods.a modes/.libs/libxf86modes.a ramdac/.libs/libramdac.a ddc/.libs/libddc.a i2c/.libs/libi2c.a dixmods/.libs/libxorgxkb.a ../../composite/.libs/libcomposite.a ../../xfixes/.libs/libxfixes.a ../../Xext/.libs/libXextbuiltin.a ../../glx/.libs/libglx.a ../../randr/.libs/librandr.a ../../render/.libs/librender.a ../../damageext/.libs/libdamageext.a ../../miext/sync/.libs/libsync.a ../../miext/damage/.libs/libdamage.a ../../miext/shadow/.libs/libshadow.a ../../Xi/.libs/libXi.a ../../xkb/.libs/libxkb.a ../../mi/.libs/libmi.a ../../os/.libs/libos.a -lgcrypt -ldl -lpciaccess -lpthread -lpixman-1 -lXfont -lXau -lXdmcp -laudit -lm -lrt
sdksyms.o:(.data.rel+0x27e0): undefined reference to `outl'
collect2: ld returned 1 exit status
make[5]: *** [Xorg] Error 1

I hope I'll be able to get access to a porter machine with the appropriate packages (I'll have to mix stuff from unstable and experimental so that might be a bit difficult) to try and track that down.

Mraw,
KiBi.
Comment 1 Cyril Brulebois 2011-12-20 10:12:43 UTC
Wild guess:

commit aa0bfb0f133481c57762012e8e30c05ffa151423
Author: Adam Jackson <ajax@redhat.com>
Date:   Fri Jan 7 16:57:15 2011 -0500

    linux: Remove ia64 domain I/O support code
    
    pciaccess handles this now.
    
    Reviewed-by: Jeremy Huddleston <jeremyhu@apple.com>
    Tested-by: Jeremy Huddleston <jeremyhu@apple.com>
    Signed-off-by: Adam Jackson <ajax@redhat.com>
    Reviewed-by: Jamey Sharp <jamey@minilop.net>
Comment 2 Cyril Brulebois 2011-12-22 18:42:01 UTC
Guilty commit confirmed by a git bisect on a Debian ia64 porter box (merulo.debian.org).
Comment 3 Cyril Brulebois 2011-12-29 18:44:48 UTC
v2 @ http://patchwork.freedesktop.org/patch/8528/
Comment 4 Jeremy Huddleston Sequoia 2012-03-24 11:49:27 UTC
commit 644efb43e0639af648dd46d9729c2cabd9511238
Author: Cyril Brulebois <kibi@debian.org>
Date:   Fri Dec 30 02:34:36 2011 +0000

    linux/ia64: Fix regression after domain I/O support code removal.
    
    Side effect of aa0bfb0f133481c57762012e8e30c05ffa151423:
    |   CCLD   Xorg
    | sdksyms.o:(.data.rel+0x27d8): undefined reference to `outl'
    | collect2: ld returned 1 exit status
    
    Since the linux/ia64 domain I/O support code got removed in that
    commit, there's no reason to keep on declaring those functions
    (inb, inl, inw, outb, outl, outw).
    
    Bugzilla: https://bugs.freedesktop.org/43985
    
    Reviewed-by: Jeremy Huddleston <jeremyhu@apple.com>
    Signed-off-by: Cyril Brulebois <kibi@debian.org>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.