Bug 44038 - some 3D wine apps no longer work (bisected)
Summary: some 3D wine apps no longer work (bisected)
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/evdev (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL:
Whiteboard: 2012BRB_Reviewed
Keywords: regression
Depends on:
Blocks: xserver-1.12 xserver-1.13
  Show dependency treegraph
 
Reported: 2011-12-21 20:47 UTC by Jos van Wolput
Modified: 2015-03-26 16:14 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jos van Wolput 2011-12-21 20:47:05 UTC
Some 3D wine apps (Dream Aquarium, Free Desktop Fish Screensaver) no longer work
when using xserver git version (or v.1.11.99.2).
Although the apps are running in the background, they don't appear on the screen.

I did bisect xserver:
The latest working version is xserver-57cd32..., 2011-10-03, xfree86/modes:
Make cursor position transform a helper function, Aaron Plattner.
The bug seems to be in xserver-f5d50b4..., 2011-10-03, Merge remote-tracking branch 'whot/next', Keith Packard.

These wine apps work without problems using xserver-57cd32 or any previous version.

I am using kernel 3.1.0-5.dmz.1-liquorix-amd64, Debian/Sid and the latest git versions of drm, libX11, libXi, mesa, xserver, xf86-video-ati and xf86-input evdev, all of which I regularly update!
Comment 1 Jeremy Huddleston Sequoia 2012-01-02 20:45:57 UTC
I really don't see how input changes could cause this, but...

The commit that you are blaming with your git bisect is a merge.  Can you please bisect that merge to see what commit within the merge caused the issue.
Comment 2 Jos van Wolput 2012-01-02 22:02:35 UTC
(In reply to comment #1)
> I really don't see how input changes could cause this, but...
> 
> The commit that you are blaming with your git bisect is a merge.  Can you
> please bisect that merge to see what commit within the merge caused the issue.

Could you please tell me exactly where to find the remote-tracking branch 'whot/next', I'm sorry I can't find that merge.
Comment 3 Peter Hutterer 2012-01-02 22:26:15 UTC
If you run git log on that commit, it shows you the two branches that got merged together:

commit afb1fe695d197187a301c19863a128a65389b15c
Merge: 7fb4bef c7163fd
Author: Keith Packard <keithp@keithp.com>
Date:   Mon Sep 26 20:24:15 2011 -0700

    Merge remote-tracking branch 'whot/next'


The second line means that c7163fd was merged into 7fb4bef, so whot/next at that time was c7163fd. That's your starting point.
Comment 4 Jos van Wolput 2012-01-03 01:40:15 UTC
(In reply to comment #3)
> 
> The second line means that c7163fd was merged into 7fb4bef, so whot/next at
> that time was c7163fd. That's your starting point.

I have found the merge that causes the issue!
The wine app runs with xserver-c7163fd (2011-09-27) but not with the next one 'whot/next' xserver-524e544, Add #include "inpututils.h" to xkbAccessX.c for init_device_event, 2011-10-02, merged into f5d50b4...
Comment 5 Jos van Wolput 2012-01-07 21:12:52 UTC
I was wrong blaming xserver for this wine regression!
When using xf86-input-evdev-2.6.0 together with the latest git versions of
xserver, xf86-video-ati, libX11 and mesa the wine apps are running fine, the issue occurs when using the git version of xf86-input-evdev or version 2.6.99.901.

I am now doing a bisect of xf86-input-evdev to pinpoint which commit causes
the regression.
Comment 6 Jos van Wolput 2012-01-07 23:13:36 UTC
The first git version of input-evdev causing the wine regression is
xf86-input-evdev-b450efd..., committer Peter Hutterer, 2011-11-09,Support smooth scrolling on REL_WHEEL, REL_HWHEEL and REL_DIAL.

No issue with its parent ffe35b6c2..., Exit axis labelling if axes are neither rel nor abs,
Also no issue with the preceding eede8ccf..., Don't crop long value from EvdevBitIsSet.
Comment 7 Jos van Wolput 2012-01-08 00:41:18 UTC
Additional info:
When the wine graphics configuration is set to emulate a virtual desktop the apps
run without problem, the issue only occurs when the virtual desktop emulation
is not set.
Comment 8 Peter Hutterer 2012-01-08 18:05:25 UTC
Please double-check this by rebuilding the stack with the evdev driver before/after the commit. I really don't know how any input driver change should stop wine from displaying applications. This sounds too weird.
Comment 9 Jos van Wolput 2012-01-09 04:19:58 UTC
(In reply to comment #8)
Hi Peter,

I did a new bisect of xserver.
The first combination of xserver and input-evdev that cause the issue really is
xserver-3304bbf..., Input: Add smooth-scrolling support to GetPointerEvents
and xf86-input-evdev-b450efd..., Support smooth scrolling on REL_WHEEL, REL_HWHEEL and REL_DIAL.

No problem running the wine app with the previous commits of xserver and input-evdev.

Rebuilding did not make any difference, I double-checked before and after the commit, the issue is always reproducible.
Comment 10 Jos van Wolput 2012-01-11 20:22:35 UTC
(In reply to comment #8)

When the wine app is started with the usb mouse unplugged then it starts running.
Comment 11 Peter Hutterer 2012-01-11 20:50:38 UTC
hmm, tested DreamAquarium today and it seems to start fine. The keyboard works, though the mouse jumps to 0/0 on startup and is then trapped on the left edge of the screen. Which window manager do you use?
Comment 12 Jos van Wolput 2012-01-11 22:27:36 UTC
(In reply to comment #11)
>Which window manager do you use?

I am using the latest git version of xserver, with xfce4 and xfwm4 (4.8.3-1), logged in with lightdm, from Debian/Sid.

Running wine from a terminal it stops at:
---
wine ./Dream_Aquarium.scr
err:winedevice:ServiceMain driver L"DritekPortIO" failed to load
err:ntdll:RtlDeleteResource Deleting active MRSW lock (0x1125c4), expect failure
wine: Unhandled page fault on read access to 0x0c45536d at address 0x7bc347b2 (thread 0016), starting debugger...
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "Gallium 0.4 on AMD RS780", version "1.4 (2.1 Mesa 8.0-devel (git-459a444))").
fixme:win:EnumDisplayDevicesW ((null),0,0x6ff5fc,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x6ff5fc,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x6ff5fc,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x6ff90c,0x00000000), stub!
(always stopping here!
When running it shows a lot of fixme:
fixme:wincodecs:JpegDecoder_Frame_GetResolution (0x15afec,0x6fedc8,0x6fedc0): stub)
---

I also tried Blackbox wm, getting the same issue!
With blackbox I had to restart login, with xfwm4 I have to switch to another workspace and stop the terminal or kill the app.

When the app is running (with input-evdev 2.6.0) the mouse pointer only appears
after a right click showing a menu, after closing this menu, the pointer again
disappears. It doesn't seem to be trapped on the edge of the screen.
Comment 13 Peter Hutterer 2012-06-14 23:06:57 UTC
any chance this has been accidentally fixed by the 1.12 release?
Comment 14 Jos van Wolput 2012-06-15 00:50:13 UTC
(In reply to comment #13)
> any chance this has been accidentally fixed by the 1.12 release?

I am now using the git xserver 1.12.99 and input-evdev 2.7.0 but
wine ./Dream_Aquarium.scr still no longer starts working when the
usb mouse is plugged in.
Comment 15 Matt Dew 2013-03-10 21:49:27 UTC
1.14.0 was just released. Any chance this bug has been fixed?

Jos, can you try it and let us know?
Comment 16 Jos van Wolput 2013-03-15 11:53:42 UTC
(In reply to comment #15)
> 1.14.0 was just released. Any chance this bug has been fixed?
> 
> Jos, can you try it and let us know?

I'm sorry, I'm no longer using this wine apps.
Comment 17 Jos van Wolput 2015-03-26 16:14:40 UTC
Fixed, using xorg-server-1.16.4 and wine 1.7.38


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.