Bug 44156 - [GM45] failure to control backlight
Summary: [GM45] failure to control backlight
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Jani Nikula
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 39962 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-26 11:29 UTC by alan.zimm
Modified: 2017-07-24 23:03 UTC (History)
9 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg with drm.debug=0x06 showing problem (123.45 KB, text/plain)
2011-12-26 11:29 UTC, alan.zimm
no flags Details
Xorg.0.log (39.05 KB, text/x-log)
2011-12-26 11:42 UTC, alan.zimm
no flags Details
dmesg from earlier boot showing dri problem (51.83 KB, text/x-log)
2011-12-26 11:50 UTC, alan.zimm
no flags Details
dmesg 2012-01-01 (52.38 KB, text/plain)
2012-01-01 11:00 UTC, Jonathan Nieder
no flags Details
Xorg.0.log 2012-01-01 (36.47 KB, text/plain)
2012-01-01 11:01 UTC, Jonathan Nieder
no flags Details
/sys/kernel/debug/dri/0/i915_error_state 2012-01-01 (1.31 MB, text/plain)
2012-01-01 11:02 UTC, Jonathan Nieder
no flags Details
dmesg output with drm_debug=0xe (667.53 KB, text/plain)
2012-04-29 01:52 UTC, alan.zimm
no flags Details
intel_gpu_dump.backlight_on.txt (1.43 MB, text/plain)
2012-06-07 01:11 UTC, alan.zimm
no flags Details
intel_gpu_dump.backlight_off.txt (1.44 MB, text/plain)
2012-06-07 01:11 UTC, alan.zimm
no flags Details
intel_reg_dump.on.txt (13.44 KB, text/plain)
2012-06-07 01:46 UTC, alan.zimm
no flags Details
intel_reg_dump.off.txt (13.44 KB, text/plain)
2012-06-07 01:46 UTC, alan.zimm
no flags Details
intel_reg_dump.on.v2.txt (13.52 KB, text/plain)
2012-06-07 12:51 UTC, alan.zimm
no flags Details
intel_reg_dump.off.v2.txt (13.52 KB, text/plain)
2012-06-07 12:51 UTC, alan.zimm
no flags Details
always use LBPC 0xff in combination mode (1.86 KB, patch)
2012-09-10 12:46 UTC, Jani Nikula
no flags Details | Splinter Review
lspci info from bug reporter... (4.02 KB, text/plain)
2012-12-18 22:02 UTC, Rodrigo Vivi
no flags Details
drm/i915: add quirk to invert brightness on Packard Bell NCL20 (1.30 KB, patch)
2013-01-22 10:48 UTC, Jani Nikula
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description alan.zimm 2011-12-26 11:29:11 UTC
Created attachment 54829 [details]
dmesg with drm.debug=0x06 showing problem

[Cross-reference: Debian bug 627372 at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=627372]

On boot up, the screen turns black, and stays that way. The system is
otherwise useable, if I ssh in to it, and also allows me to log in from gdm.

I am running Debian testing on a Packard Bell laptop

System environment:
--chipset: GM45 (via dmesg)
--system architecture: i686
--xserver-xorg-video-intel version: debian 2:2.17.0-1
   From Xorg.0.log
[    35.267] (II) Module intel: vendor="X.Org Foundation"
[    35.267] 	compiled for 1.11.1.902, module version = 2.17.0
[    35.267] 	Module class: X.Org Video Driver
[    35.267] 	ABI class: X.Org Video Driver, version 11.0

--xserver-xorg version: 1.7.6+10
X.Org X Server 1.11.2.902 (1.11.3 RC 2)
Release Date: 2011-12-09

--mesa version:
  cant  run glxinfo

--libdrm version:
  libdrm-intel1: 2.4.29-1
  libdrm-noveau1a: 2.4.29-1
  libdrm-radeon1: 2.4.29-1
  libdrm2: 2.4.29-1

--kernel version: 3.1.0-1-686-pae
--linux distribution: Debian testing
--Laptop model: Packard Bell NCL20
--Display connector: internal display
Comment 1 alan.zimm 2011-12-26 11:42:59 UTC
Created attachment 54830 [details]
Xorg.0.log
Comment 2 alan.zimm 2011-12-26 11:50:04 UTC
Created attachment 54831 [details]
dmesg from earlier boot showing dri problem
Comment 3 Jonathan Nieder 2012-01-01 10:50:49 UTC
From <http://bugs.debian.org/627372>:

| run "setpci -s 00:02.0 F4.B=00" as root to turn the backlight back on. You
| may be able to do this over ssh, depending on your setup, otherwise you
| will have to do this with the dark screen."
|
| The setpci solves the issue

This doesn't explain the rendering errors in the "dmesg from earlier boot showing dri problem", unfortunately. :/

*** This bug has been marked as a duplicate of bug 40455 ***
Comment 4 Jonathan Nieder 2012-01-01 11:00:36 UTC
Created attachment 55022 [details]
dmesg 2012-01-01
Comment 5 Jonathan Nieder 2012-01-01 11:01:27 UTC
Created attachment 55023 [details]
Xorg.0.log 2012-01-01
Comment 6 Jonathan Nieder 2012-01-01 11:02:15 UTC
Created attachment 55024 [details]
/sys/kernel/debug/dri/0/i915_error_state 2012-01-01
Comment 7 Chris Wilson 2012-04-16 05:26:51 UTC
*** Bug 39962 has been marked as a duplicate of this bug. ***
Comment 8 Chris Wilson 2012-04-25 02:28:12 UTC
These bugs all have similar symptoms that could be explained and fixed by the following patch. So please do test drm-intel-next-queued and report back. On trying the equivalent patch in the past, it has caused modesetting regression for the initial switch from the BIOS configuration, so do look out for any glitches during boot. Thanks.

commit 969d380a39d33f7533b6dcee35e834109d23f9e9
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Apr 24 16:36:50 2012 +0100

    drm/i915: Remove too early plane enable on pre-PCH hardware
    
    Enabling the plane before we have assigned valid address means that it
    will access random PTE (often with conflicting memory types) and cause
    GPU lockups. However, enabling the plane too early appears to workaround
    a number of bugs in our modesetting code.
    
    Cc: Franz Melchior <melchior.franz@gmail.com>
    References: https://bugs.freedesktop.org/show_bug.cgi?id=39947
    References: https://bugs.freedesktop.org/show_bug.cgi?id=41091
    References: https://bugs.freedesktop.org/show_bug.cgi?id=49041
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Acked-by: Jesse Barnes <jbarnes@virtuousgeek.org>
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Comment 9 Jonathan Nieder 2012-04-27 10:06:35 UTC
Alan tested 3.2.y with 969d380a39d3 cherry-picked on top.  The result[1]:

> I compiled both versions as per your instructions, and the behaviour is the
> same each time.
>
> I need to use setpci ... to get the screen backlight on.
>
> Do you need any additional information?

Reopening.

[1] http://bugs.debian.org/627372
Comment 10 Jonathan Nieder 2012-04-27 10:14:03 UTC
Ok, here's what I'd suggest to track this down further:

Please boot in recovery mode so X is not started automatically.
Append drm.debug=0xe log_buf_len=4194304 to the kernel command line
for more verbose logs.  Once logged in, run "modprobe i915" to make
sure the Intel driver is loaded, and attach full output from "dmesg".
Comment 11 Daniel Vetter 2012-04-27 10:16:11 UTC
> Alan tested 3.2.y with 969d380a39d3 cherry-picked on top.  The result[1]:
> 
> > I compiled both versions as per your instructions, and the behaviour is the
> > same each time.
> >
> > I need to use setpci ... to get the screen backlight on.
> >
> > Do you need any additional information?
> 
> Reopening.

setpci to get the backlight to turn on is a different problem (the only difference is that this is the first non-Acer machine).

So the first question is: Is the invalid GTT fetch gone?
Comment 12 Jonathan Nieder 2012-04-27 10:18:59 UTC
(In reply to comment #11)
> setpci to get the backlight to turn on is a different problem

I don't follow.  Do you mean that it is different from what Alan
reported on 2011-11-26?
Comment 13 Daniel Vetter 2012-04-27 10:23:07 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > setpci to get the backlight to turn on is a different problem
> 
> I don't follow.  Do you mean that it is different from what Alan
> reported on 2011-11-26?

Yep. If all it takes to get back the backlight, that's a different bug. If the gpu hangs are gone and the error_state empty, this one here is fixed.

I prefer to have individual bug reports for separate issues, it makes tracking much easier.
Comment 14 Jonathan Nieder 2012-04-27 12:42:47 UTC
(In reply to comment #13)
> (In reply to comment #12)
>> (In reply to comment #11)

>>> setpci to get the backlight to turn on is a different problem
>> 
>> I don't follow.  Do you mean that it is different from what Alan
>> reported on 2011-11-26?
>
> Yep. If all it takes to get back the backlight, that's a different bug.

Um, but when Alan first tried the setpci command in January, it
_was_ all it took to get back the backlight.

So if that's something the patch was not supposed to fix, then I
don't understand why it would be relevant for the bug Alan reported.
Perhaps you were reacting to a stray error message from his logs.
Comment 15 alan.zimm 2012-04-29 01:45:47 UTC
My understanding of this bug is that the driver is not turning on the
backlight when it should, or setting the range of possible values such that
it cannot come on.

The setpci command is an override to get it to come on, but is not a true
solution, because it has to be worked in to all the possible places where
the screen can be turned on, by modifying scripts.

Alan

On Fri, Apr 27, 2012 at 9:42 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=44156
>
> --- Comment #14 from Jonathan Nieder <jrnieder@gmail.com> 2012-04-27
> 12:42:47 PDT ---
> (In reply to comment #13)
> > (In reply to comment #12)
> >> (In reply to comment #11)
>
> >>> setpci to get the backlight to turn on is a different problem
> >>
> >> I don't follow.  Do you mean that it is different from what Alan
> >> reported on 2011-11-26?
> >
> > Yep. If all it takes to get back the backlight, that's a different bug.
>
> Um, but when Alan first tried the setpci command in January, it
> _was_ all it took to get back the backlight.
>
> So if that's something the patch was not supposed to fix, then I
> don't understand why it would be relevant for the bug Alan reported.
> Perhaps you were reacting to a stray error message from his logs.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 16 alan.zimm 2012-04-29 01:52:41 UTC
Created attachment 60759 [details]
dmesg output with drm_debug=0xe

Booting with the kernel compiled with the patch provided by Jonathan Nieder on 2012-04-26
Comment 17 Chris Wilson 2012-05-11 07:17:52 UTC
Daniel is working on some patches to fix the backlight controller and is looking for victims^Wtesters.
Comment 18 alan.zimm 2012-05-11 07:30:22 UTC
That would be me?

On Fri, May 11, 2012 at 4:17 PM,  <bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=44156
>
> Chris Wilson <chris@chris-wilson.co.uk> changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|REOPENED                    |NEEDINFO
>         AssignedTo|chris@chris-wilson.co.uk    |daniel@ffwll.ch
>
> --- Comment #17 from Chris Wilson <chris@chris-wilson.co.uk> 2012-05-11 07:17:52 PDT ---
> Daniel is working on some patches to fix the backlight controller and is
> looking for victims^Wtesters.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 19 Daniel Vetter 2012-06-05 07:10:18 UTC
Ok, I've created these patches, available at http://cgit.freedesktop.org/~danvet/drm/log/?h=backlight-confusion

Git link is git://people.freedesktop.org/~danvet/drm backlight-confusion

Please test them, thanks.
Comment 20 alan.zimm 2012-06-06 15:59:26 UTC
Hi

building as follows

git checkout stable/linux-3.4.y
git remote add danvet git://people.freedesktop.org/~danvet/drm
git fetch danvet
git checkout danvet/backlight-confusion

cp /boot/config-$(uname -r) .config; # current configuration
make deb-pkg; # optionally with -j<num> for parallel build
# Accepted defaults all the way through for the new config stuff

dpkg -i linux-image-3.4.0+_3.4.0+-1_i386.deb

The backlight still does not come on.

Did I build it properly?

Alan


On Tue, Jun 5, 2012 at 4:10 PM, <bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=44156
>
> --- Comment #19 from Daniel Vetter <daniel@ffwll.ch> 2012-06-05 07:10:18
PDT ---
> Ok, I've created these patches, available at
> http://cgit.freedesktop.org/~danvet/drm/log/?h=backlight-confusion
>
> Git link is git://people.freedesktop.org/~danvet/drm backlight-confusion
>
> Please test them, thanks.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 21 Jonathan Nieder 2012-06-06 16:07:51 UTC
bugzilla-daemon@freedesktop.org wrote:

> dpkg -i linux-image-3.4.0+_3.4.0+-1_i386.deb
>
> The backlight still does not come on.

Did you reboot?
Comment 22 alan.zimm 2012-06-06 23:11:25 UTC
Yes, and it was the default kernel on startup. Tried to suspend and resume
once rebooteted, but screen remained black until I ran setpci.

Was there any specific kernel config i needed to do?

Alan
On Jun 7, 2012 1:07 AM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=44156
>
> --- Comment #21 from Jonathan Nieder <jrnieder@gmail.com> 2012-06-06
> 16:07:51 PDT ---
> bugzilla-daemon@freedesktop.org wrote:
>
> > dpkg -i linux-image-3.4.0+_3.4.0+-1_i386.deb
> >
> > The backlight still does not come on.
>
> Did you reboot?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 23 Jonathan Nieder 2012-06-06 23:14:53 UTC
Alan Zimmerman wrote:

> Was there any specific kernel config i needed to do?

No, your test looks valid.  Thanks.
Comment 24 Daniel Vetter 2012-06-07 00:28:47 UTC
Created attachment 62695 [details]
intel_gpu_dump.backlight_on.txt

Ok, can you please grab the latest version of intel-gpu-tools and grab the output of intel_reg_dumper for when the backlight is broken?
Comment 25 alan.zimm 2012-06-07 01:11:28 UTC
I am attaching two dumps, one with the backlight on, and another when
it has failed to be turned on again after a suspend/resume cycle.

Both having booted 3.2.0-2-686-pae #1 SMP Mon May 21 18:24:12 UTC 2012

Alan

On Thu, Jun 7, 2012 at 9:28 AM,  <bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=44156
>
> --- Comment #24 from Daniel Vetter <daniel@ffwll.ch> 2012-06-07 00:28:47 PDT ---
> Ok, can you please grab the latest version of intel-gpu-tools and grab the
> output of intel_reg_dumper for when the backlight is broken?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 26 alan.zimm 2012-06-07 01:11:31 UTC
Created attachment 62696 [details]
intel_gpu_dump.backlight_off.txt
Comment 27 Daniel Vetter 2012-06-07 01:23:13 UTC
Created attachment 62699 [details]
intel_reg_dump.on.txt

I need the output of intel_reg_dumper, not intel_gpu_dump ... the latter is outdated and killed from git intel-gpu-tools anyway.
Comment 28 alan.zimm 2012-06-07 01:46:17 UTC
Oops. Sorry.

Attached are the off and on versions for intel_reg_dumper, under
3.2.0-2-686-pae #1 SMP Mon May 21 18:24:12 UTC 2012.

I cloned it from the repo at
git://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools

Alan

On Thu, Jun 7, 2012 at 10:23 AM,  <bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=44156
>
> --- Comment #27 from Daniel Vetter <daniel@ffwll.ch> 2012-06-07 01:23:13 PDT ---
> I need the output of intel_reg_dumper, not intel_gpu_dump ... the latter is
> outdated and killed from git intel-gpu-tools anyway.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 29 alan.zimm 2012-06-07 01:46:18 UTC
Created attachment 62700 [details]
intel_reg_dump.off.txt
Comment 30 Daniel Vetter 2012-06-07 08:43:24 UTC
Created attachment 62761 [details]
intel_reg_dump.on.v2.txt

Oops, sorry. I've just noticed that intel_reg_dumper doesn't read out the backlight regs on gen4. Can you try the latest version from git please?

http://cgit.freedesktop.org/xorg/app/intel-gpu-tools/
Comment 31 alan.zimm 2012-06-07 12:51:48 UTC
Ok, I have done this, the files are attached, they are different from before.


FYI, my theory (only a theory) is that the driver keeps a max and min
value for allowed settings, and they do not get set properly, but end
up as zero.  So it is correctly doing everything, but things the on
value is zero.

Alan


On Thu, Jun 7, 2012 at 5:43 PM,  <bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=44156
>
> --- Comment #30 from Daniel Vetter <daniel@ffwll.ch> 2012-06-07 08:43:24 PDT ---
> Oops, sorry. I've just noticed that intel_reg_dumper doesn't read out the
> backlight regs on gen4. Can you try the latest version from git please?
>
> http://cgit.freedesktop.org/xorg/app/intel-gpu-tools/
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 32 alan.zimm 2012-06-07 12:51:49 UTC
Created attachment 62762 [details]
intel_reg_dump.off.v2.txt
Comment 33 Daniel Vetter 2012-06-07 13:03:31 UTC
Thanks for the updated dumps. I've noticed a few other ugly things in our backlight code, and the code history isn't too confidence-inspiring either :(

I'll try to dig around a find a patch that should help for your machine, too.
Comment 34 Jani Nikula 2012-08-28 10:16:58 UTC
Might be a long shot, but please see the patches and discussion at [1], also available in the "backlight" branch of [2]. Please test.

[1] http://thread.gmane.org/gmane.comp.freedesktop.xorg.drivers.intel/13642
[2] git://gitorious.org/jani/drm.git
Comment 35 alan.zimm 2012-08-29 19:26:30 UTC
I have tested the patches, and it seems to work.

Build steps
-------------------
-in ./kernel/linux

$ git fetch

From git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
   eea5b55..c182ae4  master     -> origin/master


$ git checkout stable/linux-3.4.y
$ git remote add jani git://gitorious.org/jani/drm.git
$ git fetch jani
$ git checkout jani/backlight

Previous HEAD position was f18a511... Linux 3.4.1
HEAD is now at 1cd48c1... drm/i915: remove module parameter and quirk for inverting brightness


$ cp /boot/config-$(uname -r) .config; # current configuration
$ make deb-pkg; # optionally with -j<num> for parallel build
[ Accept defaults for all config options (NEW) stuff ]

$ cd ..
# dpkg -i linux-image-3.6.0-rc2+_3.6.0-rc2+-2_i386.deb
-----------

I also removed the setpci call from /etc/rc.local, which forced the backlight before


Results
-----------
Basically, screen stays on. In particular

a. At the point in the boot where the graphics driver is initialised, and the font changes, the screen stays on, where it went off before
b. After suspend/resume the screen comes back immediately, without requiring a setpci call.

Note: The screen bright/dim controls under gnome do not do anything, but it may be misconfigured on my side.
Comment 36 Jani Nikula 2012-09-06 11:38:48 UTC
(In reply to comment #35)
> I have tested the patches, and it seems to work.

Thanks for your testing. Unfortunately, there were some other issues with the patches, so we have to think of something else.

To check out an idea, please attach the output of

  $ cat /sys/kernel/debug/dri/0/i915_opregion | od -t x1
Comment 37 Jani Nikula 2012-09-10 12:46:37 UTC
Created attachment 66927 [details] [review]
always use LBPC 0xff in combination mode

Please try the attached patch and report back. Thanks.
Comment 38 Jani Nikula 2012-09-17 12:42:49 UTC
Long story short, per discussion with reporter by email, i915.invert_brightness=1 fixes the issue. Please report 'lspci -vmmnn'.
Comment 39 Rodrigo Vivi 2012-12-18 22:02:13 UTC
Created attachment 71761 [details]
lspci info from bug reporter...
Comment 40 Jani Nikula 2013-01-22 10:48:10 UTC
Created attachment 73445 [details] [review]
drm/i915: add quirk to invert brightness on Packard Bell NCL20

Please try the attached patch. Do *not* use i915.invert_brigthness=1 module parameter.
Comment 41 Daniel Vetter 2013-01-22 11:52:57 UTC
Patch merged into drm-intel-next-queued:

commit 5559ecadad5a73b27f863e92f4b4f369501dce6f
Author: Jani Nikula <jani.nikula@intel.com>
Date:   Tue Jan 22 12:50:36 2013 +0200

    drm/i915: add quirk to invert brightness on Packard Bell NCL20
Comment 42 alan.zimm 2013-01-22 12:02:00 UTC
On which Remote? I do not see it on jani or on danvet

danvet    git://people.freedesktop.org/~danvet/drm (fetch)
danvet    git://people.freedesktop.org/~danvet/drm (push)
jani    git://gitorious.org/jani/drm.git (fetch)
jani    git://gitorious.org/jani/drm.git (push)
origin    git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git(fetch)
origin    git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git(push)
stable    git://
git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git (fetch)
stable    git://
git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git (push)

git show 5559ecadad5a73b27f863e92f4b4f369501dce6f
fatal: bad object 5559ecadad5a73b27f863e92f4b4f369501dce6f


Alan

On Tue, Jan 22, 2013 at 1:52 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Daniel Vetter <daniel@ffwll.ch> changed bug 44156<https://bugs.freedesktop.org/show_bug.cgi?id=44156>
>  What Removed Added  Status NEEDINFO RESOLVED  Resolution --- FIXED
>
>  *Comment # 41 <https://bugs.freedesktop.org/show_bug.cgi?id=44156#c41>on bug
> 44156 <https://bugs.freedesktop.org/show_bug.cgi?id=44156> from Daniel
> Vetter <daniel@ffwll.ch> *
>
> Patch merged into drm-intel-next-queued:
>
> commit 5559ecadad5a73b27f863e92f4b4f369501dce6f
> Author: Jani Nikula <jani.nikula@intel.com>
> Date:   Tue Jan 22 12:50:36 2013 +0200
>
>     drm/i915: add quirk to invert brightness on Packard Bell NCL20
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 43 Daniel Vetter 2013-01-22 12:24:15 UTC
On the repo with the official branches: http://cgit.freedesktop.org/~danvet/drm-intel
Comment 44 alan.zimm 2013-01-22 15:32:01 UTC
Built it eventually. Initial boot seems good, the console does not blank
half way through.

Alan
On Jan 22, 2013 2:24 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 43 <https://bugs.freedesktop.org/show_bug.cgi?id=44156#c43>on bug
> 44156 <https://bugs.freedesktop.org/show_bug.cgi?id=44156> from Daniel
> Vetter <daniel@ffwll.ch> *
>
> On the repo with the official branches:http://cgit.freedesktop.org/~danvet/drm-intel
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 45 alan.zimm 2013-01-22 19:46:20 UTC
With the new version from today, it boots fine with the backlight on, but
the following commands make no difference at all to the brightness. FYI.

root@alanz-laptop:~# setpci -s 00:02.0 F4.B=FF
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=FE
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=FD
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=F0
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=E0
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=D0
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=C0
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=B0
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=A0
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=90
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=80
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=70
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=60
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=50
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=40
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=30
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=20
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=10
root@alanz-laptop:~# setpci -s 00:02.0 F4.B=00

Alan

On Tue, Jan 22, 2013 at 5:31 PM, AlanKim Zimmerman <alan.zimm@gmail.com>wrote:

> Built it eventually. Initial boot seems good, the console does not blank
> half way through.
>
> Alan
> On Jan 22, 2013 2:24 PM, <bugzilla-daemon@freedesktop.org> wrote:
>
>>   *Comment # 43 <https://bugs.freedesktop.org/show_bug.cgi?id=44156#c43>on bug
>> 44156 <https://bugs.freedesktop.org/show_bug.cgi?id=44156> from Daniel
>> Vetter <daniel@ffwll.ch> *
>>
>> On the repo with the official branches:http://cgit.freedesktop.org/~danvet/drm-intel
>>
>>  ------------------------------
>> You are receiving this mail because:
>>
>>    - You reported the bug.
>>
>>
Comment 46 Daniel Vetter 2013-01-22 20:37:08 UTC
The setpci thing is the legacy hack (which on some Acer laptops seems to get horribly in the way). Backlight /should/ get controlled through /sys/class/backlight drivers. At least that's what X will use ...

Do none of those drivers work? If that's the case, you need a platform specific (probably some acpi/wmi magic) backlight driver ...
Comment 47 alan.zimm 2013-01-22 20:44:19 UTC
Yes,

root@alanz-laptop:~# echo 649450 >
/sys/class/backlight/intel_backlight/brightness
root@alanz-laptop:~# echo 2649450 >
/sys/class/backlight/intel_backlight/brightness

behaves as expected. The second value comes from

root@alanz-laptop:~# cat
/sys/class/backlight/intel_backlight/max_brightness
2649450


Thanks
  Alan

On Tue, Jan 22, 2013 at 10:37 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 46 <https://bugs.freedesktop.org/show_bug.cgi?id=44156#c46>on bug
> 44156 <https://bugs.freedesktop.org/show_bug.cgi?id=44156> from Daniel
> Vetter <daniel@ffwll.ch> *
>
> The setpci thing is the legacy hack (which on some Acer laptops seems to get
> horribly in the way). Backlight /should/ get controlled through
> /sys/class/backlight drivers. At least that's what X will use ...
>
> Do none of those drivers work? If that's the case, you need a platform specific
> (probably some acpi/wmi magic) backlight driver ...
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.