Bug 4420 - small characters render poorly
Summary: small characters render poorly
Status: RESOLVED DUPLICATE of bug 5589
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-11 04:05 UTC by Sebastien Bacher
Modified: 2006-12-11 21:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien Bacher 2005-09-11 04:05:56 UTC
This bug has been opened here: http://bugzilla.ubuntu.com/show_bug.cgi?id=14070

"I have got lots of technical documents/datasheets in PDF format,
...
Also, the quality of the rendering is poor : I often can't even read the small
characters in diagrams.
...
http://bugzilla.ubuntu.com/attachment.cgi?id=3359
sample datasheet
...
> can you make a screenshot of the issue on the example pdf you put with this bug?
...
http://bugzilla.ubuntu.com/attachment.cgi?id=3395
Evince next to Kpdf

I just made one. It's page 10 of the document. Evince is on top, and Kpdf at the
bottom. I adjusted the page width so that the zoom factor in both apps is
exactly the same, as this obviously affect anti-aliasing/rendering.
The interesting part is the small characters in the diagram on the right part of
the page. Evince at first might appear cleared to you, because the line look
"thiner". However there are many missing pixels, that make it hard to read, and
force me to "guess" what's writen. Data sheets are there to provide reference
information, "guessing" is not good at all, you must sure of what you are
reading. Now with Kpdf, it's the other way around : it may appear more "blurry"
to you a t first (I think obvjectively it is, in some places), but the advantage
is that there is no mising pixels, and that ALL the text inthe diagram is
actually readable without effort, whereas with Evince some characters may be
clear, but many aren't. Kpdf is more "consistent", the text will always be
complete and readable."
Comment 1 Jeff Muizelaar 2006-01-31 04:34:24 UTC
This is likely due to cairo's poor downscaling quality.
Comment 2 Jeff Muizelaar 2006-12-11 21:39:30 UTC

*** This bug has been marked as a duplicate of 5589 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.