Bug 44315 - Make check regression on mips*: unit test for mieq fails
Summary: Make check regression on mips*: unit test for mieq fails
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: Other All
: high major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard: 2011BRB_Reviewed
Keywords: patch
Depends on:
Blocks: xserver-1.12
  Show dependency treegraph
 
Reported: 2011-12-30 04:30 UTC by Cyril Brulebois
Modified: 2012-02-20 15:36 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Full backtrace (2.33 KB, text/plain)
2011-12-30 04:30 UTC, Cyril Brulebois
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cyril Brulebois 2011-12-30 04:30:53 UTC
Created attachment 54973 [details]
Full backtrace

The following commit introduces a failure in make check on the Debian mips and mipsel platforms:

commit 4597ac6fe0580323860080dae2576733acc49757
Author: Jeremy Huddleston <jeremyhu@apple.com>
Date:   Mon Oct 17 23:45:32 2011 -0700

    test: Add unit test for mieq
    
    Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
    Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>


First published in 1.11.99.1, confirmed in 1.11.99.2 and 1.11.99.901 (1.12 RC1).


Build logs are available (clicking on Maybe-Failed for the appropriate version) on:
  https://buildd.debian.org/status/logs.php?pkg=xorg-server&arch=mips
  https://buildd.debian.org/status/logs.php?pkg=xorg-server&arch=mipsel

On the build daemons, I'm getting a segfault:
,--
/usr/bin/make  check-TESTS
make[4]: Entering directory `/build/buildd2-xorg-server_1.11.99.901-1-mips-u2FZcA/xorg-server-1.11.99.901/build-main/test'
PASS: list
PASS: string
(null): not enough space for touch events (max 5 touchpoints). Dropping this event.
(null): not enough space for touch events (max 5 touchpoints). Dropping this event.
(null): not enough space for touch events (max 5 touchpoints). Dropping this event.
PASS: touch
PASS: xkb
[dix] EventToCore: Not implemented yet 
[dix] EventToCore: Not implemented yet 
[dix] EventToCore: Not implemented yet 
[mi] Increasing EQ size to 512 to prevent dropped events.
[mi] EQ overflowing.  Additional events will be discarded until existing events are processed.

Backtrace:
/bin/bash: line 5: 11775 Segmentation fault      ${dir}$tst
FAIL: input
PASS: xtest
PASS: misc
PASS: fixes
PASS: xfree86
========================================================================
make[4]: *** [check-TESTS] Error 1
1 of 9 tests failed
`--

In Qemu, I'm getting a bus error instead:
,--
make  check-TESTS
make[3]: Entering directory `/home/kibi/xorg-server/test'
PASS: xkb
[dix] EventToCore: Not implemented yet
[dix] EventToCore: Not implemented yet
[dix] EventToCore: Not implemented yet
[mi] Increasing EQ size to 512 to prevent dropped events.
[mi] EQ overflowing.  Additional events will be discarded until existing events  
are processed.

Backtrace:
/bin/bash: line 5: 17194 Bus error               ${dir}$tst
FAIL: input
PASS: xtest
PASS: list
PASS: misc
PASS: fixes
PASS: xfree86
========================================================================
1 of 7 tests failed
`--

I'm attaching gdb.txt for the latter.
Comment 1 Julien Cristau 2011-12-30 11:46:54 UTC
http://patchwork.freedesktop.org/patch/8531/
Comment 2 Jeremy Huddleston Sequoia 2012-01-18 11:00:34 UTC
While the symptom wasn't in 1.11, the root of the problem was there, so I've pulled this into server-1.11-branch
Comment 3 Cyril Brulebois 2012-02-20 15:36:12 UTC
Fixed in xorg-server-1.11.99.902~55^2

commit 6269977c91071e0ea16ca5b4b8e15fd6db0b6fcf
Author: Julien Cristau <jcristau@debian.org>
Date:   Fri Dec 30 20:41:25 2011 +0100

    os: don't ignore failure from dladdr
    
    If dladdr returns 0, don't go and use the returned Dl_info, it may
    contain garbage.
    
    X.Org bug#44315 <https://bugs.freedesktop.org/show_bug.cgi?id=44315>
    
    Reported-and-tested-by: Cyril Brulebois <kibi@debian.org>
    Reviewed-by: Jeremy Huddleston <jeremyhu@apple.com>
    Reviewed-by: Cyril Brulebois <kibi@debian.org>
    Signed-off-by: Julien Cristau <jcristau@debian.org>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.