Bug 44927 - [SNB IVB regression] gl-117 abort when click
Summary: [SNB IVB regression] gl-117 abort when click
Status: CLOSED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: All Linux (All)
: high major
Assignee: Chad Versace
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 42993
  Show dependency treegraph
 
Reported: 2012-01-19 01:23 UTC by cc
Modified: 2015-05-12 05:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cc 2012-01-19 01:23:19 UTC
when enter gl-117 and click, the game will quit unexpect. I list the Bug info as follows. 

Additionally, I also tested other commit of Mesa and found "(7.11)7722a54e60c9da080b557d6596e4c9d363ead515" is good.

Environment:
------------
Kernel_version:		3.2.0_stable_20120112+
Libdrm:		(master)2.4.30-1-g66518ab5653cfdc840cd69e7b653ec05df060584
Mesa:		(8.0)9489ae8938b74551913337876656bcb9178a8905
Xserver:		(server-1.11-branch)xorg-server-1.11.3
Xf86_video_intel:		(master)2.17.0-385-g7290ced5791f9860b00901fa9a4545ab5a067fae
Cairo:		(master)738be215dae1a98af39f68cc9ac5c338a2e44e38


Bug detailed description:
--------------------------
Info: Found gl-117 data directory /usr/share/gl-117 
Info: Startup gl-117, V1.3 ... 
Info: Loading /root/.gl-117/conf 
Info: Saving /root/.gl-117/conf 
Info: Loading /root/.gl-117/conf.interface 
Info: Saving /root/.gl-117/conf.interface 
Info: Using SDL and GLUT
Info: Using SDL_mixer
Info: No joystick found
Segmentation fault (core dumped)

dmesg:
gl-117[5211]: segfault at 3e7882f0 ip b702cc4f sp bfba0ef0 error 6 in i965_dri.so[b6e46000+39c000]

Reproduce steps:
----------------
1.xinit& && gnome
2.gl-117
Comment 1 Gordon Jin 2012-01-19 21:57:23 UTC
so it's regression 7.11->8.0
Comment 2 Ian Romanick 2012-01-20 15:47:35 UTC
I am unable to reproduce this on current 8.0 branch or master.  Can you try again and provide a backtrace?  For reference, I'm on

OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL version string: 3.0 Mesa 8.0-rc1 (git-1b33ae3)
OpenGL shading language version string: 1.30
Comment 3 cc 2012-01-20 17:18:08 UTC
Maybe you need click one or more times to reproduce. I list the bt info as follows:

--------------------
Program received signal SIGSEGV, Segmentation fault.
0xb7672c4f in _mesa_meta_begin (ctx=0x8187e40, state=812937) at drivers/common/meta.c:425
425	   memset(save, 0, sizeof(*save));
(gdb) bt
#0  0xb7672c4f in _mesa_meta_begin (ctx=0x8187e40, state=812937) at drivers/common/meta.c:425
#1  0xb74f4199 in gen6_resolve_slice (intel=<optimized out>, mt=0x835fef8, level=0, layer=0, op=BRW_HIZ_OP_DEPTH_RESOLVE)
    at gen6_hiz.c:256
#2  0xb74b02d3 in intel_miptree_slice_resolve (intel=0x8187e40, mt=0x835fef8, level=0, layer=0, 
    need=INTEL_NEED_DEPTH_RESOLVE, func=0xb74f4660 <gen6_resolve_depth_slice>) at intel_mipmap_tree.c:609
#3  0xb74af1fb in intel_renderbuffer_resolve_depth (intel=0x8187e40, irb=0x835f878) at intel_fbo.c:954
#4  0xb74b60d1 in intel_span_resolve_buffers (intel=0x8187e40) at intel_span.c:288
#5  intelSpanRenderStart (ctx=0x8187e40) at intel_span.c:330
#6  0xb7632d8b in _swrast_render_start (ctx=0x8187e40) at swrast/s_context.c:867
#7  0xb766bb38 in _swsetup_RenderStart (ctx=0x8187e40) at swrast_setup/ss_context.c:202
#8  0xb76068f9 in run_render (ctx=0x8187e40, stage=0x81ff170) at tnl/t_vb_render.c:276
#9  0xb75fba63 in _tnl_run_pipeline (ctx=0x8187e40) at tnl/t_pipeline.c:163
#10 0xb75fc058 in _tnl_draw_prims (ctx=0x8187e40, arrays=0x81ece20, prim=0x81eb708, nr_prims=1, ib=0x0, min_index=0, 
    max_index=3) at tnl/t_draw.c:523
#11 0xb74c7c61 in brw_draw_prims (ctx=0x8187e40, arrays=0x81ece20, prim=0x81eb708, nr_prims=1, ib=0x0, 
    index_bounds_valid=1 '\001', min_index=0, max_index=3, tfb_vertcount=0x0) at brw_draw.c:614
#12 0xb75ec86a in vbo_exec_vtx_flush (exec=0x81eb2e8, keepUnmapped=1 '\001') at vbo/vbo_exec_draw.c:407
#13 0xb75e8c57 in vbo_exec_FlushVertices_internal (exec=0x81eb2e8, unmap=<optimized out>) at vbo/vbo_exec_api.c:444
#14 0xb75e8c8f in vbo_exec_FlushVertices (ctx=0x8187e40, flags=1) at vbo/vbo_exec_api.c:1195
#15 0xb75ca6d9 in _mesa_DepthRange (nearval=0, farval=1) at main/viewport.c:119
#16 0xb7673538 in _mesa_meta_begin (ctx=0x8187e40, state=812937) at drivers/common/meta.c:672
#17 0xb74f4199 in gen6_resolve_slice (intel=<optimized out>, mt=0x835fef8, level=0, layer=0, op=BRW_HIZ_OP_DEPTH_RESOLVE)
    at gen6_hiz.c:256
#18 0xb74b02d3 in intel_miptree_slice_resolve (intel=0x8187e40, mt=0x835fef8, level=0, layer=0, 
    need=INTEL_NEED_DEPTH_RESOLVE, func=0xb74f4660 <gen6_resolve_depth_slice>) at intel_mipmap_tree.c:609
#19 0xb74af1fb in intel_renderbuffer_resolve_depth (intel=0x8187e40, irb=0x835f878) at intel_fbo.c:954
#20 0xb74b60d1 in intel_span_resolve_buffers (intel=0x8187e40) at intel_span.c:288
#21 intelSpanRenderStart (ctx=0x8187e40) at intel_span.c:330
#22 0xb7632d8b in _swrast_render_start (ctx=0x8187e40) at swrast/s_context.c:867
#23 0xb766bb38 in _swsetup_RenderStart (ctx=0x8187e40) at swrast_setup/ss_context.c:202
#24 0xb76068f9 in run_render (ctx=0x8187e40, stage=0x81ff170) at tnl/t_vb_render.c:276
#25 0xb75fba63 in _tnl_run_pipeline (ctx=0x8187e40) at tnl/t_pipeline.c:163
#26 0xb75fc058 in _tnl_draw_prims (ctx=0x8187e40, arrays=0x81ece20, prim=0x81eb708, nr_prims=1, ib=0x0, min_index=0, 
    max_index=3) at tnl/t_draw.c:523
#27 0xb74c7c61 in brw_draw_prims (ctx=0x8187e40, arrays=0x81ece20, prim=0x81eb708, nr_prims=1, ib=0x0, 
    index_bounds_valid=1 '\001', min_index=0, max_index=3, tfb_vertcount=0x0) at brw_draw.c:614
#28 0xb75ec86a in vbo_exec_vtx_flush (exec=0x81eb2e8, keepUnmapped=1 '\001') at vbo/vbo_exec_draw.c:407
Comment 4 Ian Romanick 2012-01-23 10:41:48 UTC
It looks like it's in a HiZ resolve, so I'm reassigning to Chad.
Comment 5 Chad Versace 2012-01-27 17:05:02 UTC
Assigning to self. I began working on it yesterday.
Comment 6 Chad Versace 2012-02-08 11:50:58 UTC
Fixed on master by:

commit 7b36c68ba6899c7f30fd56b7ef07a78b027771ac
Author: Chad Versace <chad.versace@linux.intel.com>
    i965: Rewrite the HiZ op
Comment 7 Chad Versace 2012-02-08 12:00:48 UTC
Reopening bug.

idr requested that I leave the bug open until it is fixed on 8.0.
Comment 8 cc 2012-02-14 17:40:11 UTC
This issue still exist.

Kernel_version:		2.6.31.12
Libdrm:		(master)2.4.31-3-gced219ebbd3b266ac8326223bad62f994907ae6b
Mesa:		(8.0)65526d54aa2599b069bd443d3e6e9762e613042d
Xserver:		(server-1.11-branch)xorg-server-1.11.4
Xf86_video_intel:		(master)2.17.0-650-gc0376b7f7b083ab2e87edc36e56fd8eb99c3cd05
Cairo:		(master)4f81940749b680c6e48d393fd13108775efa38eb
Comment 9 Gordon Jin 2012-02-14 18:34:29 UTC
(In reply to comment #8)
> This issue still exist.
> Kernel_version:        2.6.31.12
> Libdrm:        (master)2.4.31-3-gced219ebbd3b266ac8326223bad62f994907ae6b
> Mesa:        (8.0)65526d54aa2599b069bd443d3e6e9762e613042d

The mentioned fix is only on mesa master (thus it's not closed). 
You need test master.
Comment 10 Chad Versace 2012-02-15 15:01:53 UTC
Marking RESOLVED/FIXED. The fixes were recently cherry-picked to 8.0.

FYI, the app is inherently buggy. My patches just fix the crash described in the bug report.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.