Bug 44958 - [SNB IVB HSW] mesa demo test texleak bus error
[SNB IVB HSW] mesa demo test texleak bus error
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
All Linux (All)
: medium normal
Assigned To: Ian Romanick
cancan,feng
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-19 18:15 UTC by cc
Modified: 2014-08-07 09:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cc 2012-01-19 18:15:32 UTC
Environment:
------------
Kernel_version:        3.2.0_stable_20120112+
Libdrm:        (master)2.4.30-1-g66518ab5653cfdc840cd69e7b653ec05df060584
Mesa:        (8.0)9489ae8938b74551913337876656bcb9178a8905
Xserver:        (server-1.11-branch)xorg-server-1.11.3
Xf86_video_intel:       
(master)2.17.0-385-g7290ced5791f9860b00901fa9a4545ab5a067fae
Cairo:        (master)738be215dae1a98af39f68cc9ac5c338a2e44e38

Bug detailed description:
--------------------------
8192 x 8192 max texture size
Bus error (core dumped)

Reproduce steps:
----------------
1.xinit& && gnome
2../texleak
Comment 1 Gordon Jin 2012-01-19 18:54:52 UTC
Is this bug#36070?
Comment 2 cc 2012-01-19 21:59:16 UTC
(In reply to comment #1)
> Is this bug#36070?

They are not the same issues.

And I found this is not a regression bug for on  the commit
Mesa: (7.11)c0009739bf65883c780408e252c6bdc76f56aecb
this issue is also exist.
Comment 3 Gordon Jin 2012-03-31 23:43:22 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Is this bug#36070?
> They are not the same issues.

What's the difference? Or do you mean you can't reproduce bug#36070?
Comment 4 Kenneth Graunke 2012-05-31 17:08:11 UTC
In case people aren't aware, "texleak" is from the Mesa demos repository:

ssh://git.freedesktop.org/git/mesa/demos

src/tests/texleak

And yes, it does give me a "bus error" on SNB.
Comment 5 cancan,feng 2013-03-11 05:48:57 UTC
The issue still exists with the follow commits:
---------------------------------
Libdrm:            (master)libdrm-2.4.42
Mesa:              (9.1)mesa-9.1
Xserver:           (server-1.13-branch)xorg-server-1.13.2.902
Xf86_video_intel:  (master)2.21.3
Cairo:             (master)1.12.14
Libva:             (master)libva-1.1.0
Libva_intel_driver:  (master)00f65b78e6de520a4820702207ce098c6b073724
Kernel:      3.8
Comment 6 Eric Anholt 2013-04-08 20:21:24 UTC
commit ca9a7d975af228cabb79c3040ec67f26f94f90a2
Author: Eric Anholt <eric@anholt.net>
Date:   Tue Apr 2 17:28:41 2013 -0700

    intel: Avoid making tiled miptrees we won't be able to blit.
Comment 7 Gordon Jin 2013-04-23 05:26:43 UTC
Cancan, can you verify?
Comment 8 shui yangwei 2013-06-17 03:28:06 UTC
I find this issue exists on HSW,and we tried this release environment on IVB, this issue reproduced, I reopened this bug here:
-----------------------------------
Kernel: 3.9.5
Mesa: 9.1.3 (almost the same as RC1)
Libdrm: 2.4.45 (even older than RC1)
Xf86-video-intel: 2.21.9
Libva: master (to be 1.2)
Libva-intel-driver: master (to be 1.2)
Cairo: 1.12.14
Xserver: 1.14
Comment 9 Ian Romanick 2013-06-19 08:25:44 UTC
I just cherry picked the relevant patches to the 9.1 branch.  This should be fixed as of commit 060f7b0.  This will be in 9.1.4.
Comment 10 meng 2014-08-07 09:39:25 UTC
Verified it.