Bug 45214 - Textures disappearing or missing in RegnumOnline OpenGL game
Textures disappearing or missing in RegnumOnline OpenGL game
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
x86-64 (AMD64) Linux (All)
: medium critical
Assigned To: Kenneth Graunke
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-25 02:06 UTC by Mateusz Kaduk
Modified: 2012-06-01 01:22 UTC (History)
1 user (show)

See Also:


Attachments
Blinking textures (729.54 KB, image/gif)
2012-01-25 02:06 UTC, Mateusz Kaduk
Details
This screenshot shows (safe-mode) how game is expected to look. (170.28 KB, image/jpeg)
2012-01-25 02:10 UTC, Mateusz Kaduk
Details
This screenshot shows (shader mode) what goes wrong. (156.62 KB, image/jpeg)
2012-01-25 02:13 UTC, Mateusz Kaduk
Details
Current git crashes Xorg (3.08 KB, text/plain)
2012-01-29 02:41 UTC, Mateusz Kaduk
Details
Textures broken in left corner (126.39 KB, image/jpeg)
2012-02-05 04:31 UTC, Mateusz Kaduk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Kaduk 2012-01-25 02:06:27 UTC
Created attachment 56124 [details]
Blinking textures

In attached GIF you can find, what is wrong with OpenGL rendering.

It's tested with 8.0-dev mesa, latest commits seems to be:

commit 422b18794eacc8f0be5b4e9611e2726f4e0d86b6
Author: Eric Anholt <eric@anholt.net>
Date:   Fri Jan 20 13:43:11 2012 -0800
Comment 1 Mateusz Kaduk 2012-01-25 02:10:54 UTC
Created attachment 56126 [details]
This screenshot shows (safe-mode) how game is expected to look.

Please compare to blinking GIF. This picture shows what is expected.
Comment 2 Mateusz Kaduk 2012-01-25 02:13:23 UTC
Created attachment 56127 [details]
This screenshot shows (shader mode) what goes wrong.

Missing textures. This is not animated version, captured when textures were blinking.
Comment 3 Mateusz Kaduk 2012-01-25 02:23:51 UTC
lspci -nn | grep VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
Comment 4 Mateusz Kaduk 2012-01-29 02:41:17 UTC
Created attachment 56282 [details]
Current git crashes Xorg

Hi,

I tried recent commits in mesa, and I experience Xserver segmentation fault crash.
I am a bit worried since its release candidate and content is deteriorating. I hope it wont be release until critical bugs are fixed.

I tried bisecting, but because of introduced bugs in building process on some machines in git history, its not possible to bisect (sorry!!). 
I tried debugging Xserver from ssh, from another laptop (see attachment).

If you have any ideas, how to find out why Xserver is crashing, please let me know, so I can test RegnumOnline textures bug.

Thanks
Comment 5 Mateusz Kaduk 2012-01-29 02:54:17 UTC
Ok Xserver does not crash anymore, I installed one from Debian Experimental.
It does crash with Xorg from Debian Sid.

So please ignore, last attachment. But Texture bug is still present, so please leave this bug open.
Comment 6 Kenneth Graunke 2012-02-02 23:37:14 UTC
Okay, I can reproduce this.  I've managed to capture an apitrace which demonstrates the bug so we can debug it without needing the game and an account.

Now to trim it down and figure out what shader's going wrong...
Comment 7 Mateusz Kaduk 2012-02-02 23:53:25 UTC
(In reply to comment #6)
> Now to trim it down and figure out what shader's going wrong...

That's a good news, so there is a chance it will be in mesa 8.0 ? I keep fingers crossed. If you commit fix, I will test it. Thanks.
Comment 8 Mateusz Kaduk 2012-02-05 04:31:18 UTC
Created attachment 56622 [details]
Textures broken in left corner

Hi,

With git mesa as of the moment of writing, the problem is almost gone. Blinking is gone. But sometimes I see still some rare artefacts on the sides of the screen, or trees (attached screenshot).

In general most annoying bug seems to be fixed, maybe those small texture problems are related to other condition ?

Thanks for fixing.
Comment 9 Pablo 2012-02-10 07:25:14 UTC
see, 44701

same issue on radeon drivers. (mark as duplicated if is needed)
Comment 10 Mateusz Kaduk 2012-02-17 08:34:03 UTC
Problem is NOT gone, it was custom patch from Kenneth, but after git clean, I see that it hasn't been merged, and game is still not playable.

I would be grateful if your patch could be merged.
Comment 11 Kenneth Graunke 2012-06-01 01:22:21 UTC
The original flickering issue is gone.  From playing a few minutes of the game, it appears to be working just fine with Mesa 8.1/master.

If there are further issues with Regnum, feel free to report them...