Bug 45221 - [bisected IVB] glean/fbo regression in stencil-only case
[bisected IVB] glean/fbo regression in stencil-only case
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Kenneth Graunke
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-25 03:25 UTC by Kenneth Graunke
Modified: 2012-02-16 00:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Graunke 2012-01-25 03:25:53 UTC
glean/fbo fails on Ivybridge since commit 28cfa1fa213fe7ba6e5b57e61da663a6c3bf0c13
(i965: Don't reallocate push constant URB space on new VS programs.)

$ ./bin/glean -r foo -o -v -v -v -t +fbo --quick
----------------------------------------------------------------------
fbo test: Test OpenGL Extension GL_EXT_framebuffer_object

Mesa: Initializing x86-64 optimizations
GL_EXT_framebuffer_object is supported
GL_ARB_framebuffer_object is supported
  depth = 0, stencil = 1
  (0, 0) = [0.376471, 0.003922, 0.003922], is expected to be[1.000000, 0.000000, 0.000000]
FAILURE: Render to single texture failed (at tfbo.cpp:850)
  mode = 0
fbo:  FAIL rgba8, db, z24, s8, win+pmap, id 33
	7 tests passed, 1 tests failed.

Reverting the patch fixes it (but is obviously not a solution).
Comment 1 Kenneth Graunke 2012-02-10 21:28:55 UTC
Patch on mailing list:
http://lists.freedesktop.org/archives/mesa-dev/2012-February/018940.html
Comment 2 Kenneth Graunke 2012-02-16 00:28:25 UTC
commit 709f50928e1d4df755ffb90ec9f33ba6c9605a32
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Thu Jan 19 09:55:34 2012 -0800

    i965: Emit Ivybridge VS workaround flushes.
    
    I recently discovered this text in the BSpec.  It seems wise to comply,
    though I haven't observed it to fix anything yet.
    
    Fixes a regression in glean/fbo since 28cfa1fa213fe.
    
    NOTE: This is a candidate for stable release branches.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=45221
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Reviewed-by: Eric Anholt <eric@anholt.net>

Also cherry-picked to 8.0.