Bug 45291 - No video output via DisplayPort on Mobility HD 4670.
Summary: No video output via DisplayPort on Mobility HD 4670.
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Default DRI bug account
QA Contact:
: 82285 (view as bug list)
Depends on:
Reported: 2012-01-26 19:28 UTC by Jon Sturm
Modified: 2019-11-19 08:25 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

dmesg (62.07 KB, text/plain)
2012-01-26 19:28 UTC, Jon Sturm
no flags Details
Xorg.0.log (78.18 KB, patch)
2012-01-26 19:29 UTC, Jon Sturm
no flags Details | Splinter Review

Description Jon Sturm 2012-01-26 19:28:29 UTC
Created attachment 56209 [details]

I have a Dell Studio XPS 1610 laptop and a Dell U2312HM monitor with DisplayPort. The monitor works in the BIOS but as soon as Grub loads and Linux starts to boot it blanks and enters Powersave mode.once in X xrandr reports it as on but there is no picture and the monitors OSD just continues to report that it is in Powersave mode. Enabling and disabling the monitor via Xrandr does not error and my windows manager resizes things as if it was enabled but the monitor still shows no input.

There are no errors in dmesg during this and everything is reported as working.(the warning at the end of dmesg is from a different HDMI monitor which I plugged later since the DisplayPort one wasn't working)
Comment 1 Jon Sturm 2012-01-26 19:29:40 UTC
Created attachment 56210 [details] [review]
Comment 2 Alex Deucher 2012-01-27 07:29:50 UTC
Do other modes besides 1920x1080 on the displayport monitor work?  E.g.,
xrandr --output DisplayPort-0 --mode 1024x768
Comment 3 Jon Sturm 2012-02-05 17:52:13 UTC
Sorry for the late reply, but no, no other modes worked.
Comment 4 Glen Ogilvie 2014-08-05 08:40:16 UTC
Also occurs on a Dell Studio 1747 with an Mobility Radoen HD 4650.

Anything I can do to help?   No errors in the logs.  Monitor is detected, correct resolutions found.  I can tell it to extend the desktop it.. but no output on the monitor.. it stays sleeping.

Works OK on the ATI legacy driver.. but I want to upgrade from a 4 year old distro.
Comment 5 Alex Deucher 2014-08-25 13:53:44 UTC
*** Bug 82285 has been marked as a duplicate of this bug. ***
Comment 6 p3we 2015-08-29 21:27:43 UTC
This issue also occurs on Dell U2312MH monitor connected to ATI Mobility Radeon 540v (RV710) over DisplayPort. The driver properly detects plugged monitor and discover all capabilities but there is no signal on DisplayPort. After short time monitor goes to sleep mode.

I have tried all available modes with no success. VGA output works fine.

I have tested this configuration under Windows and DisplayPort works as expected, so it is no a hardware problem.
Comment 7 Martin Peres 2019-11-19 08:25:05 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/248.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.