Bug 4550 - xorg cannot process the big request correctly
xorg cannot process the big request correctly
Status: RESOLVED DUPLICATE of bug 4565
Product: xorg
Classification: Unclassified
Component: Server/General
git
x86 (IA32) All
: high normal
Assigned To: Xorg Project Team
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-22 04:03 UTC by Rui Feng
Modified: 2010-03-27 04:22 UTC (History)
1 user (show)

See Also:


Attachments
demonstration of the failure for big request (2.99 KB, text/plain)
2005-09-22 04:08 UTC, Rui Feng
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rui Feng 2005-09-22 04:03:25 UTC
All tests of TOO_LONG type in XProto* section of xts5 fail since xorg cannot
process the big request correctly.
Comment 1 Rui Feng 2005-09-22 04:08:55 UTC
Created attachment 3362 [details]
demonstration of the failure for big request

It can demonstrate the failure of big request:
1. It can work correctly when the request size is less than
XMaxRequestSize(display).

2. It fail when the request is a big request (that is to say, request size >
XMaxRequestSize(display)) or a bad too long request (request size >
XExtendedMaxRequestSize(display)).
Comment 2 Daniel Stone 2007-02-27 01:28:09 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 3 Corbin Simpson 2010-03-27 04:22:32 UTC

*** This bug has been marked as a duplicate of bug 4565 ***