Bug 45577 - main/image.c:1597: _mesa_convert_colors: Assertion `dstType == 0x1406' failed.
Summary: main/image.c:1597: _mesa_convert_colors: Assertion `dstType == 0x1406' failed.
Status: RESOLVED DUPLICATE of bug 45578
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 23:24 UTC by Vinson Lee
Modified: 2012-02-03 07:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2012-02-02 23:24:14 UTC
mesa: 84a1273e7fe1216a4724ab13cd061a12b48893c2 (master)

Run piglit test fbo-alphatest-formats on swrast.

$ ./bin/fbo-alphatest-formats -auto
Mesa: Initializing x86-64 optimizations
Using test set: Core formats
Testing 3
Testing 4
Testing GL_RGB
Testing GL_RGBA
Testing GL_ALPHA - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE_ALPHA - fbo incomplete (status = 0x8cdd)
Testing GL_INTENSITY - fbo incomplete (status = 0x8cdd)
Testing GL_ALPHA4 - fbo incomplete (status = 0x8cdd)
Testing GL_ALPHA8 - fbo incomplete (status = 0x8cdd)
Testing GL_ALPHA12 - fbo incomplete (status = 0x8cdd)
Testing GL_ALPHA16 - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE4 - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE8 - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE12 - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE16 - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE4_ALPHA4 - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE8_ALPHA8 - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE12_ALPHA12 - fbo incomplete (status = 0x8cdd)
Testing GL_LUMINANCE16_ALPHA16 - fbo incomplete (status = 0x8cdd)
Testing GL_INTENSITY4 - fbo incomplete (status = 0x8cdd)
Testing GL_INTENSITY8 - fbo incomplete (status = 0x8cdd)
Testing GL_INTENSITY12 - fbo incomplete (status = 0x8cdd)
Testing GL_INTENSITY16 - fbo incomplete (status = 0x8cdd)
Testing GL_R3_G3_B2
fbo-alphatest-formats: main/image.c:1597: _mesa_convert_colors: Assertion `dstType == 0x1406' failed.
Aborted (core dumped)

(gdb) bt
#0  0x00007f1d287913b5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007f1d28794b1b in __GI_abort () at abort.c:92
#2  0x00007f1d28789d2d in __GI___assert_fail (assertion=0x7f1d265b5f7a "dstType == 0x1406", 
    file=<optimized out>, line=1597, function=<optimized out>) at assert.c:81
#3  0x00007f1d2644efcd in _mesa_convert_colors (srcType=5121, src=0x7f1d25860014, dstType=32818, 
    dst=0x7f1d2509c010, count=16, mask=<optimized out>) at main/image.c:1597
#4  0x00007f1d26541f78 in convert_color_type (newType=32818, span=<optimized out>, output=<optimized out>)
    at swrast/s_span.c:959
#5  _swrast_write_rgba_span (ctx=<optimized out>, span=<optimized out>) at swrast/s_span.c:1331
#6  0x00007f1d2656583c in smooth_rgba_triangle (ctx=0xd88b30, v0=<optimized out>, v1=<optimized out>, 
    v2=0x7f1d29393658) at swrast/s_tritemp.h:819
#7  0x00007f1d26575e7b in quadfunc_rgba (ctx=0xd88b30, v0=<optimized out>, v1=1, v2=2, v3=3)
    at swrast_setup/ss_tritmp.h:232
#8  0x00007f1d264eb422 in _tnl_render_quads_verts (ctx=0xd88b30, start=<optimized out>, count=4, 
    flags=<optimized out>) at tnl/t_vb_rendertmp.h:383
#9  0x00007f1d264f3040 in run_render (ctx=0xd88b30, stage=<optimized out>) at tnl/t_vb_render.c:321
#10 0x00007f1d264e6da9 in _tnl_run_pipeline (ctx=0xd88b30) at tnl/t_pipeline.c:163
#11 0x00007f1d264e7afc in _tnl_draw_prims (ctx=<optimized out>, arrays=0xdecc48, prim=0x7fff3682a5a0, 
    nr_prims=1, ib=0x0, min_index=<optimized out>, max_index=3) at tnl/t_draw.c:523
#12 0x00007f1d264e7ee7 in _tnl_vbo_draw_prims (ctx=0xd88b30, arrays=0xdecc48, prim=0x7fff3682a5a0, 
    nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=3, tfb_vertcount=0x0)
    at tnl/t_draw.c:423
#13 0x00007f1d264d5027 in vbo_draw_arrays (ctx=0xd88b30, mode=<optimized out>, start=0, 
    count=<optimized out>, numInstances=1) at vbo/vbo_exec_array.c:635
#14 0x000000000045476c in piglit_draw_rect (x=-1, y=-1, w=0.25, h=2)
    at piglit/tests/util/piglit-util-gl.c:738
#15 0x000000000042a1d8 in alphatest (rect=0x7fff3682a6f0, alpha=0.200000003, func=513, ref=0.25)
    at piglit/tests/fbo/fbo-alphatest-formats.c:50
#16 0x000000000042a7ee in test_format (format=0x456740, baseformat=0)
    at piglit/tests/fbo/fbo-alphatest-formats.c:177
#17 0x000000000042a0a7 in fbo_formats_display (test_format=0x42a209 <test_format>)
    at piglit/tests/fbo/fbo-formats.h:611
#18 0x000000000042ae46 in piglit_display () at piglit/tests/fbo/fbo-alphatest-formats.c:281
#19 0x000000000042b551 in display () at piglit/tests/util/piglit-framework.c:56
#20 0x00007f1d28e51220 in fghRedrawWindow (window=0xd66a70) at freeglut_main.c:210
#21 fghcbDisplayWindow (window=0xd66a70, enumerator=0x7fff3682a880) at freeglut_main.c:227
#22 0x00007f1d28e54939 in fgEnumWindows (enumCallback=0x7f1d28e51120 <fghcbDisplayWindow>, 
    enumerator=0x7fff3682a880) at freeglut_structure.c:394
#23 0x00007f1d28e5165a in fghDisplayAll () at freeglut_main.c:249
#24 glutMainLoopEvent () at freeglut_main.c:1450
#25 0x00007f1d28e51f0e in glutMainLoop () at freeglut_main.c:1498
#26 0x000000000042bcc0 in main (argc=1, argv=0x7fff3682abd8)
    at piglit/tests/util/piglit-framework.c:304
(gdb) frame 3
#3  0x00007f1d2644efcd in _mesa_convert_colors (srcType=5121, src=0x7f1d25860014, dstType=32818, 
    dst=0x7f1d2509c010, count=16, mask=<optimized out>) at main/image.c:1597
1597	         ASSERT(dstType == GL_FLOAT);
(gdb) print /x dstType
$1 = 0x8032

piglit/tests/util/glew.h:1184:#define GL_UNSIGNED_BYTE_3_3_2 0x8032
piglit/tests/util/glew.h:8263:#define GL_UNSIGNED_BYTE_3_3_2_EXT 0x8032
Comment 1 Brian Paul 2012-02-03 07:20:43 UTC
This really the same bug as 45578.

*** This bug has been marked as a duplicate of bug 45578 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.