Bug 45683 - mission-control-5 crashed with SIGSEGV in g_str_hash()
Summary: mission-control-5 crashed with SIGSEGV in g_str_hash()
Status: RESOLVED DUPLICATE of bug 40283
Alias: None
Product: Telepathy
Classification: Unclassified
Component: mission-control (show other bugs)
Version: unspecified
Hardware: Other All
: medium critical
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-06 03:23 UTC by Cristian Aravena
Modified: 2012-02-06 05:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian Aravena 2012-02-06 03:23:29 UTC
Open bug in Launchpad.net:
https://bugs.launchpad.net/bugs/927313

#0  g_str_hash (v=0x0) at /build/buildd/glib2.0-2.30.0/./glib/gstring.c:142
        p = 0x0
        h = 5381
#1  0x00007f7679767f43 in g_hash_table_lookup_node (hash_return=<synthetic pointer>, key=0x0, hash_table=0x1418180) at /build/buildd/glib2.0-2.30.0/./glib/ghash.c:360
        node_hash = <optimized out>
        hash_value = <optimized out>
        have_tombstone = 0
        step = 0
        node_index = <optimized out>
        first_tombstone = 0
#2  g_hash_table_lookup (hash_table=0x1418180, key=0x0) at /build/buildd/glib2.0-2.30.0/./glib/ghash.c:1022
        node_hash = <optimized out>
        __PRETTY_FUNCTION__ = "g_hash_table_lookup"
#3  0x000000000041baa2 in mcd_dispatcher_client_needs_recovery_cb (client=0x1424e40, self=0x141d800) at mcd-dispatcher.c:683
        handler = <optimized out>
        channel = 0x1502e20
        object_path = 0x14e5ad0 "/org/freedesktop/Telepathy/Connection/butterfly/msn/cristian_40romanescu_2ecl/TextChannel1"
        properties = <optimized out>
        hname = 0x0
        channels = <optimized out>
        observer_filters = 0x14a6400
        list = 0x14aaae0
        __PRETTY_FUNCTION__ = "mcd_dispatcher_client_needs_recovery_cb"
#4  0x00007f7679c5c0a4 in g_closure_invoke (closure=0x1482530, return_value=0x0, n_param_values=1, param_values=0x14aa4e0, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.30.0/./gobject/gclosure.c:774
        marshal = 0x7f7679c5d3e0 <g_cclosure_marshal_VOID__VOID>
        marshal_data = <optimized out>
        in_marshal = <optimized out>
        __PRETTY_FUNCTION__ = "g_closure_invoke"
#5  0x00007f7679c6e02a in signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=0x1424e40, emission_return=0x0, instance_and_params=0x14aa4e0) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3272
        tmp = <optimized out>
        handler = 0x1481ed0
        accumulator = 0x0
        emission = {next = 0x0, instance = 0x1424e40, ihint = {signal_id = 45, detail = 0, run_type = G_SIGNAL_RUN_FIRST}, state = EMISSION_RUN, chain_type = 4}
        class_closure = 0x0
        hlist = 0x7f7679ea91d0
        handler_list = 0x1481ed0
        return_accu = 0x0
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}, {v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}}}
        signal_id = 45
        max_sequential_handler_number = 2189
        return_value_altered = 0
#6  0x00007f7679c776b1 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=<optimized out>) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3003
        instance_and_params = 0x14aa4e0
        signal_return_type = 4
        param_values = 0x14aa4f8
        node = 0x1414dc0
        i = <optimized out>
        n_params = 0
        __PRETTY_FUNCTION__ = "g_signal_emit_valist"
#7  0x00007f7679c77852 in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3060
        var_args = {{gp_offset = 24, fp_offset = 48, overflow_arg_area = 0x7ffff6e5f110, reg_save_area = 0x7ffff6e5f050}}
#8  0x00007f767a628ba8 in _tp_cli_dbus_properties_invoke_callback_get_all (self=0x1424e40, error=0x0, args=0x14aaa60, generic_callback=0x434370 <_mcd_client_proxy_observer_get_all_cb>, user_data=<optimized out>, weak_object=<optimized out>) at _gen/tp-cli-generic-body.h:1190
        callback = 0x434370 <_mcd_client_proxy_observer_get_all_cb>
#9  0x00007f767a62fa80 in tp_proxy_pending_call_idle_invoke (p=0x1539520) at proxy-methods.c:153
        pc = 0x1539520
        invoke = <optimized out>
        __PRETTY_FUNCTION__ = "tp_proxy_pending_call_idle_invoke"
#10 0x00007f7679779a5d in g_main_dispatch (context=0x13fe840) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:2441
        dispatch = 0x7f7679775790 <g_idle_dispatch>
        was_in_call = 0
        user_data = 0x1539520
        callback = 0x7f767a62fa10 <tp_proxy_pending_call_idle_invoke>
        cb_funcs = 0x7f7679a29670
        cb_data = 0x14a4c10
        current_source_link = {data = 0x152a2c0, next = 0x0}
        need_destroy = <optimized out>
        source = 0x152a2c0
        current = 0x14315c0
        i = <optimized out>
#11 g_main_context_dispatch (context=0x13fe840) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3011
No locals.
#12 0x00007f767977a258 in g_main_context_iterate (context=0x13fe840, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3089
        max_priority = -100
        timeout = 0
        some_ready = 1
        nfds = 0
        allocated_nfds = <optimized out>
        fds = <optimized out>
#13 0x00007f767977a792 in g_main_loop_run (loop=0x13f9bd0) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3297
        __PRETTY_FUNCTION__ = "g_main_loop_run"
#14 0x000000000040e9e5 in main (argc=<optimized out>, argv=<optimized out>) at mc-server.c:78
        mcd = 0x1405010
Comment 1 Simon McVittie 2012-02-06 05:05:53 UTC
The Launchpad report was for version 5.9.1 (please include this information when forwarding bugs, particularly if it's an older version); this crash was fixed in 5.9.3.

*** This bug has been marked as a duplicate of bug 40283 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.