Bug 45943 - [r300g] r300_emit.c:365:r300_emit_aa_state: Assertion `(aa->dest)->cs_buf' failed.
[r300g] r300_emit.c:365:r300_emit_aa_state: Assertion `(aa->dest)->cs_buf' fa...
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300
git
Other All
: medium normal
Assigned To: Default DRI bug account
https://cvs.khronos.org/svn/repos/reg...
:
: 45993 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-11 14:16 UTC by Pavel Ondračka
Modified: 2012-02-13 06:13 UTC (History)
1 user (show)

See Also:


Attachments
full backtrace (60.32 KB, text/plain)
2012-02-11 14:16 UTC, Pavel Ondračka
Details
new backtrace (43.28 KB, text/plain)
2012-02-12 09:15 UTC, Pavel Ondračka
Details
possible fix (836 bytes, patch)
2012-02-12 09:39 UTC, Marek Olšák
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Ondračka 2012-02-11 14:16:22 UTC
Created attachment 56904 [details]
full backtrace

Triggered with Firefox 10 at https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/sdk/tests/webgl-conformance-tests.html (click run tests and wait). Firefox 10 is needed earlier versions doesn't trigger this.

radeon: Cannot get a relocation in radeon_drm_cs_write_reloc.
r300: Warning: cs_count off by -6 at (r300_emit_aa_state, r300_emit.c:370)
radeon: The kernel rejected CS, see dmesg for more information.
r300_emit.c:365:r300_emit_aa_state: Assertion `(aa->dest)->cs_buf' failed.

Program received signal SIGTRAP, Trace/breakpoint trap.
_debug_assert_fail (expr=0x2c2fa6f "(aa->dest)->cs_buf", file=0x2c2fa58 "r300_emit.c", line=
    365, function=0x2c2ff77 "r300_emit_aa_state") at util/u_debug.c:281

Full backtrace attached, from dmesg:
[50370.978205] [drm:r100_cs_packet_next_reloc] *ERROR* No packet3 for relocation for packet at 13.
[50370.978211] [drm] ib[13]=0x000013A1
[50370.978214] [drm] ib[14]=0x00C30040
[50370.978217] [drm:r300_packet0_check] *ERROR* No reloc for ib[12]=0x4E80
[50370.978220] [drm] ib[11]=0x000013A0
[50370.978223] [drm] ib[12]=0x00000000
[50370.978225] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

GPU:RV530
Kernel: 3.2.3
Mesa: d5a6c172547d8964f4d4bb79637651decaf9deee
Libdrm: 2.4.31
Comment 1 Marek Olšák 2012-02-12 04:43:35 UTC
Could you please test Mesa master again?
Comment 2 Pavel Ondračka 2012-02-12 09:15:50 UTC
Created attachment 56919 [details]
new backtrace

Now it fails at the newly added assertion:
r300_render.c:1260:r300_resource_resolve: Assertion `0 && "Resource resolve is unsupported, invalid call."' failed.
Comment 3 Marek Olšák 2012-02-12 09:39:10 UTC
Created attachment 56920 [details] [review]
possible fix

Can you try this patch?
Comment 4 Pavel Ondračka 2012-02-12 09:56:06 UTC
(In reply to comment #3)
> Created attachment 56920 [details] [review] [review]
> possible fix
> 
> Can you try this patch?

Yes, that patch fixes it.
Comment 5 Marek Olšák 2012-02-12 12:40:13 UTC
Could you please test Mesa master again? The commit 094eeff19946138d6306d74e9e62af5e9d192abd should fix this.
Comment 6 Pavel Ondračka 2012-02-12 12:56:16 UTC
Fixed indeed, thank you.
Comment 7 Pavel Ondračka 2012-02-13 06:13:43 UTC
*** Bug 45993 has been marked as a duplicate of this bug. ***