Bug 46213 - [865G] Low framerate with glxgears and general low performance
Summary: [865G] Low framerate with glxgears and general low performance
Status: RESOLVED NOTABUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i830 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-17 00:43 UTC by piranna
Modified: 2012-03-03 11:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (43.62 KB, text/x-log)
2012-03-03 02:39 UTC, piranna
Details
dmesg output (no drm.debug=0x06 option) (47.90 KB, text/plain)
2012-03-03 02:43 UTC, piranna
Details
xorg.conf (2.46 KB, application/octet-stream)
2012-03-03 02:43 UTC, piranna
Details
xrandr --verbose (3.49 KB, text/plain)
2012-03-03 02:45 UTC, piranna
Details
VBIOS dump (48.00 KB, application/octet-stream)
2012-03-03 02:59 UTC, piranna
Details
dmesg (39.15 KB, text/plain)
2012-03-03 08:35 UTC, piranna
Details
Chromium scrolling (865.99 KB, text/xml)
2012-03-03 09:20 UTC, piranna
Details
Mahjongg going from window to maximized (538.18 KB, text/xml)
2012-03-03 09:21 UTC, piranna
Details
Mahjongg going from maximized to windowed (391.32 KB, text/xml)
2012-03-03 09:21 UTC, piranna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description piranna 2012-02-17 00:43:57 UTC
Bug description:
On freshly installed Ubuntu 11.10 (32 bits) on a HP D530 micro-desktop machine (referenced at http://intellinuxgraphics.org/user.html as supported on Debian by i810 driver) i got a general low performance with refreshing, giving glxgears a value of 59fps on windowed and falling to 29.5fps on fullscreen, and also making video playback unusable droping a lot of frames (and flash videos just getting frozen after one or two seconds). Disabling on Xorg.conf file Triple buffering and v-sync glxgears get raised to 400fps windowed and falling to 40fps on fullscreen, and althought video is still dropping frames, at least it's "usable", but window refreshing (from windowed to fullscreen or loading a web page) is still really slow, raising CPU to 100% doing this.

On internet it's possible to find some videos showing this chipset moving Compiz without problems (http://handyfloss.wordpress.com/2007/12/14/compiz-fusion-on-an-integrated-intel-865g-graphics-chip/). There are also some post circa 2009 of people claiming a loss of performance with this chipset after some software updates and getting CPU up to 100% like it was rendered by software althought glxinfo claims hardware aceleration is enabled, and i got the same issues with an (older) Intel i815 chipset that were later solved when transition to EXA was finished (in this case after the were solved a got an improvement from 400fps fullscreen to 4.000fps :-) ), so i think maybe it's related to this and could be a regression (at least on http://intellinuxgraphics.org/2011Q4.html say driver was not checked against 865G chipset, so it would be by-passed by accident...).

I'm not currently in front of the machine (i'm at work), but i can be able to send you any needed file or test result by demand.

System environment:
-- chipset: 865G
-- system architecture: x86 (32 bits)
-- xf86-video-intel: 2.15.901-1ubuntu2.1
-- xserver: 7.6+7ubuntu7.1
-- mesa: 7.11-0ubuntu3
-- libdrm: 2.4.26-1ubuntu1
-- kernel: 3.0.0-16-generic
-- Linux distribution: Ubuntu 11.10 x86 (32 bits)
-- Machine or mobo model: HP D530 micro-desktop
-- Display connector: VGA
Comment 1 Chris Wilson 2012-02-18 11:39:17 UTC
To put your results in context, my 855gm achieves 470fps and 55fps fullscreen (1024x768). So I judge yours to be in line with what to expect from the hardware, if a little subpar.

The secret with these gen2 devices is not to use GL at all! For instance, with video use the video overlay (by using Xv). And compiz is just going to be a waste of time and energy.
Comment 2 Eric Anholt 2012-03-02 17:52:23 UTC
The numbers in this report talking about glxgears just reflect surprise at vsync.  It is an intentional choice to avoid tearing, and not something we will change by default.  If you're excited about seeing tearing in your apps and rendering frames you'll never see, you can disable vsync in driconf.

If you can come up with a specific application that is using CPU where it didn't before and a sysprof profile showing that CPU usage (and probably INTEL_DEBUG=fallback output explaining the software fallback), then we might be able to do something.
Comment 3 piranna 2012-03-03 02:39:43 UTC
Created attachment 57960 [details]
Xorg.0.log
Comment 4 piranna 2012-03-03 02:43:10 UTC
Created attachment 57961 [details]
dmesg output (no drm.debug=0x06 option)
Comment 5 piranna 2012-03-03 02:43:55 UTC
Created attachment 57962 [details]
xorg.conf
Comment 6 piranna 2012-03-03 02:45:54 UTC
Created attachment 57963 [details]
xrandr --verbose
Comment 7 piranna 2012-03-03 02:59:41 UTC
Created attachment 57966 [details]
VBIOS dump
Comment 8 piranna 2012-03-03 03:09:48 UTC
Sorry for answer so late, this is not my main computer (it's my parents one).

Ok, after some regular usage (reading mail, surfing web...) with System Monitor at panel to see how system evolutes:

* CPU is always about 5-10% and system load about 0.5-1
* just moving the mouse CPU increases to 40%
* browser scrolling (Chromium 17.0.963.56) increase CPU to 80-100%
* loading a webpage with about 100 thumbnails freezes browser with CPU 100% about two seconds
* Gnome Mahjongg gets frozen with CPU 100% at refreshing window when going from windowed to maximized and viceversa for about 2 seconds

Also i'm thinking about try with old Ubuntu Live-CDs to look for when started the regression.

I'll try to do the sysprof this afternoon (i need to learn to use it). Where must i use the INTEL_DEBUG=fallback flag? As kernel parameter un Grub?

And no, i'm not excited about rendering frames i will not see ;-) I disabled vsync just for try and it was the only thing that did relative small YouTube videos (320x240) didn't drop frames and get frozen... :-/ I really would love to have vsync back... :-D Oh, and i don't want to use compiz (i hate it and in fact i'm using a plain no-effects Gnome panel desktop), maybe just some games like Warmux or Quake 3 (this would be a good performance test to put in perspective since my old P3 1.1GHz computer with an i815 graphic card played it very good, i'll try later). Compiz was just an example that the graphic card was enought powerful to use it without problems... :-)

P.D.: i've attached the pending log files. It keeps some with boot flags, i'll try to upload later.
Comment 9 piranna 2012-03-03 08:35:35 UTC
Created attachment 57977 [details]
dmesg
Comment 10 piranna 2012-03-03 09:20:29 UTC
Created attachment 57978 [details]
Chromium scrolling
Comment 11 piranna 2012-03-03 09:21:02 UTC
Created attachment 57979 [details]
Mahjongg going from window to maximized
Comment 12 piranna 2012-03-03 09:21:39 UTC
Created attachment 57980 [details]
Mahjongg going from maximized to windowed
Comment 13 piranna 2012-03-03 09:29:34 UTC
Added attachements for dmesg with drm.debug=0x06 flag enabled and profilings of Chromium scrolling (just this bug page) and maximizing and windowing Gnome Mahjongg.
Comment 14 Chris Wilson 2012-03-03 10:35:54 UTC
In those examples, the driver is not the bottleneck.
Comment 15 piranna 2012-03-03 10:49:52 UTC
Should i do the tests with a fresh install of Ubuntu? What would be a good example?
Comment 16 Chris Wilson 2012-03-03 11:02:33 UTC
You need to find something that performs absymally due to a mistake in the driver. Otherwise, we will continue to insist that everything is as good as it is going to get on that hardware...

The best examples will be taken from your usual workloads as that will give the greatest perceived improved, and that's the challenge you face.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.