Bug 46285 - xcompmgr 1.1.6-1 doesn't draw shadows
Summary: xcompmgr 1.1.6-1 doesn't draw shadows
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xcompmgr (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: patch, regression
Depends on:
Blocks:
 
Reported: 2012-02-19 05:36 UTC by Stephanie Schilling
Modified: 2018-08-10 20:29 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
This patch reworks the XFixesIntersectRegion calls to apply to the correct window modes. (951 bytes, patch)
2012-08-12 03:12 UTC, Brandon Gooch
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Stephanie Schilling 2012-02-19 05:36:55 UTC
OS: Arch Linux
WM: Openbox

xcompmgr 1.1.6-1 doesn't draw shadows. Downgrading to 1.1.5-1 fixes it.

I launch it with xcompmgr -cf & (in ~/.config/openbox/autostart)
Getting no error-messages (or any other messages) when I start it from the terminal.

Link to Arch Linux bug-report: 
https://bugs.archlinux.org/task/28480#comment89626
Comment 1 Danny 2012-03-03 19:34:22 UTC
I can confirm this.  I ran into the same issue when I updated this afternoon.  Downgrading to previous xcompmgr version (1.1.5) still works as expected.

Running Gentoo Linux with FVWM window manager.
Comment 2 Brad Laue 2012-03-27 08:42:59 UTC
Can confirm this issue as well using Gentoo and WindowMaker 0.95.2.
Comment 3 Brandon Gooch 2012-08-12 03:12:26 UTC
Created attachment 65447 [details] [review]
This patch reworks the XFixesIntersectRegion calls to apply to the correct window modes.
Comment 4 Pedro Ribeiro 2012-08-15 22:16:36 UTC
The patch above by Brandon Gooch seems to fix the issue for me.

I'm using Debian Wheezy with Openbox.
Comment 5 Stephanie Schilling 2012-09-08 09:20:46 UTC
I didn't patch it myself but the patched version in Arch Linux (xcompmgr 1.1.6-2) makes the shadows work normal for me. 
Thank you! :)
Comment 6 Clemens Fuchslocher 2012-09-29 14:23:32 UTC
Same problem with xcompmgr 1.1.6 and FVWM 2.6.5 under Ubuntu 12.04.

Brandons patch fixes the issue for me and others. So please release a new version of xcompmgr.

Do you know compton? https://github.com/chjj/compton
Comment 7 GitLab Migration User 2018-08-10 20:29:18 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/app/xcompmgr/issues/3.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.