Bug 46495 - no lines in pdf under Mac Lion 10.7
Summary: no lines in pdf under Mac Lion 10.7
Alias: None
Product: cairo
Classification: Unclassified
Component: pdf backend (show other bugs)
Version: 1.12.8
Hardware: Other All
: medium normal
Assignee: Adrian Johnson
QA Contact: cairo-bugs mailing list
Depends on:
Reported: 2012-02-22 21:47 UTC by Charles Doutriaux
Modified: 2018-08-25 13:57 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

trace from 10.7 Mac (cairo 1.10.2) (179.06 KB, application/x-gzip)
2012-02-22 21:47 UTC, Charles Doutriaux

Description Charles Doutriaux 2012-02-22 21:47:29 UTC
Created attachment 57500 [details]
trace from 10.7 Mac (cairo 1.10.2)

When running our software (CDAT) under Mac Lion 10.7 I don't get any lines in my pdf/ps. png works.

Additional pdf/ps crash Preview under Mac 10.7 (but the same pdf can be seen fine in 10.6)

Software runs fine under 10.6 and various Linux flavors.

Anybody runs into this?

I tried to compile cairo (1.10.2) using clang as suggested on some post. It doesn't seem to change anything.

Comment 1 Charles Doutriaux 2012-03-07 11:59:00 UTC
Updating the component in hope to get an answer, problem exists for both ps and pdf output.
Comment 2 Adrian Johnson 2012-03-07 12:59:53 UTC
I don't have a Mac so there is nothing I can do. Have you tried git master?
Comment 3 Charles Doutriaux 2012-03-08 19:28:02 UTC
Can you ask help from somebody developing the Quartz back-end?
Comment 4 Charles Doutriaux 2012-12-01 17:24:09 UTC
Any news on this? Still present under Mountain Lion and Cairo 1.12.8

Changing the component to png hoping I will get better feedback. I see the issue with pdf/ps/png, etc...

Same C code and same Cairo but compiled on Mac 10.6.8 works.

I can generate a new trace if needed. 

Comment 5 Charles Doutriaux 2012-12-01 17:25:31 UTC
By the way the "image" backend works fine (picture geenrated that way looks ok on screen)
Comment 6 GitLab Migration User 2018-08-25 13:57:22 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/cairo/cairo/issues/286.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.