Bug 46574 - FindPackageKitQt2.cmake is installed in the wrong place
Summary: FindPackageKitQt2.cmake is installed in the wrong place
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: packagekit-qt (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium minor
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-24 06:23 UTC by Eduardo Hernandez
Modified: 2018-08-21 15:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Hernandez 2012-02-24 06:23:45 UTC
Packagekit-qt2 0.6.21 installs FindPackageKitQt2.cmake under /usr/share/cmake/Modules. This effectively hides the module from cmake at runtime.

The problem is in lib/packagekit-qt2/modules/Makefile.am and lib/packagekit-qt/modules/Makefile.am .

libproxy had a similar bug: http://code.google.com/p/libproxy/issues/detail?id=163

It seems new versions of packagekit don't use these cmake files, so probably the problem went away, but in the new versions the NEWS file recommends to use 0.6.x versions for stability.

cmake version is 2.8.7-2
Linux is Arch.


To reproduce:
Create a stub CMakeLists.txt file containing

find_package(PackageKitQt2)

and run cmake <DIRECTORY WHERE ABOVE FILE EXISTS>. a warning that the module cannot be found is printed.
Comment 1 Richard Hughes 2012-02-28 01:02:19 UTC
Hmm, I wonder why we've not noticed this before... Is there any chance you could write a patch to fix this please? Thanks.
Comment 2 Richard Hughes 2018-08-21 15:52:48 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.