Bug 46591 - Firefox segfaults when visiting website, reporting Mesa error
Summary: Firefox segfaults when visiting website, reporting Mesa error
Status: RESOLVED DUPLICATE of bug 42128
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 7.11
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-24 13:33 UTC by Rick Jenkins
Modified: 2012-02-24 13:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rick Jenkins 2012-02-24 13:33:32 UTC
When attempting to visit:

www.leadnow.ca 

using Firefox 10.0.1 under Gentoo Linux, the program unexpectedly closes with the error report:

> firefox
Mesa 7.11.2 implementation error: unexpected format in _mesa_choose_tex_format()
Please report at bugs.freedesktop.org
Mesa 7.11.2 implementation error: unexpected MESA_FORMAT for renderbuffer
Please report at bugs.freedesktop.org
###!!! ABORT: Divide by zero: file /var/tmp/portage/www-client/firefox-10.0.1/work/mozilla-release/toolkit/xre/nsSigHandlers.cpp, line 174
###!!! ABORT: Divide by zero: file /var/tmp/portage/www-client/firefox-10.0.1/work/mozilla-release/toolkit/xre/nsSigHandlers.cpp, line 174
Segmentation fault
Comment 1 Kenneth Graunke 2012-02-24 13:42:15 UTC
What graphics card is this?  (lspci -nn | grep VGA would tell you.)

If it's Intel 8xx/9xx, it sounds like a duplicate of #42128.
Comment 2 Rick Jenkins 2012-02-24 13:47:02 UTC
Spot on:

fuchsia rick # lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)

My apologies for the dupe.
Comment 3 Rick Jenkins 2012-02-24 13:51:33 UTC

*** This bug has been marked as a duplicate of bug 42128 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.