Bug 4669 - Xorg hangs when dri is enabled
Xorg hangs when dri is enabled
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/other
DRI git
Other Linux (All)
: high normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-03 02:16 UTC by Marcin Kurek
Modified: 2005-10-27 06:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Kurek 2005-10-03 02:16:08 UTC
Some time ago I update my system to modular X (7.0.0 RC0 from Gentoo portage) 
and Xorg starts to hang when I have dri enabled in my xorg.conf file (http://
www.tbs-software.com/morgoth/files/private/drm/xorg.conf).

I did some tests and this problem seems to be random. Sometimes xorg starts with 
dri without any problems and sometimes it lockup the machine completly (Only 
emergency reboot help here) I use Pegasos II machine with 1GB of ram (HighMem 
enabled) and G4 1GHz CPU. My card is Radeon 9000 card with 128MB/128Bit/DVD/VIVO 
(Take a look at http://www.tbs-software.com/morgoth/files/private/drm/lspci.txt)

I enable a drm debug and notice a nice fllod in syslog with:

========
........
[drm:drm_ioctl] pid=8363, cmd=0x20006444, nr=0x44, dev 0xe200, auth=1
[drm:radeon_cp_idle]
[drm:radeon_do_cp_idle]
[drm:drm_ioctl] ret = fffffff0
........
========

The complete log can be found at (http://www.tbs-software.com/morgoth/files/
private/drm/dri-syslog.txt) also I upload the XOrg.log from faulty startup 
(http://www.tbs-software.com/morgoth/files/private/drm/Xorg.0.log)

I test using slighy patched 2.6.13 and a vanilla kernel with identical result. 
Also today I give a try to drm cvs snapshot ... same.

BTW I was able to found almost identical log (with the same problem) on net 
(http://www.gg3.net/~chutz/gentoo/xorg/kernel.log.txt), but I have no ideas who 
produce it ;(
Comment 1 Marcin Kurek 2005-10-27 23:40:34 UTC
OK, fxed by http://gate.crashing.org/~benh/radeon-memmap.diff