Bug 47203 - libxt 1.1.2 breaks xscreensaver
Summary: libxt 1.1.2 breaks xscreensaver
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xt (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard: 2012BRB_Reviewed
Keywords: regression
Depends on:
Blocks: X11R7.7
  Show dependency treegraph
 
Reported: 2012-03-11 07:38 UTC by Dave
Modified: 2012-03-12 18:47 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave 2012-03-11 07:38:30 UTC
libxt 1.1.2 breaks some themes in xscreensaver.  For example select bumps and xscreensaver displays corrupted graphics and reports an error "Warning: Select failed; error code 5".  Downgrading to the previous version of libxt solves the problem.  Rebuiling xscreensaver has no effect.
Comment 1 Alan Coopersmith 2012-03-11 09:43:14 UTC
I suspect this might be due to the change in
http://cgit.freedesktop.org/xorg/lib/libXt/commit/?id=70bb9e28d37fff4ead4d0a2c672af77059765fa4
that Jeremy applied to fix bug 20048, since that appears to the be the 
change closest to the Select() error handling code in this release.
Comment 2 Jeremy Huddleston Sequoia 2012-03-11 16:13:03 UTC
If that is the case, I'm curious what fd->revents and fd->events are set to, but lets first confirm that this is the cause.  Dave, can you please build libXt-1.1.2 with 70bb9e28d37fff4ead4d0a2c672af77059765fa4 reverted?
Comment 3 Dave 2012-03-12 00:35:35 UTC
I will do so this evening when I get home from work.
Comment 4 Christian Hesse 2012-03-12 01:40:29 UTC
I can confirm the reverting 70bb9e28d37fff4ead4d0a2c672af77059765fa4 fixes it for me.
Comment 5 Dave 2012-03-12 13:57:42 UTC
I can also confirm that this fixes it.
Comment 6 Jeremy Huddleston Sequoia 2012-03-12 17:34:25 UTC
Ok, then can you tell me what fd->revents and fd->events are set to?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.