Bug 48051 - Document is rendered extremely slowly
Summary: Document is rendered extremely slowly
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) other
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-29 08:54 UTC by thomas
Modified: 2018-08-21 10:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Rendering of this pdf is extremely slow (114.99 KB, application/pdf)
2012-03-29 08:54 UTC, thomas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thomas 2012-03-29 08:54:53 UTC
Created attachment 59230 [details]
Rendering of this pdf is extremely slow

The attached test document renders extremely slowly in evince and okular.

poppler version (openSUSE 12.1) is 0.18.0
Comment 1 Thomas Freitag 2012-05-02 00:04:05 UTC
I rendered it with my actual version (includes patch for bug 13497) in less than one second.
Comment 2 thomas 2012-05-02 12:45:05 UTC
I tested it with poppler 0.18.4 and okular. The low-res version is rendered quickly, which is already a huge improvement as the document is usable. The high-res version, however, still takes quite long to render/display on my system.
Comment 3 Albert Astals Cid 2012-05-10 10:15:52 UTC
In 0.20 renders in 34 msec in splash but takes 66 sec in cairo, reassigning.

BTW thomasf i think you did not mean bug 13497 since that's not a poppler bug :D
Comment 4 Thomas Freitag 2012-05-10 10:39:14 UTC
(In reply to comment #3)
> In 0.20 renders in 34 msec in splash but takes 66 sec in cairo, reassigning.
> 
> BTW thomasf i think you did not mean bug 13497 since that's not a poppler bug
> :D

Yes, You're true: I mean't bug 13487, which removes unneccessary transparency groups, sorry :-(
Comment 5 Thomas Freitag 2012-05-14 03:26:31 UTC
Oh, I missed that it was "cairo only" problem. But also with the actual git master pdfcairo of attachment 59230 [details] renders it in less than 1 second. So I just wonder, looking at a PDF page, why the cairo rendering of just some text should take so much time. Do I use the wrong PDF for my tests?
Comment 6 Adrian Johnson 2012-05-14 03:41:53 UTC
The slow rendering is caused by TextOutputDev, not CairoOutputDev. Evince extracts the text at the same time as it renders pages. pdftocairo only uses CairoOutputDev.
Comment 7 GitLab Migration User 2018-08-21 10:47:33 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/376.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.