Bug 48120 - GL_EXT_texture_sRGB_decode still broken
GL_EXT_texture_sRGB_decode still broken
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Ian Romanick
:
: 40509 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 06:11 UTC by andreas.sturmlechner
Modified: 2012-07-31 18:15 UTC (History)
3 users (show)

See Also:


Attachments
screenshot of civ4 on wine-1.3.15 with mesa-7.11.2 (162.96 KB, image/jpeg)
2012-03-31 06:11 UTC, andreas.sturmlechner
Details
output of glxinfo32 with latest mesa git (12.30 KB, text/plain)
2012-03-31 06:33 UTC, andreas.sturmlechner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas.sturmlechner 2012-03-31 06:11:03 UTC
Created attachment 59307 [details]
screenshot of civ4 on wine-1.3.15 with mesa-7.11.2

My problem appears to be identical to bug 35373. After all, it was the same with the mesa version that was supposed to have it fixed.

The system:
Gentoo amd64 multilib, kernel-3.3, GMA4500MHD
Intel userspace driver version: git

Affected/tested mesa versions:
7.11.2, 8.0, git

The problem:
Starting Civilization IV from wine-1.3.15 onwards (the first version to use that extension) it paints too dark images as soon as accessing the main menu.

Temporary solution (as in above bug 35373):
MESA_EXTENSION_OVERRIDE="-GL_EXT_texture_sRGB_decode"


There is an option in wine-1.3.15 to disable hardware pixel- and vertexshader, turned off it renders graphics less dark, but still not right.
Comment 1 andreas.sturmlechner 2012-03-31 06:33:05 UTC
Created attachment 59308 [details]
output of glxinfo32 with latest mesa git
Comment 2 Md Imam Hossain 2012-04-01 15:33:02 UTC
still present in Mesa 8 and Mesa 8-devel (git)
Comment 3 Gregory 2012-05-21 09:16:27 UTC
I have this problem on i915 too. So MESA_EXTENSION_OVERRIDE="-GL_EXT_texture_sRGB_decode" is not working.
Comment 4 network723 2012-05-29 22:34:31 UTC
Have the same problem on Sandy Bridge gen2. Too dark s3tc-compressed textures in most of games on wine. Disabling s3tc makes some textures to bright. 

Disabling GL_EXT_texture_sRGB_decode helps.
Comment 5 network723 2012-05-29 22:46:26 UTC
Have the same problem on Sandy Bridge gen2. Too dark s3tc-compressed textures in most of games on wine. Disabling s3tc makes some textures too bright. 

Disabling GL_EXT_texture_sRGB_decode helps.
Comment 6 Eric Anholt 2012-07-30 20:14:13 UTC
Care to try:

http://lists.freedesktop.org/archives/mesa-dev/2012-July/024917.html
Comment 7 andreas.sturmlechner 2012-07-30 20:40:43 UTC
Thx, I tried it immediately (patched mesa-8.1_rc1_pre20120724) but without success. Builds fine, but the same graphics issue as before.
Comment 8 andreas.sturmlechner 2012-07-30 21:05:59 UTC
Pardon, I failed. :) After patching the actually relevant mesa-32bit packge it seems to be FIXED! :D
Comment 9 Eric Anholt 2012-07-30 21:08:26 UTC
*** Bug 40509 has been marked as a duplicate of this bug. ***
Comment 10 Eric Anholt 2012-07-31 18:15:27 UTC
Thanks!

commit 19bd5936af7278c0cce0728e8d6dec1a951eaf58
Author: Eric Anholt <eric@anholt.net>
Date:   Mon Jul 30 11:04:57 2012 -0700

    i965: Add support for GL_SKIP_DECODE_EXT on other SRGB formats.
    
    Fixes some failures in getteximage-formats.
    
    v2: Remove stray include, and drop extra test for encoding == GL_SRGB --
        _mesa_get_srgb_format_linear() returns the same format if it wasn't SRGB.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=48120
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org> (v1)
    NOTE: This is a candidate for the 8.0 branch.