Bug 48180 - Unplug HDMI - xrandr gives blank screen and "Configure crtc 0 failed"
Summary: Unplug HDMI - xrandr gives blank screen and "Configure crtc 0 failed"
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xrandr (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Keith Packard
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-02 02:39 UTC by Jamie Kitson
Modified: 2018-08-11 04:36 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jamie Kitson 2012-04-02 02:39:49 UTC
With my Asus Zenbook UX31E (Intel HD Graphics 3000) when I plug an HDMI device in and run xrandr
everything is fine and both laptop and external HDMI monitor work.
However, when I disconnect the HDMI device and run xrandr again it
gives the following errors and both screens go off.

[jamie at jamie-laptop ~]$ xrandr --output eDP1 --auto --output HDMI1
--auto --above eDP1
xrandr: Configure crtc 0 failed
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  150 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Serial number of failed request:  38
  Current serial number in output stream:  38

[jamie at jamie-laptop ~]$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1980, maximum 8192 x 8192
eDP1 connected (normal left inverted right x axis y axis)
   1600x900       60.0 +
   1024x768       60.0
   800x600        60.3     56.2
   640x480        59.9
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

When both are connected and working:

[jamie at jamie-laptop ~]$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1980, maximum 8192 x 8192
eDP1 connected 1600x900+0+1080 (normal left inverted right x axis y
axis) 293mm x 164mm
   1600x900       60.0*+
   1024x768       60.0
   800x600        60.3     56.2
   640x480        59.9
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+0+0 (normal left inverted right x axis y
axis) 475mm x 267mm
   1920x1080      60.0*+
   1600x1200      60.0
   1680x1050      60.0
   1280x1024      60.0
   1440x900       59.9
   1280x960       60.0
   1280x720       60.0
   1024x768       60.0
   800x600        60.3
   640x480        60.0
   720x400        70.1
DP1 disconnected (normal left inverted right x axis y axis)
Comment 1 Jamie Kitson 2013-01-04 10:45:46 UTC
Same behaviour on my UX32VD.
Comment 2 Jamie Kitson 2013-01-04 10:47:03 UTC
(In reply to comment #1)
> Same behaviour on my UX32VD.

Sorry ignore that, I thought I was commenting on another bug.
Comment 3 GitLab Migration User 2018-08-10 20:33:48 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/app/xrandr/issues/14.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.