Bug 48241 - [SNB] rendering issues in minecraft GLSL mod.
Summary: [SNB] rendering issues in minecraft GLSL mod.
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-03 04:51 UTC by Peter Kuhmann
Modified: 2019-09-25 18:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Kuhmann 2012-04-03 04:51:20 UTC
Today I wanted to test a mod for the game "Minecraft". It's a shader mod (GLSL).

LINK: http://www.minecraftforum.net/topic/940974-123sonic-ethers-unbelievable-shaders-glsl-shaders-dynamic-shadows-more/

When I started Minecraft I noticed that there were some transperency bugs. I think this isn't normal.

I made some screenshots (one with the shader mod and one screenshot without).

→ without shaders: http://www.mediafire.com/imageview.php?quickkey=ffzdpnzpemdxi46

→ with shaders: http://www.mediafire.com/imageview.php?quickkey=5wujw9516dwy6sj

P.s.: I have a Lenovo-Thunkpad-Edge E520, i5-2430m, Ubuntu12.04-Beta2

Hope this will help someone,

For more questions :  halbblutplins@googlemail.com
Comment 1 Eric Anholt 2013-11-28 00:34:44 UTC
An apitrace of the problem would help a lot -- this thing looks like it takes a bit of setup, and I'm not convinced I'd be replicating your environment.
Comment 2 Tapani Pälli 2014-12-02 06:45:33 UTC
I tried to reproduce this but unfortunately could not figure out how to use these GLSL mods or if they work anymore (?) with modern Minecraft (1.8.1 atm). Peter, are you still able to use these and does it work for you now?
Comment 3 MWATTT 2014-12-22 15:03:09 UTC
There are two compenents for the Minecraft's shader mod: the mod and shaderpacks.
The mod is here: http://www.minecraftforum.net/forums/mapping-and-modding/minecraft-mods/1286604-shaders-mod-updated-by-karyonix

The last version supports Minecraft 1.8 (but not 1.8.1).

The mod can be installed by executing the .jar file. It will create a new profile.

Most shaderpacks can be found on the first post from the link above. The most used shaderpack is SEUS : http://www.minecraftforum.net/forums/mapping-and-modding/minecraft-mods/1280299-sonic-ethers-unbelievable-shaders-v10-1. 
Shaderpacks must be placed on /home/USER/.minecraft/shaderpacks (the folder is automatically created when the mod is started). 

The main problem I've encountred with this one is a shader compilation failure (affect all OpenSource drivers). The SEUS's shaderpack use texture2Dlod in fragment shader without enabling any extensions, which AFAIK sould not be used on GLSL 1.20. A workaround is to bump all affected shaders to 1.30. The driconf option "force_glsl_extensions_warn" semms to be a simpler workaround.

There are also a lot framebuffer related problem on SandyBridge with some shaderpacks, including SEUS, which doesn't happend on others drivers (r600g). That lead to a black screen.

About apitrace, can I send a trace which is something like 200Mo?
Comment 4 Matt Turner 2017-03-22 16:52:43 UTC
Can you still reproduce this with Mesa 17.0?

If you can, please make an apitrace and upload it to something like Google Drive.
Comment 5 GitLab Migration User 2019-09-25 18:49:13 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1384.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.