Bug 48441 - gnome-control-center crashes
Summary: gnome-control-center crashes
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 8.0
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
: 49039 49083 49212 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-08 10:31 UTC by Alen Skondro
Modified: 2012-07-01 06:57 UTC (History)
10 users (show)

See Also:
i915 platform:
i915 features:


Attachments
gdb backtrace (8.06 KB, text/plain)
2012-04-08 10:31 UTC, Alen Skondro
Details
Host.inc from llvm-3.0 (1.93 KB, text/plain)
2012-04-23 10:26 UTC, Alen Skondro
Details
GDB output (1.13 KB, text/plain)
2012-04-23 13:11 UTC, Alen Skondro
Details
valgrind log (33.46 KB, text/plain)
2012-04-24 02:15 UTC, Serg Sergiu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alen Skondro 2012-04-08 10:31:47 UTC
Created attachment 59651 [details]
gdb backtrace

I'm using gnome 3.4 on arch linux (x86_64) and when starting the control-center, it crashes.

The error in the gdb trace points to the mesa (nouveau_dri.so) component.

The backtrace log is in the attachment .

Additional information regarding this bug can be found on 
https://bugs.archlinux.org/task/29202
Comment 1 Ionut Biru 2012-04-10 09:06:59 UTC
We have users that told us that is not related only to nouveau. Ati is involved as well and the main developer of clutter said that it might be a bug in llvmpipe or its usage.
Comment 2 nobled 2012-04-23 09:29:05 UTC
llvm::sys::getHostTriple() is kind of a weird place to crash. What version of LLVM is it, and can you build it with debug symbols before linking mesa against it? Which line in LLVM's source is calling std::string::append()?
Comment 3 Alen Skondro 2012-04-23 10:26:08 UTC
Created attachment 60489 [details]
Host.inc from llvm-3.0
Comment 4 Alen Skondro 2012-04-23 10:26:34 UTC
It's version 3.0.

I already built a debug version of LLVM and linked mesa against it but could not really see what exactly the error is since some important variables were optimized and I couldn't read their values. 

But the string::append call (via overloaded operator I guess) happens in llvm/lib/Support/Unix/Host.inc, line 50.
Comment 5 Ionut Biru 2012-04-23 10:29:09 UTC
You can compile llvm and mesa with -g -O0
Comment 6 Alen Skondro 2012-04-23 13:11:20 UTC
Created attachment 60495 [details]
GDB output

This is what I got so far.
Even though I compiled with -g -O0 parameters, there are still variables marked as "optimized out".
Comment 7 Michel Dänzer 2012-04-24 00:49:44 UTC
*** Bug 49083 has been marked as a duplicate of this bug. ***
Comment 8 Ionut Biru 2012-04-24 00:51:09 UTC
We have couples of valgrid logs
https://bugs.archlinux.org/task/29202?getfile=8642
Comment 9 Michel Dänzer 2012-04-24 00:53:34 UTC
FWIW, the environment variable DRAW_USE_LLVM=0 should work around the crash at a potential performance penalty.
Comment 10 Raphael Rochet 2012-04-24 01:02:29 UTC
Stange enough, I experience this crash with ati driver.

And there's no crash if using clutter-gtk-1.0.4-1.

That's not a fix of course ... just wanted to note it here in case it matters.
Comment 11 Raphael Rochet 2012-04-24 01:06:05 UTC
(In reply to comment #9)
> FWIW, the environment variable DRAW_USE_LLVM=0 should work around the crash at
> a potential performance penalty.

Tried to run "DRAW_USE_LLVM=0 gnome-control-center" but still crashing.
Comment 12 Alen Skondro 2012-04-24 01:21:29 UTC
try MALLOC_CHECK_=1 gnome-control-center
Comment 13 Raphael Rochet 2012-04-24 01:40:04 UTC
(In reply to comment #12)
> try MALLOC_CHECK_=1 gnome-control-center

Damned. Worked, got 10+ errors like this :
*** glibc detected *** gnome-control-center: free(): invalid pointer: 0x00007f36260d74d8 ***
Comment 14 Serg Sergiu 2012-04-24 02:15:53 UTC
Created attachment 60515 [details]
valgrind log
Comment 15 Pascal S 2012-04-24 12:57:41 UTC
Same behaviour as #13 here, using radeon driver on 9600 card.
Comment 16 zebulon 2012-04-24 13:01:13 UTC
using
nouveau-dri 8.0.2-1
xf86-video-nouveau 0.0.16_git20120210-1
on archlinux 32 bits

DRAW_USE_LLVM=0 gnome-control-center
crashes too
but 
MALLOC_CHECK_=1 gnome-control-center
works
Comment 17 Alex Deucher 2012-04-27 05:56:02 UTC
*** Bug 49212 has been marked as a duplicate of this bug. ***
Comment 18 hadrons123 2012-04-30 18:28:21 UTC
I 've been using Arch Linux and I had this issue when i  moved to Gnome 3.4. with control center at 3.4.1.1. 

Unfortunately I had to reinstall my system Yesterday and Now gnome-control-center works fine without a glitch.

My original Arch linux post.
https://bbs.archlinux.org/viewtopic.php?id=140131
Comment 19 Raphael Rochet 2012-05-07 14:15:01 UTC
It is fixed for me in last update.
( ArchLinux 64bits / gnome-control-center 3.4.1-2 )
Comment 20 Star Brilliant 2012-05-07 21:36:02 UTC
(In reply to comment #19)
> It is fixed for me in last update.
> ( ArchLinux 64bits / gnome-control-center 3.4.1-2 )

32bits also worked fine.
Comment 21 Bastien Nocera 2012-06-18 03:27:14 UTC
It wasn't fixed, it was worked around:
https://plus.google.com/104877287288155269055/posts/grHDgRNc1gi
Comment 22 Bastien Nocera 2012-06-18 10:06:23 UTC
https://bugs.webkit.org/show_bug.cgi?id=89358
Comment 23 Emil Velikov 2012-07-01 06:57:09 UTC
*** Bug 49039 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.