Bug 48748 - [snb] MapsGL causes display hangs
Summary: [snb] MapsGL causes display hangs
Status: RESOLVED DUPLICATE of bug 47535
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-15 21:58 UTC by Arun Raghavan
Modified: 2012-05-04 08:55 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
i915_error_state (2.14 MB, application/octet-stream)
2012-04-15 21:58 UTC, Arun Raghavan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arun Raghavan 2012-04-15 21:58:48 UTC
Created attachment 60044 [details]
i915_error_state

On Firefox 11.0, if I enable MapsGL with Google Maps and then try to zoom in/out, my display freezes for a few seconds, the screen blanks, and then resumes functioning. dmesg output shows this:

[ 5216.319360] ALSA sound/pci/hda/hda_codec.c:1477 hda_codec_cleanup_stream: NID=0x2
[ 5716.827756] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 5716.827767] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[ 5716.832142] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 3198688 at 3198676, next 3198689)

I'm attaching i915_error_state in case it is useful.

My hardware is a late 2011 MacBookPro (8.2).

lspci output for the graphics card:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Software:
 Kernel: 3.3.2 (with one patch to the i915 driver to make things actually -- https://github.com/fooblahblah/linux-mainline-efi-lvds/blob/master/lvds_dual_channel.patch)
 X.org server: 1.12.0
 xf86-video-intel: 2.18.0
 libdrm: 2.4.33
Comment 1 Kenneth Graunke 2012-05-04 08:55:19 UTC

*** This bug has been marked as a duplicate of bug 47535 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.