Bug 4924 - Wrong font names
Summary: Wrong font names
Status: RESOLVED FIXED
Alias: None
Product: fontconfig
Classification: Unclassified
Component: library (show other bugs)
Version: 2.3
Hardware: All Linux (All)
: highest blocker
Assignee: Keith Packard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 8100 12917
  Show dependency treegraph
 
Reported: 2005-10-29 09:17 UTC by bugzilla
Modified: 2007-10-25 11:50 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
FC_DEBUG=384 fc-cache -f (1.32 MB, text/plain)
2006-11-05 06:41 UTC, bugzilla
Details
right looking list of futura fonts (46.28 KB, image/jpeg)
2006-11-08 02:32 UTC, bugzilla
Details
wrong looking list of futura fonts (39.47 KB, image/jpeg)
2006-11-08 02:32 UTC, bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2005-10-29 09:17:58 UTC
With fontconfig 2.2.3 my Futura fonts where schown right as:
Futura BdCn BT
Futura BdCn BT, Italic
Futura Bk BT
Futura Bk BT, Italic
FuturaBlack BT
Futura Hv BT
Futura Hv BT, Italic
Futura Lt BT
Futura Lt BT, Italic
Futura LtCn BT
Futura Md BT
Futura Md BT, Bold
Futura Md BT, Bold Italic
Futura Md BT, Italic
Futura MdCn BT
Futura XBlk BT
Futura XBlkCn BT
Futura XBlkCnlt BT
Futura XBlklt BT

Now with fontconfig 2.3.2 the list is unusable as the font names are as follows:

Futura
Futura
Futura
Futura
Futura
FuturaBlack BT Semi-Expanded
Futura Bold
Futura Bold Italic
Futura Condensed
Futura Condensed
Futura Condensed
Futura Condensed
Futura Italic
Futura Italic
Futura Italic
Futura Italic
Futura Italic
Futura Italic Condensed
Futura Italic Condensed
Comment 1 Gérard Milmeister 2006-03-23 03:22:43 UTC
I can confirm this on Fedora Core 5. I normally use the
Zurich BT family, which is completely collapsed and no
longer usable.
Comment 2 Patrick Lam 2006-04-16 15:44:48 UTC
I'm not quite sure how I can address these bugs, seeing as how I don't have
access to any of these BT fonts...
Comment 3 Keith Packard 2006-09-01 11:09:46 UTC
Can you stick the mis-interpreted font files in a new directory and
provide the output of:

$ FC_DEBUG=384 fc-cache -f <path-to-new-directory>

That should help see where fontconfig is mis-interpreting the data in the fonts.
Comment 4 Keith Packard 2006-09-02 20:19:09 UTC
At least for Zurich, the variants are correctly listed in the style field, and
Gnome applications appear to be able to select the variants correctly using the
font selection dialog.
Comment 5 bugzilla 2006-11-05 06:41:15 UTC
Created attachment 7656 [details]
FC_DEBUG=384 fc-cache -f

This is the FC_DEBUG=384 fc-cache -f procedure for my Futura (and other) fonts
that still do not work.
Comment 6 bugzilla 2006-11-05 06:42:17 UTC
This bug is still valid for my Futura fonts.
Comment 7 Keith Packard 2006-11-05 12:36:12 UTC
I don't understand what you expect to see; fontconfig is correctly extracting
both listed family names (futura and, e.g., futura lt BT). Either name should
get matched.
Comment 8 bugzilla 2006-11-08 02:32:12 UTC
Created attachment 7702 [details]
right looking list of futura fonts
Comment 9 bugzilla 2006-11-08 02:32:57 UTC
Created attachment 7703 [details]
wrong looking list of futura fonts
Comment 10 bugzilla 2006-11-08 02:36:00 UTC
(In reply to comment #7)
> I don't understand what you expect to see; fontconfig is correctly extracting
> both listed family names (futura and, e.g., futura lt BT). Either name should
> get matched.
> 

In the attachments I created you can see that with the current version of
fontconfig font names oviously look wrong.

The attachment where the names look right was created with fontconfig 2.2.3
Comment 11 Keith Packard 2006-11-08 08:34:12 UTC
Fontconfig is correctly reporting the names present in the font file, and the
application is failing to select the one you want to see. You can either fix the
application or adjust the names presented by fontconfig by reconfiguring
fontconfig using the new <match target="scan"> element.
Comment 12 bugzilla 2006-11-08 09:31:38 UTC
May I add that all applications using fontconfig display a wrong list.
Comment 13 Mike FABIAN 2007-03-16 05:55:49 UTC
Recently, fontconfig seems to list the two different family names in
the Futura fonts in different order than before:

openSUSE 10.2 with original fontconfig as distributed with openSUSE 10.2:

mfabian@baker:~$ cat /etc/SuSE-release 
openSUSE 10.2 (i586)
VERSION = 10.2
mfabian@baker:~$ rpm -q fontconfig 
fontconfig-2.4.1-19
mfabian@baker:~$ fc-list Futura
Futura,Futura Hv BT:style=Heavy Italic
Futura,Futura BdCn BT:style=Bold
Futura:style=Condensed Medium
Futura,Futura Md BT:style=Bold Italic
Futura:style=Condensed ExtraBold
Futura,Futura Bk BT:style=Book Italic
Futura,Futura XBlkCnIt BT:style=Extra Black Italic
Futura:style=Medium Italic
Futura,Futura Lt BT:style=Light Italic
Futura,Futura LtCn BT:style=Light
Futura,Futura Md BT:style=Medium Italic
mfabian@baker:~$ 

openSUSE 10.2 with fontconfig updated from
http://software.opensuse.org/download/M17N/openSUSE_10.2/

mike@nozomi:~$ cat /etc/SuSE-release 
openSUSE 10.2 (X86-64)
VERSION = 10.2
mike@nozomi:~$ rpm -q fontconfig
fontconfig-2.4.2-15.1
mike@nozomi:~$ fc-list Futura
Futura Hv BT,Futura:style=Heavy Italic
Futura BdCn BT,Futura:style=Bold
Futura:style=Condensed Medium
Futura Md BT,Futura:style=Bold Italic
Futura:style=Condensed ExtraBold
Futura Bk BT,Futura:style=Book Italic
Futura XBlkCnIt BT,Futura:style=Extra Black Italic
Futura:style=Medium Italic
Futura Lt BT,Futura:style=Light Italic
Futura LtCn BT,Futura:style=Light
Futura Md BT,Futura:style=Medium Italic
mike@nozomi:~$ 

I.e. between fontconfig 2.4.1 and fontconfig 2.4.2, the order
of the listing of the two family names has changed. 

Matthias Bachert <bugzilla@mbachert.de> reported that this solved
his problem, see also 

http://bugzilla.novell.com/show_bug.cgi?id=218246




Comment 14 Behdad Esfahbod 2007-10-25 08:11:01 UTC
Keith, anything to fix here?
Comment 15 Keith Packard 2007-10-25 11:50:06 UTC
It looks like the name reordering in 2.4.2 solved this problem; I'm going to mark it as fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.