Bug 4928 - modular x.org doesn't compile on alpha
modular x.org doesn't compile on alpha
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Server/General
unspecified
Alpha Linux (All)
: high normal
Assigned To: Xorg Project Team
:
: 5096 (view as bug list)
Depends on:
Blocks: 1690
  Show dependency treegraph
 
Reported: 2005-10-30 02:09 UTC by Stefaan
Modified: 2005-12-08 11:23 UTC (History)
2 users (show)

See Also:


Attachments
Two fixes put together in a simple patch (780 bytes, patch)
2005-11-16 19:08 UTC, Stefaan
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Stefaan 2005-10-30 02:09:56 UTC
cd hw/xfree86/os-support/linux
1)
It seems an error slipped into the patch I submitted for bug #4511.  It results
in Makefile parsing errors.  Sorry about that :(  The patch adding the necessary
'\' is included here:
--- Makefile.am 2005-10-17 09:18:58 +0200
+++
/var/tmp/portage/xorg-server-0.99.2-r1/work/xorg-server-0.99.2/hw/xfree86/os-support/linux/Makefile.am
     2005-10-30 09:47:48 +0100
@@ -4,8 +4,8 @@
 PLATFORM_PCI_SUPPORT = $(srcdir)/../shared/ia64Pci.c
 endif
 if LINUX_ALPHA
-PLATFORM_PCI_SUPPORT = lnx_ev56.c
-       $(srcdir)/lnx_axp.c
+PLATFORM_PCI_SUPPORT = lnx_ev56.c \
+       $(srcdir)/lnx_axp.c \
        $(srcdir)/../shared/xf86Axp.c
 endif

2)
An include file that I believe was found by the build system earlier, is not
found anymore.  (../shared/xf86Axp.h)  
--- lnx_axp.c   2005-07-03 10:53:46 +0200
+++
/var/tmp/portage/xorg-server-0.99.2-r1/work/xorg-server-0.99.2/hw/xfree86/os-support/linux/lnx_axp.c
       2005-10-30 10:13:06 +0100
@@ -9,7 +9,7 @@
 #include "os.h"
 #include "xf86.h"
 #include "xf86Priv.h"
-#include "xf86Axp.h"
+#include "shared/xf86Axp.h"

 axpDevice lnxGetAXP(void);

I believe the same problem affects lnx_ia64.c, where #include "ia64Pci.h" is
attempted, but I haven't got an ia64 to actually confirm that.  

Thanks!
Comment 1 Stefaan 2005-11-16 19:08:57 UTC
Created attachment 3815 [details] [review]
Two fixes put together in a simple patch

Just a reminder. This short patch applies cleanly against
http://xorg.freedesktop.org/releases/X11R7.0-RC0/everything/xorg-server-0.99.3.tar.bz2
Comment 2 ajax at nwnk dot net 2005-11-19 09:37:58 UTC
*** Bug 5096 has been marked as a duplicate of this bug. ***
Comment 3 ajax at nwnk dot net 2005-11-19 09:41:51 UTC
applied the modular build part of this.

can you verify that 6.9rc2 plus the change to lnx_axp.c still builds?  i don't
want to break monolith builds just to fix modular builds.
Comment 4 Stefaan 2005-11-20 04:36:14 UTC
I used http://xorg.freedesktop.org/snapshots/xorg-x11-6.8.99.15.tar.bz2, well,
at least the Gentoo-package associated with that.  And I disabled compiling
$(KBDSRC) in the directory that also contains lnx_axp.c (sorry, but something
went wrong in linux/keyboard.h, and I don't know what, this is all irrelevant
probably, but being thorough is probably better).

I repeatedly applied and dis-applied the patch for lnx_axp.c, and recompiled
lnx_axp.o, it gave me no problems at all.
Comment 5 Donnie Berkholz 2005-12-04 05:48:44 UTC
Still waiting on the other half of the patch..
Comment 6 ajax at nwnk dot net 2005-12-09 06:23:09 UTC
monolith side applied, thanks!