Bug 49309 - R600_STREAMOUT is broken
Summary: R600_STREAMOUT is broken
Status: RESOLVED NOTABUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R600 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-30 11:26 UTC by Matteo Rapone
Modified: 2012-04-30 16:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
glxinfo output (24.99 KB, application/octet-stream)
2012-04-30 11:26 UTC, Matteo Rapone
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Rapone 2012-04-30 11:26:20 UTC
Created attachment 60802 [details]
glxinfo output

I use drivers from this PPA: https://launchpad.net/~oibaf/+archive/graphics-drivers/. xserver-xorg-video-ati version is 1204181041.0bda30, mesa version is 1204271238.6af4c9.

I don't know when it has started but yesterday I discovered that "OpenGL version string" reports OGL 2.1 instead of 3.0 while using R600_STREAMOUT and R600_GLSL130.

My GPU is a AMD Radeon HD6570 (TURKS Pro, Northern Islands). If you need other information, please let me know.
Comment 1 Marek Olšák 2012-04-30 12:12:08 UTC
So what's the issue? The GL version? There's a new requirement for GL3: 4x multisampling.
Comment 2 Alexandre Demers 2012-04-30 15:41:04 UTC
(In reply to comment #1)
> So what's the issue? The GL version? There's a new requirement for GL3: 4x
> multisampling.

If Matteo is interested, it's Mesa's commit 8e90913e9f99ff3296a3c3da36e73cd2d4730269
mesa: require GL_MAX_SAMPLES >= 4 for GL 3.0
    
    As noted in commit i965: Claim to support 4 multisamples on gen6+.,
    this was missing before.
    
    NOTE: This is a candidate for the 8.0 branch.
    
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>


So as you were pointing Marek, this is not a bug and it should be closed as so.
Comment 3 Matteo Rapone 2012-04-30 16:19:01 UTC
So is it a missing functionality? Thank you. Sorry if I've wasted your time.
Comment 4 Alex Deucher 2012-04-30 16:34:16 UTC
GL3 requires MSAA which is not yet supported.  GL3 was mistakenly enabled without it initially.  Dave has a branch with initial support which will be merged when ready:
http://cgit.freedesktop.org/~airlied/mesa/log/?h=r600g-ms


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.