Bug 49518 - [GMBUS regression] Black screen on MacBookPro 8,2 (15") since e646d57
Summary: [GMBUS regression] Black screen on MacBookPro 8,2 (15") since e646d57
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Daniel Vetter
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-04 22:33 UTC by Julian Simioni
Modified: 2017-07-24 23:01 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Dmesg output (90.03 KB, text/plain)
2012-05-04 22:40 UTC, Julian Simioni
no flags Details
intel_reg_dumper output (11.29 KB, text/plain)
2012-05-04 22:40 UTC, Julian Simioni
no flags Details
working dmesg output from 7a39a9d (141.29 KB, application/octet-stream)
2012-05-06 02:51 UTC, Julian Simioni
no flags Details
broken dmesg output from e646d57 (137.42 KB, application/octet-stream)
2012-05-06 02:53 UTC, Julian Simioni
no flags Details
kernel config (same for both broken and working) (74.73 KB, application/octet-stream)
2012-05-06 02:56 UTC, Julian Simioni
no flags Details
dmesg output booting with edp-power-sequencing-fix.patch (138.57 KB, application/octet-stream)
2012-05-08 01:34 UTC, Julian Simioni
no flags Details
intel_reg_dumper output booting with edp-power-sequencing-fix.patch (11.29 KB, application/octet-stream)
2012-05-08 01:34 UTC, Julian Simioni
no flags Details
don't return -ENXIO (1.16 KB, patch)
2012-05-10 04:22 UTC, Daniel Vetter
no flags Details | Splinter Review
improved patch after review (2.98 KB, patch)
2012-05-20 11:25 UTC, Daniel Vetter
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Simioni 2012-05-04 22:33:46 UTC
Since commit e646d57 booting my 15" MacbookPro results in a black screen. I don't believe this is related to the LVDS channels which was fixed a few commits previous, but a new issue. Please let me know if any additional information is needed.
Comment 1 Julian Simioni 2012-05-04 22:40:12 UTC
Created attachment 61064 [details]
Dmesg output
Comment 2 Julian Simioni 2012-05-04 22:40:33 UTC
Created attachment 61065 [details]
intel_reg_dumper output
Comment 3 Daniel Vetter 2012-05-05 05:35:24 UTC
Just to double check: With e646d57 you get a black screen and with the commit right before that (i.e. 7a39a9d4767e8d22) everything works smoothly? Also please boot with drm.debug=0xe added to your kernel cmdline on both a broken and a working kernel (preferrable the two sha1 versions mentioned above) and attach the complete dmesg for both runs.
Comment 4 Julian Simioni 2012-05-06 02:51:58 UTC
Created attachment 61088 [details]
working dmesg output from 7a39a9d
Comment 5 Julian Simioni 2012-05-06 02:53:04 UTC
Created attachment 61089 [details]
broken dmesg output from e646d57
Comment 6 Julian Simioni 2012-05-06 02:56:41 UTC
Created attachment 61090 [details]
kernel config (same for both broken and working)
Comment 7 Julian Simioni 2012-05-06 02:58:44 UTC
That's correct, 7a39a9d works great, e646d57 black screens. (Of course I didn't get lucky, i had to bisect :P ). Dmesg output attached as requested
Comment 8 Daniel Vetter 2012-05-07 05:51:36 UTC
Shot in the dark: Can you try the linked patch on top of drm-intel-next-queued?

https://bugs.freedesktop.org/attachment.cgi?id=60102
Comment 9 Julian Simioni 2012-05-08 01:34:23 UTC
Created attachment 61203 [details]
dmesg output booting with edp-power-sequencing-fix.patch
Comment 10 Julian Simioni 2012-05-08 01:34:50 UTC
Created attachment 61204 [details]
intel_reg_dumper output booting with edp-power-sequencing-fix.patch
Comment 11 Julian Simioni 2012-05-08 01:36:12 UTC
No dice unfortunately. Dmesg and intel_reg_dumper output attached.
Comment 12 Daniel Vetter 2012-05-10 04:22:06 UTC
Created attachment 61350 [details] [review]
don't return -ENXIO

Patch for you to try.
Comment 13 Julian Simioni 2012-05-13 03:20:31 UTC
The latest patch works when applied on aa104eb! Thanks!
Comment 14 Daniel Vetter 2012-05-20 11:25:34 UTC
Created attachment 61885 [details] [review]
improved patch after review

Daniel Kurtz suggested a slightly alternative approach to fix this bug. Please test this new patch and check whether things still work out for you. Thanks.
Comment 15 Julian Simioni 2012-05-21 10:50:24 UTC
The new patch works great too.
Comment 16 Daniel Vetter 2012-05-21 12:06:41 UTC
Patch merged to -fixes:

commit 65e818660275ecda3702a4245f308923e3813a85
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Mon May 21 20:19:48 2012 +0200

    drm/i915: be more careful when returning -ENXIO in gmbus transfer

Thanks for reporting this bug!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.