Bug 4976 - X won't allow log in for ONE user
Summary: X won't allow log in for ONE user
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xorg (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
Depends on:
Reported: 2005-11-06 11:59 UTC by Denver D. Robinson
Modified: 2006-05-21 01:58 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Description Denver D. Robinson 2005-11-06 11:59:06 UTC
SUSE 9.3 pro (x86-64) updated to a few days ago
running on a ASRock K(Upgrade-760GX MB with a AMD Athlon 64/

was working as user 'dd' in gnome session with K3b (CD/DVD burner) couldn't get
it to do what i wanted as 'dd' so i opened a terminal window, logged in as root
and issued k3b...which opened but there were LOTs of error messages in the
terminal...i shut down K3b...but the system was unstable, wait clock, slow
etc..flakey!! i did a warm boot and found i could not log in as 'dd' again...i
could (and can...i'm there now) log in as 'test' in a KDE session...

a friend said to try: log into a full screen console as root and issue 'init 3'
(to shut down X) then log in as 'dd' and issue 'startx' which gave this:

FATAL SERVER ERROR: Cannot move old log file ("/var/log/Xorg.0.log" to

Please consult The X. Org Foundation support at http://wiki.X.org

giving up. 
xinit: Connection refused (error 111): unable to connect to X Server
xinit: No such process (error 3): Server error
---end quote---

BUT, not so fast: i got exactly the same error when trying to launch X in (from
the same text terminal) as 'test' [and, do NOT forget that i am currently logged
in as 'test' in a full X/KDE session--and, you can see that works..]

so...i moved the /var/log/Xorg.0.log.old to /var/log/Xorg.0.log.old.BAK so, for
sure it should be able to do what it said it couldn't do..

and tried it again as 'dd' and got the same error again..
and tried it as 'test' and got the same error again..

and did another "shutdown -r now", got the familiar (gui) login screen and tried
'dd' (no workie) then logged in (no problem) as 'test'--which still works, as
i'm now using it..

it SEEMS to me that everything having to do with the system IS working (kinda)
or i wouldn't be able to log into X as 'test'

BUT, do not forget that i get that same error from a console terminal when
trying either 'dd' or 'test'

ps: sorry, i do not know how to determine either the "version" or the
"component"; however, /etc/X11/xinit/xinitrc is dated May 31 00:38 and
/etc/X11/server/SecurityPolicy is dated May 31 00:32

i'm willing to help, even if i don't know the version or component--i guessed!!
(and, suggest there be a link on this page to help me know how to find what they

Comment 1 Denver D. Robinson 2005-11-07 01:06:33 UTC
turns out the *reason* for the "FATAL SERVER ERROR: Cannot move old log file
("/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old")"

was found in /home/dd/.xsession-errors which said (among other things):

"** (gnome-session:7354): WARNING **:Unable to read ICE authority file:

that file could not be read because it was owned by root (apparently, somehow
launching K3b as root [and maybe K3b puking] CHANGED the ownership of
/home/dd/.ICEauthority--very UNnice of it..)

chown fixed it, and all is well..

is it still a bug? and is it a K3b bug...or a K3b but IF running in gnome and a
STUPID user who tries to lauch it in a windowed console as root? you folks have
to decide...i'm just a simple user who REFUSES to go to the dark side (went from
win3.1 to Warp 30, 4.0, eCS, redhat . . . . suse)

my thanks to all of you programmers/hackers!!


Comment 2 Erik Andren 2006-05-21 18:58:17 UTC
I don't think this is a bug with xorg. Closing. 

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.