Bug 49779 - Extra line segments in GL_LINE_LOOP
Summary: Extra line segments in GL_LINE_LOOP
Status: RESOLVED DUPLICATE of bug 81174
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) All
: low normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-11 00:33 UTC by Homer Hsing
Modified: 2015-10-17 16:14 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
code for reproducing the bug (2.16 KB, application/octet-stream)
2012-05-11 00:33 UTC, Homer Hsing
Details
wrong.png (20.86 KB, image/png)
2012-05-11 00:34 UTC, Homer Hsing
Details
correct.png (40.65 KB, image/png)
2012-05-11 00:35 UTC, Homer Hsing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Homer Hsing 2012-05-11 00:33:00 UTC
Created attachment 61421 [details]
code for reproducing the bug

Description:
If we draw a GL_LINE_LOOP, we will see an extra line on it. See attached "wrong.png".

System environment:
Ubuntu 12.04 64-bit
newest MESA code from git

How to reproduce:
compile attached "bug.cpp"
g++ bug.cpp -lglut -lGL

What should be the correct output:
See attached "correct.png"
Comment 1 Homer Hsing 2012-05-11 00:34:21 UTC
Created attachment 61422 [details]
wrong.png
Comment 2 Homer Hsing 2012-05-11 00:35:13 UTC
Created attachment 61423 [details]
correct.png
Comment 3 Charlie 2013-01-05 13:41:00 UTC
I can confirm the same issue with llvmpipe 9.0.1 on Windows 7 / 64. Although it only flickers from time to time, either in the circle's color, or in black.
Comment 4 Eric Anholt 2013-02-06 22:21:14 UTC
WIP piglit test at anongit://people.freedesktop.org/~anholt/piglit lineloop-many that doesn't reproduce the problem

There are pretty obvious bugs to be had in the vbo module with many verts of lineloops overflowing internal buffers using Begin/End.  Of course, nobody should be using Begin/End today.
Comment 5 Brian Paul 2015-10-17 16:14:09 UTC
Same as bug 81174.

*** This bug has been marked as a duplicate of bug 81174 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.