Bug 50175 - [regression kernel 3.4] : nouveau detects internal laptop display as "disconnected" / screen is turned off
[regression kernel 3.4] : nouveau detects internal laptop display as "disconn...
Status: RESOLVED NOTOURBUG
Product: xorg
Classification: Unclassified
Component: Driver/nouveau
unspecified
x86-64 (AMD64) Linux (All)
: medium major
Assigned To: Nouveau Project
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 07:20 UTC by mus.svz
Modified: 2012-06-24 14:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (56.99 KB, text/plain)
2012-05-21 07:20 UTC, mus.svz
no flags Details
output of "lspci -vv" (45.16 KB, text/plain)
2012-05-21 07:21 UTC, mus.svz
no flags Details
xrandr output (699 bytes, text/plain)
2012-05-21 07:22 UTC, mus.svz
no flags Details
Xorg.0.log (42.59 KB, text/plain)
2012-06-08 07:00 UTC, mus.svz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mus.svz 2012-05-21 07:20:30 UTC
Created attachment 61914 [details]
dmesg output

After upgrading from kernel 3.3.6 to 3.4.0 the internal display of my laptop turns off as soon as the nouveau driver / KMS is loaded. xrandr detects the LVDS-1 connection as "disconnected" while my external HDMI display works fine. Downgrading back to 3.3.6 fixes the problem.

Note that this is NOT an Optimus laptop, the integrated Intel graphic chip is disabled.

Sony Vaio S (VPCS11C5E)
NVIDIA GeForce 310M
Intel Core i5 M520
Arch Linux x64 (testing)

Although I assume this is irrelevant since this is obviously not an X problem:
xorg-server 1.12.1.902
xf86-video-nouveau 0.0.16_git20120512
libdrm 2.4.33
libdrm-nouveau 2.4.34
nouveau-dri 8.0.3

output of dmesg, lspci and xrandr are attached.
Comment 1 mus.svz 2012-05-21 07:21:51 UTC
Created attachment 61915 [details]
output of "lspci -vv"
Comment 2 mus.svz 2012-05-21 07:22:12 UTC
Created attachment 61916 [details]
xrandr output
Comment 3 mus.svz 2012-06-08 06:32:27 UTC
same problem in 3.5-rc1. any more info I can provide?
Comment 4 Maarten Lankhorst 2012-06-08 06:51:41 UTC
Xorg log perhaps :)
Comment 5 mus.svz 2012-06-08 07:00:30 UTC
Created attachment 62795 [details]
Xorg.0.log

this is with xorg-server 1.12.2 / kernel 3.4.1
Comment 6 Karol Babioch 2012-06-15 10:35:10 UTC
I'm also affected by this issue. Early during boot (probably when nouveau gets loaded) my screen gets blank/black. Observed this with both, Arch Linux and Fedora, both running on 3.4.

Serious regression, as I can remember the same kind of issue with kernels prior to 2.6.38.
Comment 7 Karol Babioch 2012-06-15 10:38:28 UTC
Just forgot to mention: I've also got a Sony VAIO (VPCS12C5E) with a dedicated NVIDIA GeForce graphics card (310M). So probably it is something specific to Sony.
I'm happy to provide logs of any sort, if needed. Just let me know.

However I don't think that it has something to do with X, because it goes black/blank during early boot, just before any X related stuff is started.
Comment 8 WorMzy Tykashi 2012-06-16 13:21:14 UTC
Similar problem here, but not on a Sony laptop.

Booting with nomodeset appears to be the only way of successfully booting, but then prevents the starting of X due to "No screens found". Without nomodeset, screen goes into power savings mode (no video output), and boot does not appear to complete (at least, I can't ssh into the affected PC).

I don't think this is a hardware-specific problem, but here's a list of my PC's hardware, just in case:

Mobo: ASUS P8Z77-V PRO
Processor: Intel Core i5-3570K 3.4GHz
GFX: nVidia GeForce GTX 560 Ti
Comment 9 Rikhard 2012-06-17 04:22:52 UTC
Same problem here with kernel 3.4.x on Aptosid when the nouveau driver is loading. Kernel 3.3.6 works all right.
I have a Nvidia Geforce 8800 GTS 512 graphic card.
Comment 10 Karol Babioch 2012-06-19 06:25:40 UTC
There seems to be a working patch over at the kernel.org bug tracker (see [1]). Interestingly enough I was pointed at it while trying to fix another issue, so I was quite surprised that it fixes this one.

Maybe someone else could try it in order to confirm it.

[1] https://bugzilla.kernel.org/attachment.cgi?id=73576
Comment 11 mus.svz 2012-06-19 07:16:08 UTC
I applied the patch against 3.4.2 and I can confirm that it fixes it, thanks!
Comment 12 black_painkiller 2012-06-19 13:56:01 UTC
It works on my vaio cw with kernel 3.5rc3 and fixes my bug https://bugzilla.kernel.org/show_bug.cgi?id=43231

thanks!
Comment 13 Emil Velikov 2012-06-19 14:02:16 UTC
Duplicate of https://bugzilla.kernel.org/show_bug.cgi?id=43168
Comment 14 Emil Velikov 2012-06-24 14:53:56 UTC
Just to clarify - this is an ACPI issue and nouveau is the victim of it