Bug 5037 - r300 driver misrenders celestia textures
r300 driver misrenders celestia textures
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300
git
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
:
: 5421 6311 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 09:16 UTC by Dag Bakke
Modified: 2009-08-24 12:23 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Celestia starting point with indirect rendering (20.32 KB, image/jpeg)
2005-11-14 09:17 UTC, Dag Bakke
Details
Celestia starting point with r300 direct rendering (35.94 KB, image/jpeg)
2005-11-14 09:18 UTC, Dag Bakke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dag Bakke 2005-11-14 09:16:32 UTC
The r300 driver misrenders celestia textures. On startup Celestia shows a pretty
blue marble (Earth) as the starting point. With r300 direct rendering, earth
comes up in some weirdo sci-fi dressing. I'll try to attach screenshots to this bug.
Comment 1 Dag Bakke 2005-11-14 09:17:36 UTC
Created attachment 3791 [details]
Celestia starting point with indirect rendering
Comment 2 Dag Bakke 2005-11-14 09:18:27 UTC
Created attachment 3792 [details]
Celestia starting point with r300 direct rendering
Comment 3 Aapo Tahkola 2005-11-19 04:51:17 UTC
Apparently Keith has already fixed this.
Comment 4 Dag Bakke 2005-12-07 19:20:50 UTC
Verified. For the benefit of others: it works for me with:
Xorg 7.0-rc3 (built with Mesa 6.4.1 headers)
Mesa cvs (as of Dec 6 2005 19:30 CET)
Radeon drm kernel bits version 1.20.0 from drm cvs (Dec 7 2005 08:40 CET)

No extensive testing yet, but initial textures look great in celestia.
Comment 5 Dag Bakke 2005-12-26 09:56:19 UTC
*** Bug 5421 has been marked as a duplicate of this bug. ***
Comment 6 Aapo Tahkola 2006-03-20 01:36:10 UTC
*** Bug 6311 has been marked as a duplicate of this bug. ***
Comment 7 ajax at nwnk dot net 2009-08-24 12:23:35 UTC
Mass version move, cvs -> git