Bug 50995 - poppler-glib/cairo does not antialias text in some PDFs, while okular does
Summary: poppler-glib/cairo does not antialias text in some PDFs, while okular does
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-12 01:04 UTC by Fabian Henze
Modified: 2018-08-21 11:03 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
the problematic PDF (shortened. used to be 15MB in size) (575.11 KB, application/octet-stream)
2012-06-12 01:08 UTC, Fabian Henze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Henze 2012-06-12 01:04:02 UTC
Hi,
I have found a PDF file, which looks horrible when rendered with poppler-glib or pdftocairo. It does render (mostly) fine in okular, so I guess it's either specific to poppler-glib or the cairo backend.

You can reproduce that bug with:
pdftocairo -png -r 90 -f 15 -l 20 exphy.pdf
or with Evince.

I am using archlinux with poppler 0.20.0 and cairo 1.12.2, but it also happens on a gentoo system with 0.18.4 and 1.10.2.

Best regards,
Fabian Henze

P.S.: I also experiences crashes when rendering this PDF file to a cairo PDFSurface, but only if I would use poppler_page_render() instead of render_for_printing().
Comment 1 Fabian Henze 2012-06-12 01:08:58 UTC
Created attachment 62919 [details]
the problematic PDF (shortened. used to be 15MB in size)
Comment 2 Dmitri Chubarov 2015-07-07 13:15:10 UTC
The problem is with rendering bitmap fonts (e.g. TeX Type 3 fonts), or embedded black and white images, such as scanned images. Some 5 years ago there was a discussion of this on Ubuntu launchpad with a few examples that are still displayed without antialiasing in poppler/cairo even using poppler 0.26.5.

https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/248355/comments/52
Comment 3 GitLab Migration User 2018-08-21 11:03:29 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/487.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.