Bug 51137 - [mach64] Use correct pixmap memory locations for UTS / DFS
[mach64] Use correct pixmap memory locations for UTS / DFS
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/mach64
git
All All
: medium major
Assigned To: Xorg Project Team
Xorg Project Team
:
Depends on:
Blocks: 44354
  Show dependency treegraph
 
Reported: 2012-06-15 17:30 UTC by Connor Behan
Modified: 2012-12-17 07:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Untested patch (2.05 KB, patch)
2012-06-15 17:34 UTC, Connor Behan
no flags Details | Splinter Review
Git patch removing the hooks (2.79 KB, patch)
2012-12-07 21:54 UTC, Connor Behan
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Connor Behan 2012-06-15 17:30:39 UTC
Somewhere along the line, pPix->devPrivate.ptr stopped being the recommended way to address a pixmap in EXA. It is usually NULL these days and drivers that refer to it will probably crash. This fixes the mach64 driver's hooks for UploadToScreen and DownloadFromScreen.
Comment 1 Connor Behan 2012-06-15 17:34:56 UTC
Created attachment 63094 [details] [review]
Untested patch
Comment 2 Michel Dänzer 2012-11-19 11:09:40 UTC
Is there any point in keeping those hooks? Looks like they just do the same thing EXA does when the hooks are missing.
Comment 3 Connor Behan 2012-11-20 08:04:24 UTC
Yeah, it's probably best to remove them. The "real" hooks are in bug 8414 but committing that is a longer term goal.
Comment 4 Matthieu Herrb 2012-11-21 10:54:10 UTC
Comment on attachment 63094 [details] [review]
Untested patch

Review of attachment 63094 [details] [review]:
-----------------------------------------------------------------

Confirmed as working with xserver 1.13 on 2 machines here, running OpenBSD/amd64 and OpenBSD/mach64 respectively.
Comment 5 Connor Behan 2012-12-07 21:54:56 UTC
Created attachment 71163 [details] [review]
Git patch removing the hooks
Comment 6 Connor Behan 2012-12-17 07:25:17 UTC
Fixed by xf86-video-mach64 commit ece8d3557eb1ffb27104bffb7841503aae4dcd6f.