Bug 5115 - Drivers for ATI cards segfault with no on-card memory reserved for textures
Drivers for ATI cards segfault with no on-card memory reserved for textures
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R100
git
Other Linux (All)
: high normal
Assigned To: Default DRI bug account
:
: 930 (view as bug list)
Depends on:
Blocks: 1690
  Show dependency treegraph
 
Reported: 2005-11-22 01:03 UTC by Michel Dänzer
Modified: 2009-08-24 12:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Proposed fix (3.23 KB, patch)
2005-11-22 01:04 UTC, Michel Dänzer
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Dänzer 2005-11-22 01:03:07 UTC
There seems to be a (somewhat reasonable) assumption in the common DRI texture
management code that heap 0 is always valid. However, the DDX drivers for ATI
cards can end up reserving no on-card memory for textures under some
circumstances, in which case heap 0 will end up being invalid, resulting in a
segfault. I'll attach a patch which avoids the segfault by setting up heap 0 for
the GART texture area in that case.
Comment 1 Michel Dänzer 2005-11-22 01:04:11 UTC
Created attachment 3863 [details] [review]
Proposed fix
Comment 2 Michel Dänzer 2005-11-30 00:51:31 UTC
Fixed in Mesa CVS trunk and 6.4 branch.
Comment 3 Michel Dänzer 2005-12-01 03:39:23 UTC
*** Bug 930 has been marked as a duplicate of this bug. ***
Comment 4 ajax at nwnk dot net 2009-08-24 12:23:36 UTC
Mass version move, cvs -> git