Bug 51647 - Cursor is invisible if no default is specified
Summary: Cursor is invisible if no default is specified
Status: RESOLVED FIXED
Alias: None
Product: Wayland
Classification: Unclassified
Component: weston (show other bugs)
Version: unspecified
Hardware: All All
: medium minor
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
: 51016 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-02 02:19 UTC by Sam Saxon
Modified: 2012-10-29 17:45 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Saxon 2012-07-02 02:19:15 UTC
It appears that a "default" cursor theme must be specified in order for a mouse cursor to show.

This theme file is found here: ~/.icons/default/index.theme

This file specifies a mouse cursor theme to be used by default. However, if this file doesn't exist, there is no fallback cursor -- so the cursor remains invisible.


-------------
To replicate:
-------------

Hopefully this will replicate the issue for everyone else:

1) Temporarilly remove/rename the following file:
   ~/.icons/default/index.theme

2) Run Weston in either direct rendering mode or as an X client.


-------------
Result:
-------------

The mouse cursor should be "invisible".


-------------
Fix:
-------------

Could we set a default cursor if no others are sepcified?

-------------
Info:
-------------

The following bug could in fact be the same issue as the one I've highlighted above:

https://bugs.freedesktop.org/show_bug.cgi?id=51016


For a bit more info, this post on the Arch forums solved the "invisible cursor" bug for me (all credit for the fix goes to user Giselher).

https://bbs.archlinux.org/viewtopic.php?pid=1122238#p1122238
Comment 1 Philipp Brüschweiler 2012-08-16 10:05:44 UTC
*** Bug 51016 has been marked as a duplicate of this bug. ***
Comment 2 Kristian Høgsberg 2012-10-29 17:45:29 UTC
The wayland-cursor library now has a built-in default cursor set.  This issues is fixed, closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.