Bug 5185 - Most full screen apps crash on exit
Summary: Most full screen apps crash on exit
Status: RESOLVED DUPLICATE of bug 5131
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 6.4
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: mesa-dev
QA Contact:
URL: http://bugs.gentoo.org/show_bug.cgi?i...
Depends on:
Reported: 2005-11-28 11:56 UTC by James Le Cuirot
Modified: 2005-11-30 08:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

xorg.conf (4.89 KB, text/plain)
2005-11-28 11:57 UTC, James Le Cuirot
Xorg.0.log (46.21 KB, text/plain)
2005-11-28 11:58 UTC, James Le Cuirot

Description James Le Cuirot 2005-11-28 11:56:40 UTC
As written in the Gentoo bug report...


Most full screen apps (i.e games) are crashing on exit in modular X. Neverball 
and Trackballs both exit with "*** glibc detected *** free(): invalid pointer" 
and fail to set the resolution back. Unreal Tournament and Return To Castle 
Wolfenstein appear to crash the X server. xscreensaver is okay though. I tried 
setting the resolution of Trackballs to be the same as my desktop but the crash 
still occurs. I also tried recompiling Neverball.

I have an ATI Radeon 345M IGP. I've had random crashing problems with the DRI 
module for months now (only just found out roughly what it is) but I think this 
is a separate issue.


One of the Gentoo guys reproduced this on his 855GM. Disabling RENDER 
acceleration does nothing. These programs worked fine on 6.8.2.
Comment 1 James Le Cuirot 2005-11-28 11:57:27 UTC
Created attachment 3925 [details]
Comment 2 James Le Cuirot 2005-11-28 11:58:31 UTC
Created attachment 3926 [details]
Comment 3 Michel Dänzer 2005-11-28 19:45:15 UTC
We need backtraces for the crashes.

As for the DRI instabilities, see if not changing the default AGP settings makes
a difference.
Comment 4 James Le Cuirot 2005-11-29 03:55:34 UTC
I recompiled Neverball and Trackballs with -g3 and ran them through gdb but all 
I got was this, which doesn't tell you very much, does it?

0xffffe410 in __kernel_vsyscall

Do I need to recompile Xorg or SDL or something else with debug symbols? Sorry, 
I can code but debugging is something I was never really taught properly.

Thanks for the DRI tip, will try that soon.
Comment 5 James Le Cuirot 2005-11-29 04:50:58 UTC
Ah sorry, ignore all that, I was being stupid. Here's the backtrace from 

#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb7af0d1d in raise () from /lib/tls/libc.so.6
#2  0xb7af2333 in abort () from /lib/tls/libc.so.6
#3  0xb7b23b52 in __fsetlocking () from /lib/tls/libc.so.6
#4  0xb7b29497 in malloc_usable_size () from /lib/tls/libc.so.6
#5  0xb7b29e9b in free () from /lib/tls/libc.so.6
#6  0xb74b65c1 in _tnl_free_vertices ()
   from /usr/lib/xorg/modules/dri/radeon_dri.so
#7  0xb73fd9a1 in radeonDestroyContext ()
   from /usr/lib/xorg/modules/dri/radeon_dri.so
#8  0xb73fa2a6 in __driUtilUpdateDrawableInfo ()
   from /usr/lib/xorg/modules/dri/radeon_dri.so
#9  0xb7d7c1bb in __glXFreeContext ()
   from //usr/lib/opengl/xorg-x11/lib/libGL.so.1
#10 0xb7cef833 in X11_GL_Shutdown (this=0x0) at SDL_x11gl.c:242
#11 0xb7ceda97 in X11_DestroyWindow (this=0x810dcf0, screen=0x8112900)
    at SDL_x11video.c:476
#12 0xb7cef43f in X11_VideoQuit (this=0x8108f00) at SDL_x11video.c:1233
#13 0xb7ce5f03 in SDL_VideoQuit () at SDL_video.c:1330
#14 0xb7cbda38 in SDL_QuitSubSystem (flags=32) at SDL.c:206
#15 0xb7cbdadf in SDL_Quit () at SDL.c:223
#16 0xb7af35a7 in exit () from /lib/tls/libc.so.6
#17 0x0806eb9c in MenuMode::doSelection (this=0x8500160) at menuMode.cc:127
Comment 6 James Le Cuirot 2005-11-29 05:44:18 UTC
I just recompiled Mesa with debug symbols as well. This might tell you a bit 

#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb7c0ed1d in raise () from /lib/tls/libc.so.6
#2  0xb7c10333 in abort () from /lib/tls/libc.so.6
#3  0xb7c41b52 in __fsetlocking () from /lib/tls/libc.so.6
#4  0xb7c47497 in malloc_usable_size () from /lib/tls/libc.so.6
#5  0xb7c47e9b in free () from /lib/tls/libc.so.6
#6  0xb6e0a5c1 in _tnl_free_vertices (ctx=0x0) at t_vertex.c:497
#7  0xb6d519a1 in radeonDestroyContext (driContextPriv=0x8133301)
    at radeon_context.c:499
#8  0xb6d4e2a6 in driDestroyContext (dpy=0x8089070, scrn=0,
    contextPrivate=0x8133330) at dri_util.c:703
#9  0xb7d461bb in DestroyContext (dpy=0x8089070, gc=0x812e478) at glxcmds.c:472
#10 0xb7eaf833 in X11_GL_Shutdown (this=0x8084008) at SDL_x11gl.c:242
#11 0xb7eada97 in X11_DestroyWindow (this=0x8084008, screen=0x808df88)
    at SDL_x11video.c:476
#12 0xb7eaf43f in X11_VideoQuit (this=0x8084008) at SDL_x11video.c:1233
#13 0xb7ea5f03 in SDL_VideoQuit () at SDL_video.c:1330
#14 0xb7e7da38 in SDL_QuitSubSystem (flags=32) at SDL.c:206
#15 0xb7e7dadf in SDL_Quit () at SDL.c:223
#16 0x08065743 in main (argc=1, argv=0x27cc) at main.c:289
Comment 7 Michel Dänzer 2005-11-29 21:54:02 UTC
Changing product as this seems to be a Mesa issue. If you have backtraces for
the X server crashes as well, please attach them to another bug.
Comment 8 Michel Dänzer 2005-11-30 00:26:07 UTC
Actually, this looks like a duplicate of bug 5185, which has been fixed in Mesa
CVS. Please attach backtraces for the X server crashes (and change the
product/component fields back) or resolve as duplicate.
Comment 9 James Le Cuirot 2005-11-30 03:14:41 UTC
Mesa CVS fixed everything, thanks a lot. But I don't know which bug this is a 
duplicate of because you gave the ID for this bug.
Comment 10 Michel Dänzer 2005-12-01 03:47:24 UTC
(In reply to comment #9)
> Mesa CVS fixed everything, thanks a lot. But I don't know which bug this is a 
> duplicate of because you gave the ID for this bug.

Whoops, thanks for verifying this!

*** This bug has been marked as a duplicate of 5131 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.