Bug 5201 - X with i810 driver does not draw window contents on screen, hijacks display.
Summary: X with i810 driver does not draw window contents on screen, hijacks display.
Status: RESOLVED DUPLICATE of bug 5443
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: (7.0 RC2)
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Alan Hourihane
QA Contact:
: 5685 (view as bug list)
Depends on:
Reported: 2005-11-30 21:34 UTC by Chandra
Modified: 2006-01-22 13:38 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:

failure log (1.71 MB, text/plain)
2005-11-30 21:42 UTC, Chandra
no flags Details
my xorg.conf (1.33 KB, text/plain)
2005-11-30 21:46 UTC, Chandra
no flags Details
martin's xorg.0.log log (94.72 KB, text/plain)
2005-12-31 02:16 UTC, Martin Schwier
no flags Details

Description Chandra 2005-11-30 21:34:39 UTC
I am experiencing MASSIVE display brokenness using i810-1.4.1/xorg 7.0-rc2 with
the 915GM chipset. Application windows simply do not display -- with
enlightenment I get empty window frames which disappear if I drag them about the
screen, and with twm I get nothing (tho xclock does display on startup).
Further, when I terminate X or attempt to switch consoles, the last thing drawn
by X persists on the screen and I can't see what I'm typing. The system does
remain responsive, and I can blindly switch to a console and reboot, or do it
via SSH, but it seems unable to draw anything on the screen once X has gotten at
it. Rebooting the machine restores the display, though unloading and loading the
kernel display drivers does not.

This appears to be driver-specific -- when I fall back to the vesa driver, X
displays things just fine, and yields control of the display when appropriate.
Comment 1 Alan Hourihane 2005-11-30 21:42:27 UTC
Something sounds very broken for this to happen.

Have you got a logfile ?
Comment 2 Chandra 2005-11-30 21:42:45 UTC
Created attachment 3952 [details]
failure log

This is a log of the (noisy) failure of the driver. Only on about half the runs
do I actually get the "QWord boundary" error message, but the failure to draw
things on the screen is consistent.
Comment 3 Chandra 2005-11-30 21:46:22 UTC
Created attachment 3953 [details]
my xorg.conf

You'll notice I've tried a few things to try to pacify the driver. I've tried
with glx and dri either explicitly loaded or commented out, and I tried
knocking down the resolution to something friendly. None of that accomplished
Comment 4 Alan Hourihane 2005-11-30 21:55:52 UTC
If you look furthur at the top of the log you'll see INVALID MEM ALLOCATION.

I suspect this is the problem.

Who makes this machine and can you see if there is a later BIOS for your hardware ?
Comment 5 Chandra 2005-11-30 22:16:53 UTC
(In reply to comment #4)
> If you look furthur at the top of the log you'll see INVALID MEM ALLOCATION.
> I suspect this is the problem.
> Who makes this machine and can you see if there is a later BIOS for your
hardware ?

The machine is a custom notebook from unitedmicro.com -- it's all Intel
components, stuck together in an unbranded case. (It's the N259EI on their site,
if you care to take a look.) Intel's site says to see the manufacturer for BIOS
upgrades, and unitedmicro.com has nothing worthwhile to say at all, so I'll try
to take it up with their tech support people in the morning. I'll keep you posted.
Comment 6 Alan Hourihane 2005-11-30 22:24:19 UTC
The alternative fix is to fix the Xserver source code.

Find the file xf86Bus.c and comment out the function call to ValidatePci().

Rebuild the Xorg server and try again.
Comment 7 Martin Schwier 2005-12-31 02:16:16 UTC
Created attachment 4201 [details]
martin's xorg.0.log log

i have exactly the same problem with the intel 855GM graphics chip in my
notebook. The screen is corrupted, the mouse cursor isn't displayed and my
keyboard doesn't work. If i kill the X server over an ssh session the screen
holds it contens and doesn't switch back to the virtual console.

I attached the Xorg.0.log. Notice the reapting error messages at the end, like:

"ADVANCE_LP_RING: outring (0x1c37) isn't on a QWord boundary(WW) I810(0):
Fixing display offsets."

I think the BIOS of my notebook doesn't offer the correct native video mode
(1280x800), because with X11R6.8 (which worked great with i810) i had to use
the 855resolution tool to reprogram the vbios so that it supports that mode. A
newer BIOS isn't available. My Notebook is a Cebop MEX 100 and it's identical
in construction with the Uniwill 223II0
(http://www.uniwill.com/products/mobility/223ii0/223ii0.php?HL=3&M=3). I dead
it runs with the latest uniwill bios, because cebop doesn't provide bios
Comment 8 Alan Hourihane 2006-01-10 08:55:48 UTC
If you don't load agpgart and intel-agp - does the problem still happen ??
Comment 9 Martin Schwier 2006-01-16 09:04:48 UTC
For me - yes.
Comment 10 Alan Hourihane 2006-01-16 10:05:04 UTC
Can you upload a log without them loaded ?
Comment 11 Alan Hourihane 2006-01-16 22:36:23 UTC
Martin - you need to rebuild X with the ValidatePci() command commented out as I
said in comment #6.
Comment 12 Alan Hourihane 2006-01-16 22:38:23 UTC
*** Bug 5443 has been marked as a duplicate of this bug. ***
Comment 13 Alan Hourihane 2006-01-16 22:44:23 UTC
Martin - are you running 2.6.15 kernel ??

Did you run an older kernel previously ?
Comment 14 Alan Hourihane 2006-01-19 21:47:32 UTC

*** This bug has been marked as a duplicate of 5443 ***
Comment 15 Martin Schwier 2006-01-23 00:53:24 UTC
Alan, i'm now using Kernel and commented out the ValidatePci() function
call. Everything works smooth now (incl. dri/glx with i915) and there are no
more error messages in the logfile except: 

(WW) I810(0): Bad V_BIOS checksum
(WW) I810(0): Extended BIOS function 0x5f05 failed.

I'm running the 1280x800 resolution without the 855resolution tool.
Comment 16 Alan Hourihane 2006-01-23 08:38:11 UTC
*** Bug 5685 has been marked as a duplicate of this bug. ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.