Bug 52357 - udisks-1.9* fails to mount CD drive if it wasn't mounted before
udisks-1.9* fails to mount CD drive if it wasn't mounted before
Status: RESOLVED NOTOURBUG
Product: udisks
Classification: Unclassified
Component: detection
unspecified
Other All
: medium normal
Assigned To: David Zeuthen (not reading bugmail)
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 10:50 UTC by Pacho Ramos
Modified: 2012-07-29 10:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
udisksctl dump (27.34 KB, text/plain)
2012-07-22 16:22 UTC, Pacho Ramos
Details
udevadm output (130.16 KB, text/plain)
2012-07-22 16:23 UTC, Pacho Ramos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos 2012-07-22 10:50:40 UTC
This can be reproduced on my system every time simply from console:
1. Poweroff system
2. Poweron WITHOUT any CD device inserted (if it's inserted while booting it will be properly detected and mounted)
3. Insert CD
4. Run "udisksctl mount -b /dev/sr0", I get:

$ udisksctl mount -b /dev/sr0
Object /org/freedesktop/UDisks2/block_devices/sr0 is not a mountable filesystem.

5. Log in as root and manually run:

# mount /dev/sr0 /mnt/backups/
mount: warning: /mnt/backups/ seems to be mounted read-only.

6. Umount it
7. Now udisksctl works ok:

 udisksctl mount -b /dev/sr0
Mounted /dev/sr0 at /run/media/pacho/Gentoo Linux amd64 20120223.

On the other hand, old udisks command always work ok:
$ udisks --mount /dev/sr0
Mounted /org/freedesktop/UDisks/devices/sr0 at /media/disk

I can even use old "udisks" command to mount it first time (instead of "mount") and udisksctl will work properly after that. Then, the problem looks to be in recognizing my device properly first time, while udisks1 looks to detect it ok
Comment 1 Pacho Ramos 2012-07-22 11:13:34 UTC
With udevil I get it failing on first run and ok on second:

$ udevil mount /dev/sr0
udevil: error: no media in device /dev/sr0 (or specify type with -t)
$ udevil mount /dev/sr0
Mounted /dev/sr0 at /media/Gentoo Linux amd64 2

But, anyway, even running it only first time (and, then, getting the failure), if I run udisksctl just after that, it's properly mounted :O
Comment 2 David Zeuthen (not reading bugmail) 2012-07-22 15:40:33 UTC
I don't think it's a problem with udisks - please attach the output of 

 udisksctl dump
 udevadm info --export-db
 (run both commands as root)

My guess is that your OS boot-up scripts simply does not initialize the udev database correctly. The output of those two commands will tell for sure. What OS are you using?

(In the future please read http://www.freedesktop.org/wiki/Software/udisks for what information to attach.)
Comment 3 Pacho Ramos 2012-07-22 16:22:47 UTC
Created attachment 64503 [details]
udisksctl dump
Comment 4 Pacho Ramos 2012-07-22 16:23:07 UTC
Created attachment 64504 [details]
udevadm output
Comment 5 Pacho Ramos 2012-07-22 16:23:23 UTC
I am running Gentoo Linux, thanks
Comment 6 David Zeuthen (not reading bugmail) 2012-07-23 04:05:08 UTC
(In reply to comment #4)
> Created attachment 64504 [details]
> udevadm output

Yeah, your udev initialization script seems busted since there is no ID_FS* properties for sr0. Not an udisks bug.
Comment 7 Pacho Ramos 2012-07-29 09:53:03 UTC
(In reply to comment #6)
> (In reply to comment #4)
> > Created attachment 64504 [details]
> > udevadm output
> 
> Yeah, your udev initialization script seems busted since there is no ID_FS*
> properties for sr0. Not an udisks bug.

Do you have any idea about what could be wrong when starting udev?
Comment 8 Pacho Ramos 2012-07-29 10:34:18 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #4)
> > > Created attachment 64504 [details]
> > > udevadm output
> > 
> > Yeah, your udev initialization script seems busted since there is no ID_FS*
> > properties for sr0. Not an udisks bug.
> 
> Do you have any idea about what could be wrong when starting udev?

Could that properties being missing because I don't have kernel polling enabled? (due udev-171 being used)