Bug 52493 - MateDesktop desktopfile error
Summary: MateDesktop desktopfile error
Status: RESOLVED NOTABUG
Alias: None
Product: desktop-file-utils
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: All other
: highest critical
Assignee: Hans Petter Jansson
QA Contact:
URL:
Whiteboard:
Keywords:
: 52491 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-25 16:06 UTC by Wolfgang Ulbrich
Modified: 2016-05-12 07:21 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Ulbrich 2012-07-25 16:06:42 UTC
I'm building Mate-Desktop rpms for fedora.
A check with rpmlint gives following error.

[rave@mother ~]$ rpmlint /var/lib/mock/fedora-16-x86_64/mate-desktop-1.4.1-5.fc16.x86_64.rpm
mate-desktop.x86_64: W: spelling-error %description -l en_US libmatedesktop -> desktop
mate-desktop.x86_64: E: invalid-desktopfile /usr/share/applications/mate-about.desktop value "MATE;GTK;Core;Utility;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
1 packages and 0 specfiles checked; 1 errors, 1 warnings.

ignore the warning, it's from the spec file

Is it possible to implemment MATE for the key "Categories" in desktop-file-utils?

thanks
Comment 1 Wolfgang Ulbrich 2012-07-25 16:08:22 UTC
I'm building Mate-Desktop rpms for fedora.
A check with rpmlint gives following error.

[rave@mother ~]$ rpmlint /var/lib/mock/fedora-16-x86_64/mate-desktop-1.4.1-5.fc16.x86_64.rpm
mate-desktop.x86_64: W: spelling-error %description -l en_US libmatedesktop -> desktop
mate-desktop.x86_64: E: invalid-desktopfile /usr/share/applications/mate-about.desktop value "MATE;GTK;Core;Utility;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
1 packages and 0 specfiles checked; 1 errors, 1 warnings.

ignore the warning, it's from the spec file

Is it possible to implemment MATE for the key "Categories" in desktop-file-utils?

thanks
Comment 2 Wolfgang Ulbrich 2012-07-25 16:09:07 UTC
oh, sorry for double posting
Comment 3 Wolfgang Ulbrich 2012-07-25 19:15:24 UTC
It seems to be that the issue effect more categories

mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/mate-settings-mouse.desktop value "MATE;GTK;Settings;HardwareSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/mate-network-properties.desktop value "MATE;GTK;Settings;X-MATE-NetworkSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/mate-appearance-properties.desktop value "MATE;GTK;Settings;DesktopSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/at-properties.desktop value "MATE;GTK;Settings;X-MATE-PersonalSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/display-properties.desktop value "MATE;GTK;Settings;HardwareSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/keyboard.desktop value "MATE;GTK;Settings;HardwareSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/window-properties.desktop value "MATE;GTK;Settings;DesktopSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/mate-keybinding.desktop value "MATE;GTK;Settings;X-MATE-PersonalSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/mate-theme-installer.desktop value "MATE;GTK;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/mate-theme-installer.desktop (will be fatal in the future): value "MATE;GTK;" for key "Categories" in group "Desktop Entry" does not contain a registered main category
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/matecc.desktop value "MATE;GTK;Settings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
mate-control-center.x86_64: E: invalid-desktopfile /usr/share/applications/default-applications.desktop value "MATE;GTK;Settings;X-MATE-PersonalSettings;" for key "Categories" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
Comment 4 Dominique Leuenberger 2012-07-25 20:36:02 UTC
See https://bugs.freedesktop.org/show_bug.cgi?id=44353#c2 for some comment on this already in the past.

The 'DE' as category does not really make sense.. the menu structure should put apps in corresponding folders without caring about what DE they were written for,
Comment 5 Wolfgang Ulbrich 2012-07-25 21:41:54 UTC
that means....?
we have to patch out all 'DE' as category in Mate?
Comment 6 Wolfgang Ulbrich 2012-07-25 21:45:43 UTC
of course, that make sense
Comment 7 Vincent Untz 2012-09-11 06:08:23 UTC
Like for all changes to the specs that are not typos, rephrasing, etc., this needs to be requested on the xdg mailing list. If nobody objects after one or two weeks, the change will go in.

So please request the changes on the mailing list.
Comment 8 Vincent Untz 2012-09-11 06:28:06 UTC
And let me add what I told to dan on IRC: when asking for the category to be added, please mention why it's needed. Merely saying "it's needed because otherwise we have errors in desktop-file-utils validation" is not a good rationale. A good rationale is to explain how the category is used by MATE to do something special.
Comment 9 Vincent Untz 2012-09-11 06:39:10 UTC
*** Bug 52491 has been marked as a duplicate of this bug. ***
Comment 10 thulani makhathini 2014-09-23 12:02:03 UTC
Fix all bugs and delete all permision commands
Comment 11 Vincent Untz 2015-09-18 09:50:41 UTC
Sorry for the noise, reassigning to new maintainer.
Comment 12 Hans Petter Jansson 2016-05-11 22:50:43 UTC
Hi Wolfgang, did you make any progress on this? Was it raised on the mailing list?
Comment 13 Wolfgang Ulbrich 2016-05-11 23:27:19 UTC
well, we use OnlyShowIn/NotShowIn for our packages and are happy with it.
Comment 14 Hans Petter Jansson 2016-05-12 07:21:05 UTC
Thanks, glad to hear you found a solution.

I'll close this, then.


bug/show.html.tmpl processed on May 30, 2016 at 01:06:42.
(provided by the Example extension).