Bug 52791 - raw file sync source
Summary: raw file sync source
Status: RESOLVED FIXED
Alias: None
Product: SyncEvolution
Classification: Unclassified
Component: SyncEvolution (show other bugs)
Version: unspecified
Hardware: All All
: medium enhancement
Assignee: Patrick Ohly
QA Contact:
URL:
Whiteboard:
Keywords:
: 55759 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-04-13 02:03 UTC by SyncEvolution Community
Modified: 2014-09-15 15:00 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Ohly 2012-07-29 18:36:00 UTC


---- Reported by jingke.zhang@intel.com 2010-04-13 02:03:49 +0000 ----

This is from http://bugzilla.moblin.org/show_bug.cgi?id=5046

In SyncEvolution 0.8.1 it was possible to configure syncing so that data sent
by a server was stored verbatim in one file per item. Full two-way and refresh
from client were supported.

The file sync still works, but now it passes the data through the Synthesis
engine, which translates to and from Evolution items on the local side. That
shouldn't lose information, but it would be desirable nevertheless to have a
true server backup without that transformation.

A rough idea for this is the following:
- add a "raw" profile class to libsynthesis which maps from SyncML item 
  attributes (type, content) to a very simple field list with corresponding
  fields
- in SyncEvolution, read/write the content field instead of asking for
  conversion with MAKE/PARSETEXTWITHPROFILE()



---- Additional Comments From patrick.ohly@intel.com 2010-08-24 06:19:29 +0000 ----

There is some code in "raw-sync-source" branch, but it must be revised to use the final support for this feature in libsynthesis:
http://meego.gitorious.org/meego-middleware/libsynthesis/commit/ae884ae56479e1a82ac845a26599559c37272dc1



--- Bug imported by patrick.ohly@gmx.de 2012-07-29 20:36 UTC  ---

This bug was previously known as _bug_ 688 at https://bugs.meego.com/show_bug.cgi?id=688
Comment 1 Patrick Ohly 2012-10-08 13:17:26 UTC
*** Bug 55759 has been marked as a duplicate of this bug. ***
Comment 2 Patrick Ohly 2014-09-15 15:00:51 UTC
Implemented and released in 1.4.99.4.

Use "raw/text/vcard" or "raw/text/calendar" to select storing contacts and calendar items as sent by the peer. No other formats currently have "raw" flavors, although adding them would be simple.

See 626e027d3d8, "datatypes: raw text items with minimal conversion".


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.